Issue 100336

Summary: Adding or removing slides in the outline view deletes or does not move objects
Product: Impress Reporter: jacobmj <jacob>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 3.0.1   
Target Milestone: ---   
Hardware: PC (x86_64)   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
ODP illustrating this bug none

Description jacobmj 2009-03-18 23:43:07 UTC
Here, I will describe two distinct, but related bugs when using the "Outline"
pane in OO Impress.  Both result in scrambling or deletion of objects contained
on the slide.

1) Consider a presentation that has a single slide that has a title, and then an
object drawn on it.  Using the outline view, create a new slide before this
slide.  Then delete that new slide.  Insertion of the new slide will create a
blank slide, as desired.  This portion reveals a bug only upon slide deletion.

2) Now consider a presentation with 2 slides.  The second slide has text and an
object.  Also in the outline view, create a new slide before this second slide.
 A blank slide should be inserted.  Instead, objects on the former slide 2 will
not move with the text to slide 3.  Note that deletion of slide 2 removes these
objects forever, rather than In larger presentations of N slides, all objects
end up on the N-1 slide.  This portion considers a bug only upon slide insertion.

Thanks.
~Jacob
Comment 1 jacobmj 2009-03-18 23:43:47 UTC
Created attachment 61023 [details]
ODP illustrating this bug
Comment 2 jfuller2007 2009-06-04 04:01:42 UTC
Jeff Fuller (06-03-2009)

I was able to reproduce the bug described here on a different configuration.  
Found that this bug also occurs in OOo-dev 3.2.0 DEV300m49 (Build:9403) running 
under Windows XP Pro 64-bit.

Replicated the behavior (and found something related) following these steps:

1. Create a new presentation in Impress.
2. Type some text in the title and text boxes (use any configuration with 
either or both so you can see where the text is going).
3. Insert a picture onto the first slide using Insert-->Picture-->From File... 
and choose any picture you have saved.
4. Click on the Outline tab to change to Outline view
5. Position the cursor right before the title and hit enter to insert a new 
slide.
***The next fiew steps detail what happens further if you keep inserting 
slides***
  5.1. Hit enter again as many times as you like and only the text will keep 
moving to the next slide.  The picture object will stay on the second slide.
  5.2. Hit backspace and you will see the text move back up until it is again 
on the same slide as the picture.
***Back to steps that replicated specific behavior described***
6. Hit backspace to delete the blank slide right before the "original" first 
slide.

At this point the text moves back to the first slide, but the inserted picture 
disappears.  Furthermore, if you position the cursor right after the "Slide 2" 
icon in Outline view at any point after step 5.1(above), then the picture will 
disappear then as well.

My specs are:
Intel Q6700 processor
4 GB memory
Windows XP Pro 64-bit / Windows Vista Ultimate 64-bit dual boot.


Comment 3 jfuller2007 2009-06-04 04:06:35 UTC
Jeff Fuller (06-03-20009)
**Correction to comment posted above**

In reference to position cursor right after the "Slide 2" icon, I mean that if 
you follow step 5.2 (press backspace to delete a slide), it will immediately 
delete the picture from the presentation.  Pressing backspace will also keep 
deleting slides until the text moves back up, but the picture does not come 
back.
Comment 4 wolframgarten 2009-06-04 08:28:31 UTC
Thanks for the detailed description. Reproducible. Reassigned.
Comment 5 Marcus 2017-05-20 11:08:47 UTC
Reset assigne to the default "issues@openoffice.apache.org".