Issue 101134

Summary: Excel Spreadsheet document is empty when opened via UNO
Product: Calc Reporter: holgeruhr <h.uhr>
Component: uiAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: elish, issues
Version: OOo 3.0.1Keywords: needhelp
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Example file 1
none
Example file 2 none

Description holgeruhr 2009-04-16 13:25:11 UTC
I have two MS-Excel example documents that show lots of spreadsheet tabs when I
open them by (for example) clicking on the file icon in the file browser.

However, if I start OpenOffice.org as a server process ("soffice
-accept='socket,host=0,tcpNoDelay=1,port=8100;urp'") and upload any of these
files by using an UNO connection, I can see (visually and by calling
"xSpreadsheetDocument.getSheets()") only one spreadsheet in the document, which
contains only one empty cell. In the shell where I started the server processs,
the following lines appear:

Warning: at xsl:stylesheet on line 32 of
file:///usr/lib/ooo3/basis3.0/share/xslt/import/spreadsheetml/spreadsheetml2ooo.xsl:
  Running an XSLT 1.0 stylesheet with an XSLT 2.0 processor
Warning: on line 4470 of
file:///usr/lib/ooo3/basis3.0/share/xslt/import/spreadsheetml/spreadsheetml2ooo.xsl:
  Creating an attribute here will fail if previous instructions create any children
Error
  com.sun.org.apache.xerces.internal.impl.io.MalformedByteSequenceException:
Invalid byte 2
  of 2-byte UTF-8 sequence.

(These lines don't appear when I start OpenOffice.org regularly and open the
files in the file browser.)
Comment 1 holgeruhr 2009-04-16 13:26:27 UTC
Created attachment 61607 [details]
Example file 1
Comment 2 holgeruhr 2009-04-16 13:27:15 UTC
Created attachment 61608 [details]
Example file 2