Issue 101216

Summary: ConditionalText: inverse logic for property "IsConditionTrue"
Product: Writer Reporter: eberlein <pet.ebe>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOO310m9Keywords: needmoreinfo, oooqa
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
file with fields to reproduce issue none

Description eberlein 2009-04-20 09:55:51 UTC
see attachment: msgBox should display "True" for property IsConditionTrue
Comment 1 eberlein 2009-04-20 09:56:30 UTC
Created attachment 61683 [details]
file with fields to reproduce issue
Comment 2 eric.savary 2009-04-20 10:14:48 UTC
Can you detail a little bit?
Do you see a problem inside of the Basic (scripting) routine or in the fields area?
Please use a current version. 2.2 is too old!

Else, this issue seems to be dup of issue 101215.
Comment 3 eberlein 2009-04-20 11:47:38 UTC
Problems occurs with a more recent version (300m41) too.
It has nothing to do with Basic, but with the core implementation.
See http://sw.openoffice.org/servlets/ReadMsg?list=dev&msgNo=2375

It's no dupe, it's a different property.
Comment 4 eric.savary 2009-04-20 11:53:09 UTC
@OS: as you asked the reporter to file an issue (see link to the mailing list)... ;)
Comment 5 bmarcelly 2009-04-21 09:01:05 UTC
I already have reported this bug in Issue 99996   ;-)
Comment 6 eberlein 2009-04-21 09:09:20 UTC
So yes, it's a dupe.
BTW, I wonder how this can be solved without breaking compatibility...
Comment 7 Marcus 2017-05-20 11:20:10 UTC
Reset assigne to the default "issues@openoffice.apache.org".