Issue 101386

Summary: [F-NAME] addin function doesn't work in OOo3.0 after document is closed and reopened
Product: Calc Reporter: randyjones <randy>
Component: programmingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P2 CC: issues, rainerbielefeld_ooo_qa, rb.henschel
Version: OOo 3.2 RC5Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
Files needed to reproduce this issue. See the included README for details. none

Description randyjones 2009-04-27 21:33:55 UTC
I have a calc addin created several years ago (circa 2000) using the xdfa.c and
xrot.c examples as starting points. The addin is "installed" by copying the
compiled shared lib to OOo_INSTALL_DIR/program/addin/ . After this the addin
will show up under the "Add-in" category in Calc by going to "Insert |
Function..." and then selecting "Add-in" for the category.

This addin works when initially entered into a cell ie [=pn_info:descr(A1)].
However after saving, closing, and then reopening the document the cell contents
read "#NAME?" as if you incorrectly spelled a function name. If you then edit
the formula by removing a character and then adding it back the function will
then start working again.

I will attach the files to build the sample xrot.c addin. You can test this
issue with these sample files. See the included README for details.

This issue is similar to issue 95707:
However in that issue my addin function names contained a ':'. I have since
replace the ':' with an '_'.
Comment 1 randyjones 2009-04-27 21:35:35 UTC
Created attachment 61858 [details]
Files needed to reproduce this issue. See the included README for details.
Comment 2 randyjones 2009-05-20 22:58:15 UTC
I just installed OOo3.1.0 and this issue still exists.
Comment 3 randyjones 2009-10-30 20:24:40 UTC
I just installed OOo3.1.1 and this issue still exists. Has anybody out there in
OOo development taken a look at this bug?

I am wondering because this bug is 6 months old and I haven't heard anything.
Comment 4 randyjones 2010-02-09 05:10:13 UTC
I just installed OOo3.2.0rc5 and this issue still exists.

This issue is keeping us from upgrading from 2.4.x to any newer version of

Is anybody alive in the openoffice calc development team?? I am wondering
because the first time I opened a bug I heard from someone in less than a week.
This issue was opened 10months ago and I still haven't heard from anyone.

I just changed Priority of this issue from P3 to P2 and changed the Version from
3.0.1 to 3.2 RC5. This is in hopes of somebody noticing...

Thanks Randy
Comment 5 Regina Henschel 2010-05-30 14:16:05 UTC
When you use an OOo3.x version, please go to Tools > Options > Load/Save >
General and set the 'ODF format version' to "1.0/1.1".

Try saving with ods and with sxc as well.

What do you get when reloading now?
Comment 6 randyjones 2010-06-05 19:07:32 UTC
I just changed the ODF format version to 1.0/1.1 and still get the same problem
with "#NAME?" displaying in the cell when reloading the spreadsheet. This
happens when saving to either ods or sxc.

This is on: 3.2.0
OOO320m12 (Build:9483)
Solaris 10 x86

Thanks Randy
Comment 7 Regina Henschel 2010-06-06 19:39:32 UTC
Please have a look at issue 98149. It seems there is someone having the same
Comment 8 randyjones 2010-06-10 16:20:36 UTC
This does appear to be the same as issue 98149.
Comment 9 martina_buss 2010-06-10 16:46:23 UTC
This seems to be SOLARIS specific?

Why did you select OS=All? are there versions for other OS available and tested
for 2.4?
Comment 10 randyjones 2010-06-10 17:58:58 UTC
I am not sure why I selected OS=All at the time. This has been over a year since
I created this issue. I have changed it to Solaris because this is the only OS I
have worked with. This is an issue on both sparc and x86.

I would be very surprised if this is a Solaris only issue especially since issue
98149 is from a windows OS.
Comment 11 Rainer Bielefeld 2010-06-11 05:23:57 UTC
I'm sorry, I accidently used my second test account "martina_buss" for my comment.

My "2.4.1  Multilingual version German UI WIN XP: [680m17(Build9310)]" shows
"Uryyb Jbeyq" in 'B1' without installed addin file in
C:\Programme\ 2.4\program\addin

"Ooo 3.1.1 WIN XP DE[OOO310m19 (Build 9420)]" and "Ooo-Dev 3.3 multilingual
version English UI WIN XP: [DEV300m80 (Build 9507)]" show "#NAME?" for the
original sample document, but for a document "OO3_addin_bug_my.ods" I created
saving original sample document with my 2.4.1, My 3.1.1 and 3.3 also show "Uryyb

I can't remember that general healing effect for Issue 98149, and so this issue
might have the same roots, but I coubt that it's competely the same.
Unfortunately currently that dll does not run on my WIN PC, and I will have to
find out what the problem is before I can do an additional test.

I also can confirm for 3.1.1 and 3.3, that modifying the formula will bring
"Uryyb Jbeyq"
Comment 12 ooo 2010-06-11 16:12:03 UTC
Grabbing issue.
Comment 13 randyjones 2010-09-17 04:21:08 UTC
I just installed OOo3.3.0beta1 and this issue still exists. So I have bumped the
version from 3.2 RC5 to 3.3 Beta 1. I am running the following build:
OOo-dev 3.3.0
OOO330m3 (Build:9519)
Solaris 10u8 sparc

Thanks Randy
Comment 14 Rainer Bielefeld 2010-09-17 08:40:34 UTC
Interesting information is where you saw this problem the first time. That it
still exists in later version until it has been fixed is trivial.
Comment 15 randyjones 2010-09-17 14:36:10 UTC
In that case then the Version really should be OOo 3.0 because that is where the
issue first appeared. Actually it probably appeared in the beta or rc versions
of 3.0.
Comment 16 randyjones 2011-04-07 03:45:32 UTC
I just installed OOo3.4.0alpha1 for testing and this issue still exists. I am running the following build:
OOo-dev 3.4.0
DEV300m105 (Build:9581)

This is on Solaris 10u6 sparc
Comment 17 Marcus 2017-05-20 11:33:51 UTC
Reset assigne to the default "".