Issue 101565

Summary: OOo 3.1.1 release stoppers / blockers
Product: Build Tools Reporter: merschmann
Component: codeAssignee: mdxonefour
Status: CLOSED FIXED QA Contact: issues@tools <issues>
Severity: Trivial    
Priority: P2 CC: andre.schnabel, cmoulin, cno, facorread, foral, frank.schoenheit, issues, jbf.faure, mechtilde, merschmann, nesshof, olaf-openoffice, oliver.brinzing, rene, ruediger.timm, stefan.weigel, stx123, uwe.luebbers
Version: current   
Target Milestone: OOo 3.1.1   
Hardware: All   
OS: All   
URL: http://wiki.services.openoffice.org/wiki/OOoRelease311
Issue Type: TASK Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 64357, 96031, 97309, 98403, 99842, 100878, 101082, 101273, 101304, 101319, 101420, 101451, 101454, 101457, 101512, 101544, 101645, 101662, 101690, 101701, 101725, 101741, 101774, 101869, 101883, 101899, 101913, 101960, 102004, 102040, 102056, 102089, 102090, 102226, 102356, 102378, 102388, 102409, 102485, 102486, 102557, 102603, 103032, 103116, 103281, 103317, 103357, 103454, 103685, 103861, 103918, 103933, 103936, 103968, 104116, 104146    
Issue Blocks:    

Description merschmann 2009-05-05 13:26:41 UTC
This is the Meta issue to track the potential stoppers for the release of OOo 3.1.1.

If anyone would like to raise an issue for the release, please add the issue id
of the issue you want to raise as dependent issue to the Meta Issue and drop a
note on releases@openoffice.org, that and why you want to declare that issue as
a stopper for releases. 

N.B.: The issue must have been confirmed.
Comment 1 Olaf Felka 2009-05-05 13:42:06 UTC
CCed ul
Comment 2 mdxonefour 2009-05-06 20:34:21 UTC
MD: As discussed in release status meeting last week I add 101420.
Comment 3 Stefan Weigel 2009-05-10 10:02:45 UTC
Adding 1-Click-Crasher issue 100878. After starting OOo, it is literally only
one click to crash it.
Comment 4 uwe.luebbers 2009-05-11 12:00:00 UTC
added 96031 and 101741
Comment 5 uwe.luebbers 2009-05-11 14:30:26 UTC
added 101504,101512,100214,101457,101774, as discussed in the release status meeting
Comment 6 uwe.luebbers 2009-05-11 14:36:12 UTC
removed 101504, added 99842 instead
Comment 7 uwe.luebbers 2009-05-11 14:44:14 UTC
now I did it :-)
Comment 8 salvatoremoi 2009-05-11 16:53:08 UTC
If possible, adding issue 101454. This bug introduces tabulation errors when you
use the .DOC file format. If someone wants compatiblity with Word he is forced
to use openoffice 2.4.x.
Comment 9 merschmann 2009-05-11 19:38:19 UTC
Adding proposed issue 101454
Comment 10 lucat 2009-05-12 11:28:17 UTC
I propose issue 89629. This is an old bug and limits compatibility between
openoffice and word. The vertical text, inside tables, is frequently used for
space reasons, so horizontal text is not always a good alternative.
Comment 11 Oliver Brinzing 2009-05-12 17:28:39 UTC
please add http://www.openoffice.org/issues/show_bug.cgi?id=101690
- Sort in CALC mixes up references to cell identifiers -
there are serveral bug reports for this issue till now
target milestone is still OOo 3.2  - this bug can destroy documents

Comment 12 jbf.faure 2009-05-13 11:52:42 UTC
Adding issue 101690 and issue 101869 as proposed.
Comment 13 jbf.faure 2009-05-17 17:28:27 UTC
Adding issue 101645 (regression on INDIRECT Calc function).
Comment 14 rene 2009-05-17 23:22:44 UTC
Assing issue 102004 (regression)
Comment 15 Marcus 2009-05-18 12:28:59 UTC
Added issue 97309
Comment 16 rene 2009-05-18 14:11:09 UTC
adding issue 101883 as approved in RSM
Comment 17 merschmann 2009-05-19 09:17:34 UTC
Nominating issue 101544 "Named ranges don't work with range operator (colon)"
Comment 18 danros66 2009-05-19 16:57:16 UTC
Please consider [Issue 94543] Error on importing a timestamp field from AS-400
via ODBC and [Issue 89867] Problem Importing Function GETPIVOTDATA From Excel 
Comment 19 camillem 2009-05-20 09:33:45 UTC
Please consider issue 102040 (regression)
Comment 20 chuckcoleman 2009-05-21 01:48:03 UTC
I nominate issue 92011, as I find this particularly vexing.
Comment 21 chuckcoleman 2009-05-21 01:52:09 UTC
I also nominate issue 11756, as this has never been fixed, at least in Aqua.  I
have a word document whose equations are completely unreadable.  I can't attach
it to the original issue until the document is made public.  :-(
Comment 22 jbf.faure 2009-05-22 08:44:59 UTC
Added issue 101960 : regression
Comment 23 uwe.luebbers 2009-05-25 16:30:01 UTC
removed 102004 because "closed/ duplicate"
Comment 24 uwe.luebbers 2009-05-25 17:29:39 UTC
added 102226
Comment 25 uwe.luebbers 2009-05-27 15:12:19 UTC
added 101913 and 64357
Comment 26 jbf.faure 2009-06-01 19:58:04 UTC
Added issue 98403 which is a regression, already fixed for OOo 3.2 and make
"curve motion path" functionality unusable.
Comment 27 rene 2009-06-02 15:43:35 UTC
ul: yeah, right, remove 102004 but do not add 101451. very helpful... If
something is a DUUPLICATE, please add that duplicate bug here, not just remove
it. Readded 101451
Comment 28 uwe.luebbers 2009-06-03 14:38:32 UTC
added 102409
Comment 29 uwe.luebbers 2009-06-03 15:16:22 UTC
added 98403

Comment 30 uwe.luebbers 2009-06-03 16:48:40 UTC
added 102090
Comment 31 uwe.luebbers 2009-06-03 17:14:47 UTC
added 102040
Comment 32 philipp.lohmann 2009-06-04 19:26:52 UTC
add issue 101082
Comment 33 roger6106 2009-06-05 20:17:00 UTC
Please consider adding Issue 101899, a regression from OpenOffice.org 3.0.1.
This issue is preventing me from upgrading to OOo 3.1.
Comment 34 Frank Schönheit 2009-06-08 13:18:24 UTC
adding term "blocker" to summary - searching for this term used to find the
proper issue for all previous release, also this is an term used in releases@ooo
quite often.
Comment 35 Olaf Felka 2009-06-08 15:02:22 UTC
of: CCing me.
Comment 36 Oliver Brinzing 2009-06-14 09:40:38 UTC
please add http://www.openoffice.org/issues/show_bug.cgi?id=102619
- calling dispatch .uno:GotoNextPlacemarker crashes OOo -

Comment 37 salvatoremoi 2009-06-22 12:33:10 UTC
I propose issue 102422 or issue 100497. A tab of 0,75 cm is
added to the unnumbered heading paragraphs when exporting to WW8 format. This is
only visible when opening the exported doc in MS Word.
Comment 38 mdxonefour 2009-06-23 11:04:06 UTC
MD: added 103032
Comment 39 chojin 2009-06-26 09:04:50 UTC
I propose Issue 103025 as it makes OOo 3.1 crash completely using basic Calc
functionalities
and Issue 102359 because it is a serious usability flaw for common users.
Comment 40 Olaf Felka 2009-06-26 12:03:22 UTC
Issue 102359 is a duplicate to issue 99971 which is definitely not a stopper.
Issue 103025 is nor reproducible in OOo310_m13 which is a developer snapshot of
the upcoming OOo 3.1.1.
Comment 41 uwe.luebbers 2009-07-01 16:41:59 UTC
added 103116
Comment 42 uwe.luebbers 2009-07-07 16:36:37 UTC
added 103281
Comment 43 uwe.luebbers 2009-07-08 11:20:47 UTC
added 101701
Comment 44 uwe.luebbers 2009-07-10 14:32:24 UTC
removed 103423, because very risky fix, for 3.1.1.
Reporter agreed 3.2, thanks for that.
Comment 45 uwe.luebbers 2009-07-14 17:30:48 UTC
added 103454 as discussed and approved in the release status meeting
Comment 46 uwe.luebbers 2009-07-17 15:36:54 UTC
Removed issue 100214, because target 3.2. I've attached it to the 3.1.1 stopper,
but I have no idea why. Must have been an accident.
Comment 47 uwe.luebbers 2009-07-20 17:54:24 UTC
added 102486 as discussed in the release status meeting
Comment 48 uwe.luebbers 2009-07-20 17:58:14 UTC
added 102356
Comment 49 uwe.luebbers 2009-07-22 11:54:38 UTC
Attached 103685
Comment 50 uwe.luebbers 2009-07-31 15:07:47 UTC
attached 103936
Comment 51 uwe.luebbers 2009-08-03 12:06:11 UTC
attached 103933
Comment 52 uwe.luebbers 2009-08-03 12:35:07 UTC
added 103968 
Comment 53 uwe.luebbers 2009-08-04 13:56:40 UTC
attached 101899
Comment 54 salvatoremoi 2009-08-04 22:06:15 UTC
Please consider adding Issue 102357, a regression from OpenOffice.org 3.0.1.
This bug stops OpenOffice.org 3.1 from reading the status of checkboxes on Word
documents.
Comment 55 uwe.luebbers 2009-08-11 16:43:59 UTC
added 103918
Comment 56 merschmann 2009-08-18 08:10:35 UTC
Adding issue 104146 , as decided in release status meeting
http://wiki.services.openoffice.org/wiki/ReleaseStatus_Minutes#Discussion_on_3.1.1_stopper_issues
Comment 57 tommy27 2009-09-02 07:47:12 UTC
OOo 3.1.1 has been released.

time to put the "FIXED" label to this issue
Comment 58 andreschnabel 2009-09-02 17:54:50 UTC
as suggested
Comment 59 andreschnabel 2009-09-02 17:55:43 UTC
and closed