Issue 102008

Summary: Calc doesn't read the position of notes in OO.o 3.1
Product: Calc Reporter: rafaelda <falecomigo>
Component: viewingAssignee: oc
Status: CLOSED WONT_FIX QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues, kpalagin
Version: OOo 3.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description rafaelda 2009-05-18 05:41:28 UTC
I'm using BrOffice 3.1 in Windows XP SP3 Pt-BR.

Steps to reproduce:
Open Calc
Click with the left button of the mouse in a cell and choose the option "Insert
note".
Write anything in the note.
Now change the position of the cell puting the mouse over the blue squares, for
example: draggin the botton square to down and the top square also to down so
that the note stays closer to it's cell.
Click anywhere outside the note to finish editing it.
Put the cursor over the cell with the note.

What happens:
The note appears but not in the positon you had left it.

What should have happend and that used to happen in previous versions:
The note should appear in the positon you left it.

Strangely when you click to edit that note again it appears in the right
position when in edit state.

Even in documents created before OOo 3.1, when they are read by OOo 3.1, the
positons of the notes is not read by Calc.
Comment 1 raal 2009-05-19 12:38:20 UTC
I can confirm on DEV300m48, WinXP 
Comment 2 oc 2009-05-19 12:48:40 UTC
Hi Daniel please have a look
Comment 3 daniel.rentz 2009-09-30 08:44:17 UTC
This is intended behaviour when the note is in hidden state. Hovering the mouse
pointer over the cell note will show the caption box at a calculated position
that is best for the current view (default: right of cell, but may be left of
cell if cell is too close at the right window border). The intention is to make
the caption completely visible to the user who is interested in reading the
contents without having to move the sheet if the note would be outside the
window. When the note is made visible (right click, Show Note), the custom
position for the note will be used of course.
Comment 4 daniel.rentz 2009-10-14 10:07:51 UTC
back
Comment 5 Mechtilde 2009-10-19 10:14:51 UTC
wontfix -> closed
Comment 6 aurelias 2010-01-11 20:52:44 UTC
The problem with this behavior is that the calculated position is not always 
optimal, for instance when it places the note behind form elements (see issue 
10621).