Issue 102103

Summary: find replace searching for font with color white finds color black/automatic instead
Product: Writer Reporter: meywer <mey.wer>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: elish, issues, jbf.faure
Version: OOo 3.0.1Keywords: needmoreinfo, oooqa
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
example document none

Description meywer 2009-05-20 19:13:13 UTC
I create cloze texts making the hidden words white.

To create a readable solution I selct the whole text and choose font color
automatic.

But:

If in the text there are colorizde words, they get lost.

Also if I want colorize the solution (to show, where there have been the
blanks/gaps/holes) I get a problem.

Tried find&replace searchig for „white“ and replacing with „green“. Writer
doesnt replace the whit, but the black (automatic) characters of the whole
document!!!
 	
That's bad.

see also 91769
Comment 1 meywer 2009-05-20 19:38:17 UTC
This is a bug, which makes writer crashing!

find (one font color) an replace (with another font color) in a document with
some more lines brings up a window „To proceed with this action, you must first
turn off the „undo“ function. Do you want to turn off the „undo“ function?“

Clicking „Yes“ makes OO freeze!!!
Comment 2 eric.savary 2009-05-20 22:41:49 UTC
Please attach a sample document and give a step by step description of what you
do, get and expect.
Comment 3 meywer 2009-05-23 18:24:09 UTC
see attachement or create an own document with usual black (automatic) colored
text and some words colored (font color) white.

open document
(don't select anything)
alt+e f (edit, find and replace)
(don't write anything!)
alt+o (more options)
alt+m (format)
alt+c (font color)
w (white)
enter (ok)
3 ⨯ tab (replace with)
(don't write anything!)
alt+m (format)
alt+c (font color)
l ↓↓↓ (light red)
enter (ok)
alt+l (replace all)

writer replaces *most of* the black (automatic) colored characters (thats new -
in former tries it colored *all* black characters light red.


(Make the document larger.

writer asks you to turn off the undo function...
turn off
writer freezes)
Comment 4 meywer 2009-05-23 18:25:19 UTC
Created attachment 62466 [details]
example document
Comment 5 meywer 2009-05-23 18:27:46 UTC
I think it's clear, that I expect to get the former white characters colorized
light red now.
Comment 6 eric.savary 2009-05-27 08:03:58 UTC
Reassigned to SBA
Comment 7 Rob Weir 2013-02-02 03:00:41 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 8 Edwin Sharp 2013-08-02 14:27:08 UTC
following steps in comment 3 with Rev. 1503704 Win 7.