Issue 102300

Summary: Paste of image from Autocad is resized and distorted
Product: Draw Reporter: emanuele_tagliavini <emanuele.tagliavini>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: clippka, issues, jbf.faure, sven.jacobi
Version: OOO310m11   
Target Milestone: ---   
Hardware: Unknown   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
spreadsheet has the same problem
none
draw has thw same problem
none
this was the attended result none

Description emanuele_tagliavini 2009-05-27 14:09:08 UTC
I'm used to copyclip drawings from the Autocad (Autodesk) window and
paste-special in to my text document. Even if I paste as Metafile Gdi or as Acad
OLE object, i obtain the same troubles: 1) the image is auto-resized and
distorterd (it automatically fits the picture in the page) 2) the polylines and
circles primitives of acad aren't correctly plotted...it happen's the same with
character like "Q" or "O"...Bye
Comment 1 eric.savary 2009-05-27 14:15:13 UTC
Not a P1.
Attach a sample file (Image and odt containing the pasted image) and a
screenshot of how it looks like when pasted.
Comment 2 eric.savary 2009-05-27 14:17:02 UTC
Plus: DOes this happen when pasting into Draw too?
Comment 3 michael.ruess 2009-05-27 14:18:14 UTC
Does this also happen when you paste the clipboard contents from acad into OOo
Spreadsheet or drawing?
Comment 4 emanuele_tagliavini 2009-05-27 14:51:50 UTC
Created attachment 62582 [details]
spreadsheet has the same problem
Comment 5 emanuele_tagliavini 2009-05-27 14:52:18 UTC
Created attachment 62583 [details]
draw has thw same problem
Comment 6 emanuele_tagliavini 2009-05-27 14:52:51 UTC
Created attachment 62584 [details]
this was the attended result
Comment 7 emanuele_tagliavini 2009-05-27 14:54:08 UTC
Spreadsheet and draw have the same trouble as writer...i've sent the info's you
need. Thanks
Comment 8 eric.savary 2009-05-27 14:54:18 UTC
@WG: Please have a look.
Comment 9 jbf.faure 2009-05-31 16:19:46 UTC
@ emanuele_tagliavini : have you tried to paste after having formatted your page
in Draw as A4 portrait instead of A4 landscape ?
Comment 10 emanuele_tagliavini 2009-06-02 19:59:04 UTC
I've formatted the page as A4 landscape...the problem remains...
Comment 11 wolframgarten 2009-06-04 08:37:27 UTC
As I do not have Autocad here I cannot reproduce this. Reassigned.
Comment 12 wolframgarten 2009-10-22 10:37:18 UTC
Reassigned.
Comment 13 eric.savary 2009-10-23 11:52:48 UTC
@wg: "Draw and Calc have the same problem". It's obviously a general graphic
import filter problem -> i.e Graphics.

The fact that you don't have AutCad (neither do I) doesn't make it a Writer problem.

Ask for CL/SJ's help. 
Comment 14 wolframgarten 2009-10-23 12:00:44 UTC
@es: it is a general problem, yes. Since I cannot handle all graphic
import/export for all applications everyone should handle it himself, especially
when they arrive on his account and you already know the right people for it
(flexible QA).....
Comment 15 Rob Weir 2013-02-02 02:55:08 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 16 Rob Weir 2013-04-05 14:14:47 UTC
This will be hard to reproduce but that is because it requires Autocad as part of the scenario.  But I don't think we need more info from the user, so I'm removing the "needmoreinfo" keyword.
Comment 17 Marcus 2017-05-20 11:27:46 UTC
Reset assigne to the default "issues@openoffice.apache.org".