Issue 102372

Summary: close document cause call to pure virtual function R6025
Product: Writer Reporter: cbn <openoffice>
Component: codeAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P2 CC: eric.savary, issues, os_ooo, rainerbielefeld_ooo_qa
Version: OOo 3.1Keywords: crash, needhelp, oooqa
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Word document with graphic embedded
none
Crash screen dump
none
Windows crash repot file none

Description cbn 2009-05-29 21:26:15 UTC
Please open the attached word document in OO 3.1. Move the graphic in the
beginning of the document a little back and forth, then close the document. When
you are prompted for save/discard/cancel, choose discard. Then the application
crashed with the runtime error from VC++ "R6025: Pure virtual function call". 

The dump of the error is attached.
Comment 1 cbn 2009-05-29 21:28:25 UTC
Created attachment 62644 [details]
Word document with graphic embedded
Comment 2 cbn 2009-05-29 21:29:16 UTC
Created attachment 62645 [details]
Crash screen dump
Comment 3 cbn 2009-05-29 21:30:14 UTC
The same error message is reported here:
http://qa.openoffice.org/issues/show_bug.cgi?id=99433. I don't know if they are
related.
Comment 4 eric.savary 2009-05-31 20:18:34 UTC
@Hbrinkmn:
- open attached document
- move the graphic
- Close document and discard warning
-> I get no Pure Virtual Function called but a crash.

I don't get a crash neither in 3.0.1 nor when saved as odt in 3.1
Comment 5 cbn 2009-05-31 20:29:55 UTC
I have seen the normal crash as well. This was reported with the error 
reporting tool when OO crashes and restarts. However, I cannot get that problem 
consistently. The crash with the virtual function call is what I saw and 
reproduced.
Comment 6 Rainer Bielefeld 2009-06-06 10:46:38 UTC
I see that problem "here and there" (app. 1x a day) in completely different
situations, as far as I remember only in WRITER. The crash happens sometimes
when I move a picture or a DRAW element, sometimes when I close the document. I
believe it started with 3.1RC.

I war not able to reproduce the crash with "National kursus juni 2009.doc", and
I still failed to find a way to make that crash 100% reproducible. 

Any Idea what might cause that Message?
Comment 7 cbn 2009-06-06 14:10:17 UTC
Created attachment 62818 [details]
Windows crash repot file
Comment 8 cbn 2009-06-06 14:13:18 UTC
After seeing Rainer's comment I repeated the steps above to reproduce the pure 
virtual function call issue. It is reproducible based on the Word file attached.

The MS crash report file is now attached to the issue.
Comment 9 Rainer Bielefeld 2009-08-03 12:24:56 UTC
This really becomes annoying, I have at least 1 crash per day!
Windows crash report tells me that it's a problem with svlmi.dll, Error address 
&#x000d;&#x000a

More details:

Fehlgeschlagene Anwendung soffice.bin, Version 3.1.9398.500, fehlgeschlagenes
Modul svlmi.dll, Version 3.0.500.0, Fehleradresse 0x0003968c.

Weitere Informationen ├╝ber die Hilfe- und Supportdienste erhalten Sie unter
http://go.microsoft.com/fwlink/events.asp.

0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 73 6f 66   ure  sof
0018: 66 69 63 65 2e 62 69 6e   fice.bin
0020: 20 33 2e 31 2e 39 33 39    3.1.939
0028: 38 2e 35 30 30 20 69 6e   8.500 in
0030: 20 73 76 6c 6d 69 2e 64    svlmi.d
0038: 6c 6c 20 33 2e 30 2e 35   ll 3.0.5
0040: 30 30 2e 30 20 61 74 20   00.0 at 
0048: 6f 66 66 73 65 74 20 30   offset 0
0050: 30 30 33 39 36 38 63 0d   003968c.
0058: 0a  
Comment 10 Rainer Bielefeld 2009-09-02 18:17:48 UTC
I created a crash report, ID rdgvndc
Comment 11 openoffice 2010-02-02 15:49:12 UTC
@es: Cannot reproduce on DEV300_m70(unxmacxi.pro). Can you try some other platforms?
Comment 12 openoffice 2010-08-26 09:35:27 UTC
OS: This one is Windows only. Can you give a hand debugging?
Comment 13 thorsten.ziehm 2010-11-09 10:07:56 UTC
OOo 3.3 is nearly final. I change the target of this issue to OOo 3.x. Please
find a solution and set a correct target, if you know when a fix can be integrated.
Comment 14 Marcus 2017-05-20 11:13:27 UTC
Reset assigne to the default "issues@openoffice.apache.org".