Issue 102378

Summary: PDF Export Crash on bigendian systems
Product: porting Reporter: Raphael Bircher <rbircher>
Component: MacOSXAssignee: Raphael Bircher <rbircher>
Status: CLOSED FIXED QA Contact: issues@porting <issues>
Severity: Trivial    
Priority: P2 CC: issues, lhorner, lohmaier, loria, mechtilde, ooo, philipp.lohmann, stefan.baltzer, ydario
Version: OOo 3.1Keywords: oooqa, regression
Target Milestone: OOo 3.1.1   
Hardware: Mac   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 101565    
Attachments:
Description Flags
Crash Report
none
patch for OOO310 codeline
none
samepatch for current DEV300 codeline (psprint was integrated into vcl module) none

Description Raphael Bircher 2009-05-30 10:07:30 UTC
Steps to reproduce

- Open OOo, create a new document
- write same lines
- Export to PDF
- OOo Crashs

Confirmed on Mac OS X 10.4.11 on PPC with OOO 3.1.0

Its a regression. on the same Computer with 3.0.0 it works.
Comment 1 Raphael Bircher 2009-05-30 10:09:13 UTC
Set keywords: oooqa, regression
Comment 2 Raphael Bircher 2009-05-30 10:10:34 UTC
Created attachment 62651 [details]
Crash Report
Comment 3 Raphael Bircher 2009-05-30 10:16:17 UTC
fergot to set OOo Version ;-)
Comment 4 Uwe Altmann 2009-06-03 15:17:19 UTC
As another user reports for OSX 10.5.7 using a PowerPC G4:
"When there is a bullet list in a writer document, then export as PDF no longer is possible: OOo freezes. "Export..." and "Export as PDF..." will result in the same error.
Using a numbered list will NOT result in this error."
Using the test doc the user provides, OOo 3.1. Intel works as expected and without an error.
Comment 5 yabba 2009-06-07 11:22:07 UTC
I use an PB G4 Mac OS X 10.5.7 german system
This problem came around the 3.1 milestone DE builds.

I confirm this problem started on some documents. Now it seams to happen 
with nearly every (old) document.

The freezing happens if you deactivate the to options (sorry, I see it right know 
only in german) : Laden/Speichern > Allgemein > Laden:
* Loading user preferences with the document
* Loading printer preferences with the document

If you activate both options OOo crashes with the click.

Comment 6 Mechtilde 2009-06-09 13:38:32 UTC
@ loria

Can you have a look
Comment 7 stefan.baltzer 2009-06-09 17:32:36 UTC
Put PL on CC. Maybe the crashreport tells something helpful?
Comment 8 philipp.lohmann 2009-06-09 17:46:41 UTC
No, sorry, the contained Stacktrace does not tell much.
Comment 9 lohmaier 2009-06-09 17:48:11 UTC
Bug was introduced with DEV300_m38 - DEV300_m37 is OK, all newer milestones
crash when exporting to PDF.

##### IMPORTANT #####
empty documents can be exported, but when you add text (e.g. the
dummy-autotext), exporting to PDF results in a crash.
Comment 10 Raphael Bircher 2009-06-09 22:01:39 UTC
Cloph, thanks very much for your informations

@all with CWS of DEV300_m38 tuch the PDF Export?
Comment 11 hdu@apache.org 2009-06-10 15:13:17 UTC
ChildWorkSpaces integrated into DEV300_m38 were: ab65, alf01, betterautoifacedoc, c24v001_DEV300, 
calc47, canvas06, cmcfixes51, configitems02_svn, cwscheckapi5_DEV300, cwscheckapi6, 
dba301b_DEV300, dba31d, dba31f, fha3fixes, fwk92, gcc44, hb12, hr57, hrovista3_DEV300, 
i96529_DEV300, impressfontsize, jsc312, jw5, macrestart2_DEV300, mav45_DEV300, mooxlsc, 
native209_DEV300, native210_DEV300, native211_DEV300, odfp30_DEV300, ooo301gsl2_DEV300, 
ooo301gsl3_DEV300, os121, os2port04, qadev34t_DEV300, qascripts04, rt35, rtlchart02, rtlcontrols, 
sb101, sjfixes11_DEV300, sjfixes12_DEV300, sw301bf04_DEV300, sw301bf05_DEV300, 
swffixes02_DEV300, sysui28_DEV300, sysui36, tl56_DEV300 and writer2latexexternal
Comment 12 Raphael Bircher 2009-06-10 15:46:21 UTC
unfortunately DEV300_m38 has a load of integrated CWS. Yesterday, cloph make a
selection wich CWS tuch the PDF Export.

rbircher > cloph
Do you can post this list here? thanks.
Comment 13 lohmaier 2009-06-27 20:20:32 UTC
*** Issue 101731 has been marked as a duplicate of this issue. ***
Comment 14 lohmaier 2009-06-27 20:21:53 UTC
*** Issue 100271 has been marked as a duplicate of this issue. ***
Comment 15 lohmaier 2009-06-27 20:27:23 UTC
I identified the issue. the problem is this:
svn diff -c 264373 svn://svn.services.openoffice.org/ooo/
Index: cws/os2port04/psprint/source/fontsubset/sft.c
===================================================================
--- cws/os2port04/psprint/source/fontsubset/sft.c	(Revision 264372)
+++ cws/os2port04/psprint/source/fontsubset/sft.c	(Revision 264373)
@@ -323,7 +323,7 @@
 
 }
 
-#if defined(_BIG_ENDIAN)
+#if defined(OSL_BIG_ENDIAN)
 #define Int16FromMOTA(a) (a)
 #define Int32FromMOTA(a) (a)
 #else


While using a OSL-Macro is indeed a good idea, the big problem is that there is
no OSL_BIG_ENDIAN macro in OOo. The macro is called OSL_BIGENDIAN, with only one
underscore.
Comment 16 lohmaier 2009-06-27 22:41:22 UTC
Created attachment 63250 [details]
patch for OOO310 codeline
Comment 17 lohmaier 2009-06-27 22:43:05 UTC
Created attachment 63251 [details]
samepatch for current DEV300 codeline (psprint was integrated into vcl module)
Comment 18 hdu@apache.org 2009-06-29 08:42:49 UTC
@cloph: outstanding work! Thanks for identifying the culprit (CWS os2port04).
Comment 19 hdu@apache.org 2009-06-29 08:45:22 UTC
Applied in CWS vcl103 for target OOo3.2.
IMHO the fix should also go into target OOo3.1.1.
Comment 20 Olaf Felka 2009-06-29 09:45:45 UTC
adding blocker issue
Comment 21 Olaf Felka 2009-06-29 10:45:05 UTC
adjusting target
Comment 22 Yuri Dario 2009-06-29 17:01:29 UTC
Sorry for breaking pdf export.
Comment 23 hdu@apache.org 2009-06-30 08:05:03 UTC
Also applied in CWS ooo311gsl05.
Finding the root cause would have been much faster if we had one stacktrace from a system which had 
debug-symbols in vcl and psprint. Or if the number of CWSses integrated per milestone were more 
sensible. For the problematic milestone DEV300_m38 about 48 CWSses got merged and the diff to its 
predecessor DEV300_m37 has almost 250000 lines of code.

@ydario: your contributions are very good and highly appreciated
Comment 24 hdu@apache.org 2009-06-30 08:08:03 UTC
correction: the diff between m37 and m38 is over 480kLOC (m38 to m39 has the 260kLOC)
Comment 25 philipp.lohmann 2009-06-30 16:57:18 UTC
please verify in CWS ooo311gsl05
Comment 26 maho.nakata 2009-07-01 22:05:49 UTC
Hi
per request of Stefan, I uploaded a package for QA.

http://ooopackages.good-
day.net/pub/OpenOffice.org/misc/OOo_ooo311gsl05_MacOSXPowerPC_install.dmg
md5sum
91f35b4c5010629d09f472494d222af8  OOo_ooo311gsl05_MacOSXPowerPC_install.dmg

thanks!
Comment 27 Raphael Bircher 2009-07-02 01:24:14 UTC
Thanks to Maho for uploading the CWS Build
PDF Export works in the CWS

Set Status to: VERIFIED
Comment 28 stefan.baltzer 2009-07-03 12:01:09 UTC
sba->rbircher: Please verify the fix in Mac PPC build of CWS.
Nakata Maho provided a build:
http://ooopackages.good-day.net/pub/OpenOffice.org/misc/OOo_ooo311gsl05_MacOSXPowerPC_install.dmg

Reassigning issue to you.
Comment 29 Mechtilde 2009-07-13 20:47:05 UTC
@ rbircher

cn you also verify in OOO310m14 or newer?
Comment 30 lhorner 2009-07-23 19:05:36 UTC
I had this 
http://ooopackages.good-
day.net/pub/OpenOffice.org/misc/OOo_ooo311gsl05_MacOSXPowerPC_install.dmg
installed and thought it fixed the issue.  I thought for some reason (misreading I think) that this fix was 
incorporated in 310m15.  Boy was I wrong.  Even text files now crash (not just the equation files that 
were giving me problems).  I'd like to go back to the patch posted above, but the link is broken.  Can it 
be reposted please.

Thanks.

G4, 10.5.7
Comment 31 lohmaier 2009-08-19 17:54:12 UTC
This issue is assigned to cws ooo311gsl05 that was integrated into OOO310_m16
(not m14 - that is what the cws was based on) (and also integrated into DEV300_m53) 

You can check this by using the "Track issue" link at the left-hand side (when
using qa.openoffice.org.... URLs) http://qa.openoffice.org/issuelinks.html

So any milestone/build starting with OOO310_m16 has the fix included, this also
covers the 3.1.1rc1 (that corresponds to OOO310_m18)
http://ooopackages.good-day.net/pub/OpenOffice.org/MacOSX/3.1.1rc1_20090807/

- verified in 3.1.1rc1, no crash when exporting to PDF anymore → closing
Comment 32 teeschmid 2009-08-21 10:18:52 UTC
I had the crashes on PDF Export on my Mac G4 OS X 10.5.
Looking forward to a resolution I downloaded the German version yesterday.
  OOo_3.1.1rc1_20090807_MacOSXPowerPC_install_de.dmg
from the link given:
http://ooopackages.good-day.net/pub/OpenOffice.org/MacOSX/3.1.1rc1_20090807/

I am sorry to say I can't verify the PDF Export, as this version crashes on opening my relevent file (a calc 
table of 48KB) and crashes as well when I try to open a .DOC file I received by mail.
It allowed me to open some simple calc files, but does did not show the PDF Export crashes on 3.1 
anyhow (have no lists).
Currently I have Mac OS X 10.5.8, the latest version, on my PPC
Comment 33 lohmaier 2009-08-21 14:36:27 UTC
please file an issue and attach the crashing calc and doc files as soon as
possible. If it is reproducible, it might be declared as stopper and fixed for
3.1.1 - otherwise a fix has to wait.

And you will always see a crash on 3.1.0 (and even earlier versions) when you
create PDF where fonts are embedded into the PDF. 
So to verify create a new text document, insert the dummy text ("Blindtext") by
using the AutoText menu or dt<F3> (english version) or bt<F3> (german version).
Such a file will crash on 3.1, but export fine in 3.1.1rc

Any other problems are not related to this issue, and thus please file seperate
bugs.
Comment 34 hdu@apache.org 2009-09-07 10:59:09 UTC
*** Issue 104782 has been marked as a duplicate of this issue. ***
Comment 35 lohmaier 2010-01-07 22:59:02 UTC
*** Issue 105991 has been marked as a duplicate of this issue. ***
Comment 36 T. J. Frazier 2012-02-19 22:38:45 UTC
*** Issue 100271 has been marked as a duplicate of this issue. ***