Issue 102807

Summary: Zoom too fast using Multi-Touch Trackpad on Apple Mac Pro
Product: General Reporter: cactuscomputing <cactuscomputing>
Component: codeAssignee: hdu <hdu>
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: alex, choi9999, dwdopenoffice, eric.savary, ericb, florian, hdu, issues, max.odendahl, mdxonefour, oc, rbircher, scottcain, stephan_schaefer, tomb8tes
Version: OOo 3.1.1Keywords: aqua, oooqa
Target Milestone: OOo 3.3   
Hardware: Mac   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 114909, 111112    

Description cactuscomputing 2009-06-15 18:38:08 UTC
On a laptop it's far to easy to alter the zoom setting's by mistake. It would be
nice if the zoom dialog provided a mechanism so that the current zoom settings
could be locked if so desired.
Comment 1 eric.savary 2009-06-16 12:03:43 UTC
What do mean with "On a laptop it's far to easy to alter the zoom setting's by
mistake"? Which zoom? Which key shortcut?
Comment 2 cactuscomputing 2009-06-16 14:12:28 UTC
The touch pad on a mac (Apple Mac Pro) supports zooming via finger gestures
(like the iphone). As a result unless you are very careful its easy to do the
pinch/expand finger gesture- radically altering the zoom on OO. Its driving my
wife crazy! 

I've tried to disable the feature both via the apple preferences and via Open
Office, with no success. It would make sense for application level control, as
the zoom is very handy in applications such as photoshop. When I use OO
(linux/windows desktop computers) I keep the zoom level at 100%. I can see that
occasionally changing zoom level would be handy, so the control in OO is very
nice. My wife though is finding that because of an unintended finger gesture
she's suddenly viewing at 400%! Providing an option to lock the zoom would be a
tremendous help. 
Comment 3 eric.savary 2009-06-16 15:42:47 UTC
Ok but do you mean the zoom which zooms the whole Desktop (which I know from a
MAC Desktop) and can be triggered over Ctrl+Mouse wheel back and forth OR the
document zoom inside a Writer document only?

Does this happen also in other non OOo applications?

I think this feature should be set at system level (Apple) and not application
level (OOo).
Comment 4 cactuscomputing 2009-06-16 16:24:50 UTC
The zooming thats a problem is for the Writer document. Other apps do zoom, but
they do not go crazy in percent terms with tiny finger movements, for instance
going from 100% to 400%. This is a very big usability issue. 

It is also desirable to control zoom at the application level since zooming via
the finger gestures can be useful in some apps, but not in others. 
Comment 5 cactuscomputing 2009-06-16 16:44:58 UTC
The zooming thats a problem is for the Writer document. Other apps do zoom, but
they do not go crazy in percent terms with tiny finger movements, for instance
going from 100% to 400%. This is a very big usability issue. 

It is also desirable to control zoom at the application level since zooming via
the finger gestures can be useful in some apps, but not in others. 
Comment 6 eric.savary 2009-06-16 23:42:40 UTC
I don't have an Apple Mac Pro to check this but I had a look at the demo of the
Multi-Touch Trackpad:

http://www.apple.com/macbookpro/features.html

I can *imagine* what happens but:
- Why the Trackpad can trigger *our* zoom??? I don't know!
- If this is intended (from our side) we should align with the Zoom velocity of
other "pure" Mac application. Then it's a bug, not an enhancement.

Else, I'm sorry but I don't think we will ever implement a special
"blocking-zoom-setting-for-people-with-unlucky-fingers-on-Apple-Mac-Pro" :)

So re-qualifying as DEFECT because YOU say, other apps behave more smoothly when
zooming but I still cannot confirm.

Setting MACPORT on CC to see if someone can confirm and detail.
Changing the summary to something more "real".
Comment 7 eric.savary 2009-06-18 00:38:20 UTC
@Macport: any comment?
Comment 8 Raphael Bircher 2009-06-30 06:19:03 UTC
add myself to CC
Comment 9 tomthetree 2009-07-22 17:41:59 UTC
I can confirm this issue, and consider its fix as an enhancement, as the feature
essentially works, but badly.

Using the 'pinch' gesture on the trackpad of my MacBook Pro (OS 10.5.7), the
document window (in the word processor and spreadsheet application, possibly
others) zooms in and out at a very fast pace, making accurate control impossible.

@es: global settings for trackpad usage in the apple preference payne cover
track speed, double click speed, and scrolling speed, though these don't seem to
correlate with the OOo application zoom behavior; I can confirm that that the
zooming velocity in OOo applications is out of line with other Apple
applications, that zoom at a more usable speed.

Comment 10 tomthetree 2009-07-22 18:22:08 UTC
After further use, I can add that its easy to unintentionally trigger the zoom
when trying to use 'two finger scrolling' with the trackpad. I'd agree that this
makes the issue a defect - really irritating! :) 
Comment 11 max.odendahl 2009-07-23 00:07:36 UTC
I'll try to look into it as soon as I find some time.....
Comment 12 scottcain 2009-09-04 16:14:48 UTC
I added myself as a cc.

Just to add my $0.02: I think OO.o is currently unusable on a MacBook Pro
because of this issue.  The zoom is way faster than any other application I've
ever used on the Mac that supports this type of zooming.  I end up using Google
Docs instead.
Comment 13 thatseattleguy 2009-09-18 23:08:16 UTC
I agree with the sentiment "OO.o is nearly unusable on a MacBook Pro due to this issue". 

This is not limited to Writer. It's a major problem in Calc, and probably other OO.o apps. It drives me 
batty, and I know of MBP users who have switched back to MS Office because of it alone.

There are at least three tracks to this I can see:

- BUG: The response to pinch-zoom gesture is mega-ultra-fast zoom and accurate view control is 
impossible. This is clearly a bug.

- ENHANCEMENT: Allow the user to disable multi-touch gesture zoom (could be per application or just 
in all applications). Ideal way for this to be done would be via control that would set the pinch-zoom-
response acceleration, which if set to zero effectively would have the effect of disabling the zoom 
response.

- ENHANCEMENT: Provide an easy keyboard shortcut to return the zoom level to 100%.
Comment 14 bfraga 2009-10-18 19:14:42 UTC
*** Issue 102807 has been confirmed by votes. ***
Comment 15 bfraga 2009-10-18 19:34:43 UTC
I also agree with "OO.o is nearly unusable on a MacBook Pro due to this issue." Incredibly annoying. But 
there's more...

Although there are many circumstances where the zoom might be unintentionally triggered 
(unintentionally triggered by the user, but the correct interpretation of a gesture), I believe there might 
also be a coding error (unintentional trigger by user AND incorrect interpretation of a gesture).

On the MBP models without a dedicated button, the trackpad serves as the click mechanism. To select 
text, you must physically press down on the trackpad with one finger and use the other to move the 
cursor to select the text. In every other application I have used, the act of pressing down on the 
trackpad means that you CANNOT gesture to pinch zoom, because otherwise, a slight movement of the 
finger that is pressing down would be a pinch zoom. Oo.o does not interpret this action in this way. 

It is rather difficult to select text while keeping one finger absolutely, completely stationary and moving 
the other every single time. The current implementation of multi-touch gestures makes selecting text 
extremely difficult.
Comment 16 dwd 2009-10-26 14:09:13 UTC
Yes this makes OpenOffice practically unusable with the unibody Macbook Pro
trackpad.  A workaround for this is available with the beta application
MultiClutch.  See
http://wcrawford.org/2008/02/28/everytime-i-think-about-you-i-touch-my-cell/
especially the comment from me (Dave Dykstra) because the application has a bug
when used on OpenOffice which also needs a workaround (sigh).
Comment 17 thatseattleguy 2009-11-01 00:17:24 UTC
This defect is currently (or was initially) marked priority 4 (P4). Given its severity for a particular segment 
of users (anyone with a Unibody Mac Book or Mac Book Pro), P4 seems too low. I would suggest P3 
(default priority) or even higher. 

How can this be priority setting changed, and if so by whom? Every day there are more users of these 
types of laptops with these kinds of trackpads, so it's an increasing rather than decreasing problem.
Comment 18 kaikydelan 2009-12-11 03:24:07 UTC
One resolution for this problem could be to change the slider to a linear
slider. The major issue I am noticing is the fact that the slider is exponential
from 100% onwards. The problem is that the zoom seems to cause that slider to
jump from 100% to 500% onward to 3000%. If there were an option to set the
maximum zoom to something more reasonable, say 400% and let the slider act
linearly, the trackpad zoom would be less problematic (not saying I like having
random zooms for Macbook Pro 3,1 but it wouldn't be as much of an issue).
Comment 19 adamtorgerson 2010-01-20 04:27:26 UTC
Like the others with a unibody plastic macbook, this bug is making the app
unusable. 
Comment 20 cactuscomputing 2010-01-26 01:45:20 UTC
See if I can change to a P2! Perhaps then a target milestone will be issued. 
Comment 21 Raphael Bircher 2010-02-09 13:27:40 UTC
P2 is realy to height. P3 is the maximum. And This is not a defect, This is a
enhacement
Comment 22 bfraga 2010-02-09 13:43:27 UTC
I don't really understand how this could be an enhancement and not a defect. I thought everyone here 
made it clear that the app is very difficult to use on a modern Apple laptop due to this bug. Since 
multitouch gestures were added in a release (I think 3.0.1) and it's always done this, I don't think calling 
the fix an "enhancement" is accurate. It's not like any other OS X application using gestures has this 
problem.

Also, I understand that changing it from P2 to P3 makes sense given that it's only mac users who are 
impacted. But that shouldn't mean that it's less important than other bugs that only impact the OS X 
builds.
Comment 23 Raphael Bircher 2010-02-09 13:47:18 UTC
And this is a porting issue so change component
Comment 24 Raphael Bircher 2010-02-09 14:31:25 UTC
@bfraga From users view you are right, that looks like a defect. I try to
explane why this is a enhacement and not a defect.

Apple's Multituch is new. No other Laptop has similar functionality. So we have
to write new code, and implement it to the right place. If you know, that OOo
has 8 Mio lines of code, you can expect, that is not a easy work.

As defect we classify issues who describe a error in a allways existing
fonctionality. The code for this feature does exist.

Writing new code is allways more riskfull as only change same existing code. A
enhacement and a feature request will be better tested as a defect. He hes a
different internal workflow.

So this change is for tecnical reason. Its important to make sure, that this
issue will pass the right workflow.

Same with te component. Normal users can't know that is a porting issue. But the
right place is important. More then 200 developers works on OOo, they are very
specialiced. If the issue is on the wrong place they will never see this issue.

And Priority 2 are mainly Crashs and freeze so I change back. Thanks for
understanding

Greeting Raphael
OOo Mac QA
Comment 25 hdu@apache.org 2010-02-10 15:58:50 UTC
The fastest solution for this issue would be to modify the method magnifyWithEvent() in aqua/source/window/salframeview.mm by using a sensitivity factor or disable it completely by an early 
return. I don't have access to a system with such a problem though else I'd give it a shot...

Then there is the question of whether to have an UI-element for the sensitivity setting or not, but this 
should be split off into a different issue assigned to requirements@openoffice.org
Comment 26 max.odendahl 2010-02-10 21:27:50 UTC
I'll look into it....clearly a defect(if confirmed), therefore changing back 
Comment 27 cactuscomputing 2010-02-11 16:58:15 UTC
Cheers, a target of 3.3 is great!
Comment 28 max.odendahl 2010-03-08 13:07:04 UTC
could someone who can reproduce this issue try
ftp://qa-upload.services.openoffice.org/vcl110/mac-intel/OOo_3.3.0_100227_MacOSXIntel_install.dmg
and report back?

This includes a fix in a similar, maybe related area, but maybe made things worse.

(Don't have a mac right now to test this out myself)
Comment 29 thatseattleguy 2010-03-11 02:48:53 UTC
tested on a MacBook Pro under 10.5.8 OS X using the link provided:

ftp://qa-upload.services.openoffice.org/vcl110/mac-
intel/OOo_3.3.0_100227_MacOSXIntel_install.dmg


It's definitely better in this build. The multi-touch zoom is still fast, but it's not bat-out-of-hell fast 
anymore (the "exponential acceleration" noted by someone seems gone). Still IMHO much too easily 
triggered, and still too fast once it is - but at least for me it's now in the "barely controllable if I'm 
careful" range.

Still would prefer a dialogue to disable this functionality and/or set the zoom speed. Of course.
Comment 30 jenikff 2010-03-14 13:13:16 UTC
My post is a bit off topic.

In NeoOffice if you right-click on NeoOffice icon (while app is running), there
is "Mac Os X options" and there "Ignore Trackpad Guestures".

The developers in NeoOffice may help you with solving this issue.
Comment 31 max.odendahl 2010-03-28 21:07:17 UTC
ok, according to tests of thatseattleguy, closing this issue

>>Still would prefer a dialogue to disable this functionality and/or set the
zoom >>speed. Of course.

please open a new issue for this if still interested
Comment 32 barkingbug 2010-08-20 03:44:37 UTC
I am curious if any workable solution was ever discovered here. It seems that this defect was upgraded to 
make the writer software move form terribly unusable on a macbook pro to simply not worth using. Does 
anyone out there still use Open Office on a macbook pro? I am a fairly new user, but after writing a few 
dozen pages, I realize that I have wasted a couple of frustrating hours with this bug. Lost cause? or am I 
missing something?

Too bad, because outside of this crippling bug the software seems stellar.
Comment 33 thatseattleguy 2010-08-21 05:21:58 UTC
I wrote after testing the current version that it was "barely controllable"...and they closed the bug as 
resolved. Sheesh - you'd expect that from Microsoft, not from open source developers.

1) Zoom is still way too fast and extremely difficult to control.
2) There should be a setting to slow this down AND a setting to disable it completely (could be the 
same dialogue).
3) There should be a simple key sequence to return the zoom to 100%.
4) Someone should re-open this bug or simply enter a brand-new one against the current version.

Really, OOo is not usable on a MacBook Pro or any new MacBook (with multi-touch) due to this; I'm not 
sure why it's not getting more attention. Maybe if some of the developers had to use a Mac laptop 
instead of their desktops for a day...
Comment 34 bafrank 2010-08-24 07:29:45 UTC
I will try submit another issue, since this one has been closed - though not resolved.

It seems that the QA lead on this issue has missed the point.  A bug that makes oo "unusable" or "barely 
useable" for a growing 5-10 percent of the computers out there may actually be MORE important than a 
crash on 1 percent.

I'm trying to find a workaround to this problem, other then shelling out for MSOffice, but still the zoom 
simply needs to be sperated from the pinch functionality of the Macbook and now all Mac products (pinch 
and zoom is part of Mac desktops as well.
Comment 35 bafrank 2010-08-24 08:02:40 UTC
Okay, being new I can't figure out how to re-open a bug.  Or open a related issue

THIS ISSUE IS NOT FIXED

It affects all MacBook users (osx 10.5 and up) and all users  who own a newer Mac desktop which has 
the pinch-open & close feature through Mac's new Magic Mouse.

If anyone is interested, the only workaround I've found is to turn-off the "pinch-open & close"feature in 
the trackpad settings.  This requires turning it back on to use in the rest of the universe of applications 
such as Safari where it is very useful or any photo editing software.

Hopefully ooO comes up with a useable solution.  As many have said, this bug renders Writer and Calc 
virtually unusable for Mac.

btw none of the update links listed in this issue work - they may already be a part of the current build.
Comment 36 bafrank 2010-08-24 08:03:07 UTC
Okay, being new I can't figure out how to re-open a bug.  Or open a related issue

THIS ISSUE IS NOT FIXED

It affects all MacBook users (osx 10.5 and up) and all users  who own a newer Mac desktop which has 
the pinch-open & close feature through Mac's new Magic Mouse.

If anyone is interested, the only workaround I've found is to turn-off the "pinch-open & close"feature in 
the trackpad settings.  This requires turning it back on to use in the rest of the universe of applications 
such as Safari where it is very useful or any photo editing software.

Hopefully ooO comes up with a useable solution.  As many have said, this bug renders Writer and Calc 
virtually unusable for Mac.

btw none of the update links listed in this issue work - they may already be a part of the current build.
Comment 37 max.odendahl 2010-08-24 08:29:20 UTC
while it works farelly well on a new macbook pro, I'll have another look at it
as soon as I find some time....
Comment 38 kasperta 2010-09-16 11:37:55 UTC
Using a magic mouse with my Mac Pro in calc, is just so utterly annoying too.

I do a lot of copy+paste, and whenever I have the CMD button pressed while moving the mouse, 
it activates the zoom feature, and everything gets very big or small depending on, whether i was 
trying to move the page up or down.

Oh how I wish I could somehow disable the zoom shortcut "CMD+moving the mouse"...

Regards, Kasper
Comment 39 florian 2010-09-16 22:04:36 UTC
Adding myself to cc.

@kasperta: Any special reason you have the zoom shortcut as CMD+Scroll instead of CTRL-Scroll?
Comment 40 kasperta 2010-09-17 08:15:19 UTC
No special reason that I am aware of, I don't think I have changed it.

In system preferences, mouse, screen zoom the shortcut on my machine is "Ctrl".

That means that in any app i can "ctrl+move mouse" to zoom, letting OS X enlarge all the pixels, I 
don't use it but it don't bother be. This also works in Openoffice. But OpenOffice also has it's own 
zoom set with the shortcut "cmd+move mouse", which makes OpenOffice do a real zoom (vector 
based).

It's the Openoffice shortcut that I would so very much like to disable, but I can't figure out a way 
to do it.

If I try to change the OS X pixel zoom shortcut to "CMD", I have now noticed that it overrules the 
OpenOffice shortcut. But sometimes, particularly after saving with "cmd+s" OpenOffice still does a 
crazy zoom. Most of the times though, the OS X zoom gains the upper hand.

But please please please - with sugar on top - add an option to disable the mouse/gesture zoom 
shortcut, it is annoying as hell and a usability catastrophy!
Comment 41 florian 2010-09-17 23:32:56 UTC
@kasperta:
OK, I see what you mean now. AFAICT from looking at the source CMD+Scrollwheel for Zooming inside 
OOo is currently hard-coded without any option to disable it.
If you want an option to disable the shortcut, please file a separate issue.
Comment 42 thorsten.ziehm 2010-09-23 15:08:58 UTC
OOo 3.3 is in showstopper-mode. This issue is too old to be a stopper for the
current release. I change the target to OOo 3.x. Please change the target
accordingly when a fix is near to be integrated into a code line. 
Comment 43 grrr 2010-09-29 04:48:40 UTC
_Make a priority fix to the zoom issue_
 
Astoundingly, OOO is <a
href="http://user.services.openoffice.org/en/forum/viewtopic.php?f=7&t=33666&start=0">bleeding</a>
users to Office due to the hardcoded zoom. I actually cared enough to register
just to have a say, what a nuisance.
Comment 44 hdu@apache.org 2010-09-29 07:59:34 UTC
Good news: A magic trackpad is on my way; soon I will have a system to debug and
solve the problem, stay tuned... reassigning to myself.
Comment 45 tomthetree 2010-09-29 08:31:45 UTC
@hdu: Great news. Best of luck with it :) 
Comment 46 kasperta 2010-09-29 13:42:06 UTC
@hdu:
If possible please take a look at issue 114643 too while you're at it: 
http://www.openoffice.org/issues/show_bug.cgi?id=114643
Comment 47 hdu@apache.org 2010-10-04 11:48:18 UTC
Fixed in CWS.  My fix here matches the apps preferred zoom granularity: Due to issue 114860 and related 
issues in other apps the smooth zoom feature has not been enabled yet. I separated that aspect out by 
filing the followup issue 114909.
Comment 48 mdxonefour 2010-10-05 11:25:19 UTC
MD: removing issue 114860 from field "depends on". From my point of view issue
114860 is only related to this one.
Comment 49 eric.savary 2010-10-05 13:13:09 UTC
.
Comment 50 hdu@apache.org 2010-10-07 08:52:04 UTC
please verify in CWS ooo33gsl10
Comment 51 oc 2010-10-07 09:26:54 UTC
verified in build cws_ooo33gsl10
Comment 52 hdu@apache.org 2010-10-11 12:52:57 UTC
Got into OOO330_m10 => closing
Comment 53 Raphael Bircher 2010-11-01 06:11:45 UTC
*** Issue 114643 has been marked as a duplicate of this issue. ***
Comment 54 hdu@apache.org 2010-11-01 09:47:13 UTC
*** Issue 114505 has been marked as a duplicate of this issue. ***
Comment 55 jiesa 2010-11-02 16:13:55 UTC
I was just told that this issue has been resolved, and I would like to inform
you that is has not.  I am using OpenOffice version 3.2.1 OOO320m18 (build:
9502).  The two-finger track pad zoom is still too sensitive.  I am getting
around this by clicking on the zoom bar in the lower right hand corner.  I am
not pleased by this.

I'd like it if there was a scroll speed throttle in the preferences.

This zoom issue is not restricted to Writer as previously stated, but also is an
issue in the spreadsheet, drawing and presentation editors.  I have not used the
other editors.
Comment 56 hdu@apache.org 2010-11-02 17:14:04 UTC
Older versions of OpenOffice.org 3 such as 3.2.1 do not have the fix. OpenOffice.org 3.3.0 which has it is 
currently only available as release candidate (from http://download.openoffice.org/index.html).
Comment 57 choi9999 2011-03-24 13:25:18 UTC
Hi -- I would like to say that this bug does not appear to be fixed.

I am running OpenOffice 3.3 on a Mac PowerBook, operating Mac OS 10.6.6.

Under System Preferences > Trackpad > Two Fingers, I have disabled "Pinch Open & Close." For "Screen Zoom," under the options, I set "Zoom While Holding" to "Control," but disabled "Screen Zoom" anyhow.

Nevertheless, for some reason, in OpenOffice, when I hold down "Command" and move two fingers on the trackpad, it zooms in and out. (Again, in System Preferences, I already disabled both "Pinch Open & Close" and "Screen Zoom," and for "Screen Zoom," "Zoom While Holding" is set to "Control," not "Command.")

The reason this is frustrating is because whenever I hold down "Command" to execute a function such as, say, saving a file, I inadvertently zoom in or out.

It seems that regardless of the System Preferences settings, OpenOffice on the Mac still sees that two-finger/Command combination as a zoom command.
Comment 58 choi9999 2011-03-24 13:29:29 UTC
Also, when I disable "Screen Zoom" as mentioned below, the two-finger/Command combination does not zoom in any other application. However, it still zooms in OpenOffice.

(In reply to comment #57)
> Hi -- I would like to say that this bug does not appear to be fixed.
> 
> I am running OpenOffice 3.3 on a Mac PowerBook, operating Mac OS 10.6.6.
> 
> Under System Preferences > Trackpad > Two Fingers, I have disabled "Pinch Open
> & Close." For "Screen Zoom," under the options, I set "Zoom While Holding" to
> "Control," but disabled "Screen Zoom" anyhow.
> 
> Nevertheless, for some reason, in OpenOffice, when I hold down "Command" and
> move two fingers on the trackpad, it zooms in and out. (Again, in System
> Preferences, I already disabled both "Pinch Open & Close" and "Screen Zoom,"
> and for "Screen Zoom," "Zoom While Holding" is set to "Control," not
> "Command.")
> 
> The reason this is frustrating is because whenever I hold down "Command" to
> execute a function such as, say, saving a file, I inadvertently zoom in or out.
> 
> It seems that regardless of the System Preferences settings, OpenOffice on the
> Mac still sees that two-finger/Command combination as a zoom command.
Comment 59 eric.savary 2011-03-24 13:40:06 UTC
This is a different problem from the current issue.
File a new issue for this.