Issue 102875

Summary: Starting Help from Dialog "Find and replace" crashes the office in second try
Product: Writer Reporter: cno
Component: codeAssignee: ab
Status: CLOSED IRREPRODUCIBLE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: issues
Version: DEV300m50Keywords: crash, regression
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description cno 2009-06-17 14:55:21 UTC
- start OOo
- new writer doc, Enter
- Ctrl-F
- hit the Help button
 > Crash

had the same (once) this morning when starting Help from the Help menu.

Crash report ID rtpfpkc
Comment 1 Olaf Felka 2009-06-17 15:07:07 UTC
I can't reproduce. Any special setting to reproduce this?
@ sba: Any ideas on this?
Comment 2 cno 2009-06-18 15:40:49 UTC
An issue from me and people start talking about "special settings" :-D

OK, tried again.
First try > false (no crash)
closed OOo completely
Second try > positive, Crash

I'll add the crash report ID when I recieve it.
Comment 3 cno 2009-06-18 20:42:26 UTC
The ID of the error report is rqmppkc
Comment 4 cno 2009-06-26 13:03:26 UTC
any idea on this?

The ID of today's error report is r5sfskc
Comment 5 michael.ruess 2009-07-17 11:55:05 UTC
Very odd crash, you have to do the described steps twice (including start of
Office. Then Writer will crash when opening Help via "Find and replace" dialog.
Did not crash in OOo 3.1.
Comment 6 Oliver Specht 2009-07-17 14:31:43 UTC
->ab: your job?

ChildEBP RetAddr  
014bef9c 60108e76 sal3!rtl_ImplGetFastUTF8UnicodeLen+0x9
[o:\dev300\src.m52\sal\rtl\source\ustring.c @ 525]
014befbc 60108fab sal3!rtl_string2UString_status+0x81
[o:\dev300\src.m52\sal\rtl\source\ustring.c @ 608]
014befdc 556f1f48 sal3!rtl_string2UString+0x19
[o:\dev300\src.m52\sal\rtl\source\ustring.c @ 724]
014bf008 556f5409 ucpchelp1!rtl::OUString::OUString+0x1e
[o:\dev300\wntmsci12.pro\inc.m52\rtl\ustring.hxx @ 190]
014bf040 556fe59d ucpchelp1!chelp::DbtToStringConverter::getTitle+0x57
[o:\dev300\src.m52\xmlhelp\source\cxxhelp\provider\urlparameter.hxx @ 108]
014bf0d8 556feaea ucpchelp1!chelp::KeywordInfo::KeywordElement::init+0x29a
[o:\dev300\src.m52\xmlhelp\source\cxxhelp\provider\databases.cxx @ 835]
014bf10c 55700949
ucpchelp1!chelp::KeywordInfo::KeywordElement::KeywordElement+0x5a
[o:\dev300\src.m52\xmlhelp\source\cxxhelp\provider\databases.cxx @ 768]
014bf258 557028f3 ucpchelp1!chelp::Databases::getKeyword+0x2bb
[o:\dev300\src.m52\xmlhelp\source\cxxhelp\provider\databases.cxx @ 972]
014bf334 55703133 ucpchelp1!chelp::Content::getPropertyValues+0x2c3
[o:\dev300\src.m52\xmlhelp\source\cxxhelp\provider\content.cxx @ 510]
014bf3a8 5c6358e6 ucpchelp1!chelp::Content::execute+0x9a
[o:\dev300\src.m52\xmlhelp\source\cxxhelp\provider\content.cxx @ 449]
014bf3ec 5c635b72 ucbhelper4MSC!ucbhelper::Content_Impl::executeCommand+0x51
[o:\dev300\src.m52\ucbhelper\source\client\content.cxx @ 1809]
014bf444 5c6373f1
ucbhelper4MSC!ucbhelper::Content::getPropertyValuesInterface+0xb9
[o:\dev300\src.m52\ucbhelper\source\client\content.cxx @ 686]
014bf488 10049745 ucbhelper4MSC!ucbhelper::Content::getPropertyValues+0x21
[o:\dev300\src.m52\ucbhelper\source\client\content.cxx @ 623]
0
Comment 7 cno 2009-07-17 16:34:15 UTC
It does not crash for me in DEV300m53 ...

When I had it the first time, some crashes appeared also on other moments with
help. Did not have that recently, but might by a co-incidence?

I'll try to keep an eye on it.
Comment 8 ab 2009-07-27 08:42:14 UTC
According to the stack this indeed is my job. I tried on
dev300 m51, but so far I could only try on Linux and
couldn't reproduce it either.

-> cornouws: Did you choose OS==Windows because
that's the only platform you've checked or are you sure
that it does not occur on other platforms?

As this is so hard to reproduce this probably is no P2,
anyway STARTED
Comment 9 cno 2009-07-27 10:07:19 UTC
@ ab: I only tried on WinXP

As written op July 17: "It does not crash for me in DEV300m53" (I should have
written m52)

As can be seen from my initial tests and the error reports, it did happen
regularly in a DEV300m50.

I will try few more times in the next version, but if it cannot be reproduced
and you cannot reproduce either, it just has disappeared..
Comment 10 ab 2009-09-03 14:08:43 UTC
Not reproducible any more -> WORKSFORME
Comment 11 Mechtilde 2009-09-08 14:06:11 UTC
worksforme -< closed