Issue 103105

Summary: EMF export broken
Product: Draw Reporter: brainy <jan.oltmann>
Component: save-exportAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 3.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
original test file
none
exported emf file (corrupt) none

Description brainy 2009-06-25 17:42:51 UTC
Since OOo 3.1 the EMF Export from Draw no longer seems to work.
Windows, IrfanView and Adobe Photoshop are showing blank pages or report errors
if I try to open the exported emf file.
I have tested it on two different PCs with the same result.

With OOo 3.0 it seemed to work, but the images sometimes looked jagged.
So I updated and now it doesn't work at all.
Comment 1 brainy 2009-06-25 17:44:13 UTC
Created attachment 63213 [details]
original test file
Comment 2 brainy 2009-06-25 17:49:29 UTC
Created attachment 63214 [details]
exported emf file (corrupt)
Comment 3 wolframgarten 2009-07-01 10:12:46 UTC
Works with a rectangle but not with an ellipse... Reproducible, Reassigned.
Comment 4 scot23 2009-08-16 18:04:34 UTC
Yes, EMF is seriously broken.  Could the priority be raised ? 
Does seem to be allergic to circles and freelance curves
Diagrams with just rectangles and lines are ok.  

I also noted that some other formats are broken too: 
GIF with Save Transparancy is distorting the colors.
WMF is truncating the edges. 
XPM reported a "decode error" from Ifranview. 

PNG,BMP,JPG(90%), and TIF are working so far, but I notice some "fuzzyness", not
sure if that is just my monitor though. 
Comment 5 sven.jacobi 2009-09-28 13:33:55 UTC
changed target