Issue 103539

Summary: Inserting file in writer document inserts content as "hidden"
Product: Writer Reporter: Daniel Benkmann <shenmux09>
Component: open-importAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: clippka, issues, michael.brauer, mst.ooo, niklas.nebel
Version: OOo 3.1Keywords: regression
Target Milestone: 3.4.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
document to be inserted none

Description Daniel Benkmann 2009-07-14 14:11:25 UTC
Steps to reproduce:
Use "Insert->File..." to insert the document AbtKopf.ott attached to this issue.
Result: The contents of AbtKopf.ott are not inserted in the current document
(although the language settings of AbtKopf.ott seem to be imported).

Inserting the same file in OOo 2.4 works.
Comment 1 Daniel Benkmann 2009-07-14 14:12:49 UTC
Created attachment 63541 [details]
document to be inserted
Comment 2 michael.ruess 2009-07-14 14:55:43 UTC
MRU->OS: insert the attached file into an empty Writer document -> the inserted
content will have the "hidden" attribute.
Looks, that this broke somewhere between OO 2.4 and 2.4.x
Comment 3 Daniel Benkmann 2009-07-14 15:27:09 UTC
Oh, I didn't notice that the 'display="none"' attribute was set in the attached
document. Looks like this issue is related to this one then:
http://qa.openoffice.org/issues/show_bug.cgi?id=96878

Looks like the fix of that issue does not work correctly when inserting a file.

May also be related: http://www.openoffice.org/issues/show_bug.cgi?id=103137
Comment 4 Daniel Benkmann 2009-07-21 15:15:29 UTC
Just to clarify the scope of this issue:
The effect of this issue is that every ODF document created with OOo 2.x which
uses text:display="none" or text:display="true" can't be inserted into OOo 3
documents using Insert->File without hiding/unhiding the wrong parts of the
inserted document. So basically ODF documents created with OOo 2.x become
incompatible with OOo 3.
Comment 5 Daniel Benkmann 2009-12-04 09:34:48 UTC
Added regression keyword; changed Platform to All
Comment 6 thorsten.ziehm 2010-11-09 10:11:23 UTC
OOo 3.3 is nearly final. I change the target of this issue to OOo 3.x. Please
find a solution and set a correct target, if you know when a fix can be integrated.
Comment 7 mst.ooo 2011-03-01 13:33:18 UTC
mine
Comment 8 mst.ooo 2011-03-01 15:50:37 UTC
the problem here is that the BuildId from the generator in meta.xml
is not available when using Insert->File.

this could cause other problems than just this issue,
so i've tried to fix it in all applications.

now Writer, Calc and Draw always load the meta.xml stream on ODF import.
of course document properties are only initialized if it is really a load.

before Calc and Draw did not load meta.xml in OrganizerMode 
(File->Templates->Organize), and Writer in OrganizerMode, Insert->File,
BlockMode (which is probably AutoText), and StyleImport (from the
stylist->Load Styles...)

starmath and reportdesign did already unconditionally load meta.xml

fixed in CWS sw34bf04
http://hg.services.openoffice.org/hg/cws/sw34bf04/rev/d470e622cd4d
Comment 9 michael.ruess 2011-03-15 15:16:08 UTC
Verified fix in CWS sw34bf04.