Issue 103648

Summary: bibliography title numbering not working
Product: Writer Reporter: romanfi <rfoo>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 3.1 RC2   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description romanfi 2009-07-20 08:56:52 UTC
I edit the index/table entry of type Bibliography and in the tab Styles I set 
the title entry to style "Heading 2". Now I update all or the bibliography. 
When I now check the created outline numbering, the numbering is wrong.

I have three other chapters above the bibliography entry all with 
style "Heading 2", their numbering is correct (e.g. 1.1, 1.2, 1.3). When I 
click on the non mutable heading of the bibliography table I see "Heading 2" 
in the toolbar, but nevertheless the title is numbered "2" instead of "1.4".

When I right click on the bibliography, then Edit Index/Table, then the tab 
styles, then on "Title" and "Heading 2" in the two columns, then on the Edit 
button in the lower right, I get the correct paragraph style dialog, and I can 
see the correct entries Outline: Level 2 and Numbering: Outline Numbering in 
the Outline&Numbering tab.
Comment 1 eric.savary 2009-07-20 09:18:28 UTC
@OS: when having:

1.1 <heading 2>
1.2 <heading 2>
1.3 <heading 2>
<biblio>
Biblio title
Biblio entries
</bibilio>

and mapping Heading 2 to Biblio Title, it should look like:
1.4 Biblio title

Instead it looks like:
2 Biblio title

It used to work in OOo 2.4.
Comment 2 Oliver Specht 2009-07-20 10:27:55 UTC
Reassigned to od
->od: The Heading2 is actually used. Only the numbering is from Heading1.

Comment 3 Marcus 2017-05-20 11:15:54 UTC
Reset assigne to the default "issues@openoffice.apache.org".