Issue 103733

Summary: Compare document between empty document and a docment with notes and changing record, crash OOo
Product: Writer Reporter: amy2008 <amy2008>
Component: codeAssignee: mst.ooo
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: issues, ooo.redflag, peter.junge, zhuangyuelin
Version: DEV300m52Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84292    
Attachments:
Description Flags
Document to reproduce none

Description amy2008 2009-07-23 06:55:58 UTC
Can reproduce it in DEV300m52 on WinXP and Fedora

How to reproduce it
1 Open a new Writer doc, enter nothing in this file, save it as first.odt
2 Open another new Writer doc, Ctrl+Enter to new a page
3 Insert - Note to insert notes in these two pages respectively
4 Set cursor on the second page, Edit - Changes - Record, enter some characters,
  Edit - Changes - Accept or Reject, Accept or Reject Changes dialog opens, 
  click "Accept all" button
5 Edit - Compare document, "Insert" dialog opens, select the document first.odt
  which you just saved it at step 1, Accept or Reject Changes dialog opens,
  click "Reject all" button

Result
OOo crashes

Expectation
OOo works well

Regards
Li Meiying
Comment 1 amy2008 2009-07-23 07:01:19 UTC
Can reproduce it in OOo2.4.1, old issue
Comment 2 michael.ruess 2009-07-23 11:55:55 UTC
Created attachment 63697 [details]
Document to reproduce
Comment 3 michael.ruess 2009-07-23 11:57:36 UTC
MRU->MST: easier to reproduce with the attached document. Just open it, compare
against an empty saved one via "Edit.Compare documents", then "Reject all" -> crash
Comment 4 mst.ooo 2009-11-04 15:24:07 UTC
a bit of debugging reveals that we crash in SwPageFrm::Cut, because the very
last page of the document is being deleted.
this unfortunate deletion due to the fact that the nodes array of the document
is empty, i.e., it does not contain a single text node in the body.
the text nodes were all removed by rejecting the redlines.

thus, this issue is a duplicate of i73682.

*** This issue has been marked as a duplicate of 73682 ***
Comment 5 mst.ooo 2009-11-04 15:25:16 UTC
close duplicate