Issue 103848

Summary: Copy/Paste to TextWrangler and iChat adds newline
Product: Writer Reporter: eclecticblue <loriannderson>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P4 CC: issues
Version: OOo 3.1   
Target Milestone: ---   
Hardware: Mac   
OS: Mac OS X, all   
URL: http://user.services.openoffice.org/en/forum/viewtopic.php?f=17&t=20879
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
I have attached an example of the types of files I have been using--they were created on other machines using Microsoft Word. none

Description eclecticblue 2009-07-27 23:18:58 UTC
I have Mac OS X v.10.5.7, OOo v.3.1.0, and TextWrangler v.2.3. When I copy
anything from Writer (whole paragraph or a portion of a line) or Calc (whole
cell, portion of a cell, or multiple cells) to TextWrangler, it adds a new line
at the end of the pasted portion. This also happens when pasting into an iChat
window, but does not happen when pasting into Firefox, Safari, or Thunderbird.
This has been reproduced by another user in the OOo Community Forum.
Comment 1 eclecticblue 2009-07-27 23:20:37 UTC
Created attachment 63812 [details]
I have attached an example of the types of files I have been using--they were created on other machines using Microsoft Word.
Comment 2 eric.savary 2009-07-27 23:51:59 UTC
@OD: I noted in issue 90511

------- Additional comments from es Fri Jun 27 14:35:25 +0000 2008 -------

Regression fixed for editors like notepad or jedit.
There has always been this problem with wordpad. Feel free to file another issue
for this.

Verified in cws sw30bf06
---------------------

I think this is this issue here.
Comment 3 Larry Gusaas 2009-07-28 00:30:21 UTC
This is not the same as issue 90511. It has nothing to do with notepad or jedit or wordpad.

This is occurring on Mac OS 10.5.x which does not use those editors.

I tested and confirmed the problem using TextWrangler. Problem also occurs using TextEdit(Mac's 
native text editor) and withTex-Edit Plus.

I also tested the example file opened in Apples pages.app. After pasting, the cursor was placed 
immediately after the pasted text, not on a new line like is done from OO.o.

I also tested with .odt files. Same results.
Comment 4 michael.ruess 2009-07-28 09:02:32 UTC
Maybe this has the same root cause as issue 99529? Should be checked with 300m53
or m53 where issue 99529 is fixed.
Comment 5 Larry Gusaas 2009-07-29 02:10:34 UTC
Manage to check briefly with DEV300_m53 before it froze. Got same results as before.
Comment 6 gallomimia 2009-10-26 04:13:08 UTC
I can confirm this issue. I copied the original post and some other text to the writer program, version 
installed from OOo_3.1.1rc2_20090827_MacOSXPowerPC_install_en-GB.dmg running under MacOSX 
10.5.8

I used TextWrangler version 3.0 (2538) of Sat, 22 Aug 2009 to complete these tests. I tried several 
other clippings to try and reproduce the bug without OOo involved. No dice.

I tried changing the line ending schema for the TextWrangler document and reproduced the bug in all 
three instances.

I have also tried pasting into TextEdit, Adium (adium.im), Terminal, Colloquy and Skype. TextEdit and 
Adium both yielded the bug, but Skype, Terminal and Colloquy did not.

I can't think of any other programs to test this with.
Comment 7 gallomimia 2009-10-30 02:37:10 UTC
Confirmed. I will begin to hunt for the code related to this issue.
Comment 8 Marcus 2017-05-20 11:24:49 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 9 Marcus 2017-05-20 11:25:58 UTC
Reset assigne to the default "issues@openoffice.apache.org".