Issue 104074

Summary: Proxy setting "System" should not prevent setting of "No proxy for"
Product: General Reporter: mux2005 <mux2005>
Component: uiAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: elish, issues
Version: OOO310m11Keywords: needhelp
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description mux2005 2009-08-07 07:07:52 UTC
The Tools/Options/Internet/Proxy UI does not allow setting "No proxy for" when
the proxy is set to "System". This is overly restrictive. There are several
scenarios when it makes sense to exclude certain servers from being proxied even
if you otherwise want to use your system's proxy setting. In my case the proxy
is not supposed to be used for connections to local Intranet servers (because
obviously a direct connection is faster and causes less network traffic).

I have created an extension which sets the following config

<prop oor:name="ooInetProxyType" oor:finalized="true">
   <value>1</value>
</prop>
<prop oor:name="ooInetNoProxy" oor:type="xs:string" oor:finalized="true">
 <value>*.mylocaldomain.de</value>
</prop>

i.e. the combination of "System" and a "no proxy for" list and it seems to work.
The proxy is used for Internet connections but not for mylocaldomain.de. So it
seems that it is only the UI that prevents the setting of this combination. The
actual network code seems to deal with it just fine.

I request that the UI be changed to allow setting a "No proxy for" list even
when "System" proxy is selected.