Issue 104212

Summary: Non-breaking spaces broken in PDFs when scale width not equal 100%
Product: gsl Reporter: Marc Wuillemin <marc.wuillemin>
Component: codeAssignee: h.ilter
Status: CLOSED FIXED QA Contact: issues@gsl <issues>
Severity: Trivial    
Priority: P3 CC: hdu, issues, rainerbielefeld_ooo_qa
Version: OOO310m18Keywords: oooqa, regression
Target Milestone: OOo 3.2   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Simple test document.
none
Resulting PDF.
none
minimal bugdoc none

Description Marc Wuillemin 2009-08-13 16:52:50 UTC
Non-breaking spaces (created using CTRL+SHIFT+SPACE) in text where the character
scale width is not equal to 100% do not appear properly when the document is
exported as PDF.
Comment 1 Marc Wuillemin 2009-08-13 16:56:26 UTC
Created attachment 64138 [details]
Simple test document.
Comment 2 Marc Wuillemin 2009-08-13 16:57:43 UTC
Created attachment 64139 [details]
Resulting PDF.
Comment 3 Marc Wuillemin 2009-08-14 09:59:18 UTC
This is a regression from version 3.1.0. It also appears on Linux.
Comment 4 Rainer Bielefeld 2009-08-14 10:12:05 UTC
I checked "test.odt" with "Ooo Dev 3.2.0 multilingual version English UI WIN XP:
[DEV300m53 (Build 9412)]" and can confirm the reported effect.

Works fine with "Ooo 3.1.0 WIN XP multilingual version German UI activated 
[OOO310m11 (Build 9399)]"

I also see the problem in CALC and DRAW (where I insert NBS using 'Insert ->
Special Character...'
Comment 5 philipp.lohmann 2009-08-14 10:16:50 UTC
pl->hdu: please have a look
Comment 6 hdu@apache.org 2009-08-21 11:29:04 UTC
Also reproducible on >=DEV300_m55. Nice bugdoc! Analyzing...
Comment 7 hdu@apache.org 2009-08-24 10:40:05 UTC
Created attachment 64337 [details]
minimal bugdoc
Comment 8 hdu@apache.org 2009-08-24 15:15:31 UTC
Fixed in CWS vcl104.
When the active text matrix was anisotropic the PDF-TJ adjustment offsets were wrongly calculated.
Comment 9 hdu@apache.org 2009-08-24 15:20:35 UTC
*** Issue 104409 has been marked as a duplicate of this issue. ***
Comment 10 hdu@apache.org 2009-08-25 13:47:38 UTC
@hi: please verify in CWS vcl104
Comment 11 h.ilter 2009-09-01 09:25:11 UTC
Verified with cws vcl104 = OK
Comment 12 Marc Wuillemin 2009-09-16 11:56:12 UTC
For those who are interested:
Fixed in DEV300m58 (Build:9423).

Cheers.
Comment 13 hdu@apache.org 2009-10-19 14:55:53 UTC
*** Issue 105186 has been marked as a duplicate of this issue. ***
Comment 14 hdu@apache.org 2009-10-28 10:33:08 UTC
*** Issue 96277 has been marked as a duplicate of this issue. ***
Comment 15 Rainer Bielefeld 2009-11-07 08:57:46 UTC
*** Issue 106695 has been marked as a duplicate of this issue. ***