Issue 104513

Summary: Writer notes containing hyperlink cannot be read by API
Product: Writer Reporter: bmarcelly <marcelly.bernard>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: elish, issues, max.odendahl, tj
Version: OOo 3.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows, all   
Issue Type: DEFECT Latest Confirmation in: 4.1.0-beta
Developer Difficulty: ---
Attachments:
Description Flags
Document contains notes containing hyperlink none

Description bmarcelly 2009-08-26 10:33:48 UTC
When you write a note containing a Web address, it is automatically converted in a 
hyperlink inside the note.

I have found that such note cannot be read consistently using the API.
Moreover the API returns different results depending on the circumstances :
- after loading the document, the note text cannot be read correctly.
- after modifying anything in the document text and saving, the note text can be read 
through TextRange but not through Content.
- after another reload, again the note text cannot be read correctly.

The consequence is that you cannot be sure of reading the contents of a Writer note.

Next attachment is a Writer document containing 2 notes and a small macro as proof. 
Follow exactly the steps indicated in the document.
Comment 1 bmarcelly 2009-08-26 10:34:50 UTC
Created attachment 64385 [details]
Document contains notes containing hyperlink
Comment 2 eric.savary 2009-09-14 23:52:08 UTC
Reassigned to JSK
Comment 3 max.odendahl 2009-09-15 03:25:01 UTC
no idea about the API, I guess os is the right guy for it.....
Comment 4 hans_werner67 2011-03-28 11:55:37 UTC
Assign to new default-assignee
Comment 5 eric.savary 2011-04-11 07:20:12 UTC
Reassigned to TBO.
Comment 6 b.osi.ooo 2011-04-11 14:01:45 UTC
Then let's take the sugestion from mod: OS here you are.
Comment 7 Edwin Sharp 2014-03-13 08:37:33 UTC
Confirmed with
AOO410m14(Build:9760)  -  Rev. 1573601
2014-03-03 17:47:48 (Mo, 03 Mrz 2014)
Win 7
Comment 8 Ariel Constenla-Haile 2014-03-13 17:59:17 UTC
The problem described here is not only limited to the API:

- Open the Navigator, expand the "Comments"
- You see two comments:

external1
external2

- Edit the external1 comment, adding a space, then place the cursor in the document body
- Now the Navigator displays 

external1 http://www.hello.com/ 
external2