Issue 104728

Summary: Opening multiple documents from WIN Explorer causes hang
Product: General Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 3.1.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Test kit, pls. see original report none

Description Rainer Bielefeld 2009-09-02 17:19:27 UTC
Steps to reproduce:

First see how it should work:
0. Download and unpack "testkit.zip"
1. Close your OOo, Start WIN Task Manager
2. Browse folder to where you unpacked "testkit.zip"
3. open "test0.odt" (or any other document in folder) by doubleclick
4. Slect OOo dialogs in menu 'Tools -> Options -> OOo -> General'
5. Menu 'File -> Open', browse for folder to where you unpacked "testkit.zip"
6. Mark some 30 documents in file overview pane
7. <Open>
   Expected: All Documents should be opened with only one "soffice.bin" process
             (check in WIN Task Manager), 2 new documents will be opened 
              each second
   Actual: as expected
8. Close OOo

Now the problem:
11. Close your OOo, start WIN Task Manager if necessary
12. Browse folder to where you unpacked "testkit.zip"
16. Mark some 30 documents in the file name overview
17. rightclick, context menu "Open"
   Expected: All Documents should be opened with only one "soffice.bin" process
             (check in WIN Task Manager)
   Actual: lots of "soffice.bin" processes will be started 
           (check in WIN Task Manager), excessive CPU load, 
           it will take endless time for each document to be opened

This sounds very similar to Issue 81988, but that should have been fixed for
2.3.1? Regression?
Comment 1 Rainer Bielefeld 2009-09-02 17:21:32 UTC
Created attachment 64503 [details]
Test kit, pls. see original report