Issue 104911

Summary: RPT: date/time field not working anymore
Product: Base Reporter: Frank Schönheit <frank.schoenheit>
Component: ReportBuilderAssignee: marc.neumann
Status: CLOSED FIXED QA Contact: issues@dba <issues>
Severity: Trivial    
Priority: P3 CC: issues, ulger
Version: DEV300m57   
Target Milestone: OOo 3.2   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 99999    
Attachments:
Description Flags
document to reproduce the bug case none

Description Frank Schönheit 2009-09-09 09:24:47 UTC
(outsourcing this as separate issue from
http://www.openoffice.org/issues/show_bug.cgi?id=100535#desc10)
- open the attached database document
- open the report "rpt_tiere" for editing
- via "Insert / Date/Time", insert date/time fields into the report header
- execute the report
=> neither the date nor the time field show the correct value, instead they
   show 30.12.99 resp. 00:00.
Comment 1 Frank Schönheit 2009-09-09 09:25:47 UTC
targeting to 3.2, as this is a regression between OOo 3.1 and m57.
Comment 2 Frank Schönheit 2009-09-09 09:27:57 UTC
nominating as 3.2 blocker by adding issue dependency
Comment 3 Frank Schönheit 2009-09-09 09:29:22 UTC
Created attachment 64636 [details]
document to reproduce the bug case
Comment 4 ud 2009-09-09 19:24:28 UTC
Add myself on cc
Comment 5 ocke.janssen 2009-09-10 06:56:20 UTC
It is no regression, it never worked. 
The problem is the group header which is set to repeat.
In this case the group header is included inside the styles.xml file like the
page header. But unfortunately the values for the auto fields must be in the
first table in the content.xml and at the moment they are written in the
styles.xml in the group header.
Comment 6 ocke.janssen 2009-09-10 07:47:17 UTC
Fixed in cws dba32h
Comment 7 ocke.janssen 2009-10-05 07:52:51 UTC
Please verify. Thanks.
Comment 8 marc.neumann 2009-10-07 08:25:56 UTC
verified in CWS dba32h

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32h
Comment 9 r4zoli 2009-10-17 09:26:18 UTC
Verifed in OOO320_m2.
Closing.