Issue 104913

Summary: Faulty formatting during import of CSV file
Product: Calc Reporter: prowlerdk <janfk>
Component: formattingAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P5 (lowest) CC: issues, rb.henschel
Version: OOo 3.1.1Keywords: oooqa
Target Milestone: ---   
Hardware: Mac   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Show cell format before and after import. none

Description prowlerdk 2009-09-09 10:11:18 UTC
Upon importing a CSV file from the Magento webshop system, some cells is
altering formatting. The cells in question is changing from "numbers" to "date".
See link:

http://picasaweb.google.com/ProwlerDK/MagentoCSV?feat=directlink

It seemes that certain prices (figures/ciffer) is causing the cell formatting to
change. I tried to enter the same price i the above cell and the exact same
thing happended. When putting 8.0000 in the formula bar (cell formatted as
number) it changes to DATE.

I could do a screencast if needed to clarify.

This issue is vital (to me) since calc is the only app.(to my knowledge) that
can handle utf-8 csv file.
Comment 1 prowlerdk 2009-09-09 10:19:12 UTC
Created attachment 64638 [details]
Show cell format before and after import.
Comment 2 Regina Henschel 2009-09-10 18:44:48 UTC
You can determine for each column, which format it should use in the import
dialog. If the data has decimal numbers, which use a dot as decimal delimiter,
then you have to set the format to "US English". Click on the column header,
then the drop down list 'Column type' is active.

The problem, that the number recognition does not handle it correct for format
"standard" is already tracked in issue 87999.

*** This issue has been marked as a duplicate of 87999 ***
Comment 3 Regina Henschel 2009-09-10 18:45:16 UTC
closing duplicate