Issue 105172

Summary: OpenOffice does not show a warning when Gnome is closed and documents are still unsaved
Product: General Reporter: dkrogh <dkrogh63>
Component: uiAssignee: Olaf Felka <olaf-openoffice>
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P2 CC: issues, joerg.skottke, marcus, Mathias_Bauer, mikhail.voytenko, philipp.lohmann
Version: OOO310m11Keywords: data_loss
Target Milestone: OOo 3.2   
Hardware: All   
OS: Unix, all   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 99999    
Attachments:
Description Flags
The configuration file that can be copied in user configuration to turn the new behavior on.
none
testcase SR72383802 none

Description dkrogh 2009-09-18 10:57:58 UTC
When the user closes his Gnome session and has still unsaved OpenOffice.org
documents, OpenOffice.org is forced to close without asking if the unsaved
documents should be saved. The result is that the user has to go thru the
restoring process when he starts OpenOffice.org again.

Under other OS'es (Windows, Linux) OpenOffice asks for each document, if it
should be saved. The shutdown process is on hold during this time. That's why I
declare this a bug. OpenOffice.org should behave the same in this case on all
platforms.
Comment 1 dkrogh 2009-09-22 13:44:10 UTC
I increased the priority of this issue to P2, because data may get lost. If the
user simply forgot that he has still a StarOffice session running (becuase he is
working on another desktop) information may get lost when shutting down the
Gnome session.

I also want to add that Gnome itself is able to handle applications with unsaved
documents. Its own text editor shows a warning when Gnome is being shut down and
there are still unsaved documents.
Comment 2 mikhail.voytenko 2009-10-05 09:37:58 UTC
As far as I know, at the time when the session close implementation was done,
the Gnome did not allow to stop session close and show a dialog. We had just
some seconds ( depending from configuration ) to store the open documents.
Otherwise the user has got dialog to kill the office, that was recognized as not
acceptable.

If the new versions of Gnome have the mechanics to handle the unsaved documents
without getting dialog to kill the application, we should of course use it.

Comment 3 Marcus 2009-10-05 13:24:41 UTC
MLA->MAV: as discussed please have a look when appropriate

set me on CC
Comment 4 joerg.skottke 2009-10-21 09:59:56 UTC
CC me
Comment 5 mikhail.voytenko 2009-10-21 10:14:51 UTC
Changing the issue type, since the current behavior is a designed one ( that of
course does not mean that we should not change it, if it is possible now ).
Comment 6 mikhail.voytenko 2009-10-21 10:15:38 UTC
Setting the target to 3.3
Comment 7 Marcus 2009-10-26 10:14:20 UTC
changed platform and OS because Linux has be taken into account, too
Comment 8 mikhail.voytenko 2009-11-16 11:52:00 UTC
Adding pl in CC.
Comment 9 thorsten.martens 2009-11-16 12:06:33 UTC
assigned to mav
Comment 10 mikhail.voytenko 2009-12-03 11:21:17 UTC
Unfortunately at least some Gnome versions/configurations are not able to handle
the scenario correctly. In case an application request from Gnome to show UI on
shutdown, and the user is not fast enough to react to the dialog, the Gnome
session manager just crashes. I have reproduced it with GEdit ( Gnome standard
text editor ), so it is definitely a problem of the Gnome shutdown process.

Anyway, the solution is now introduced in cws fwk128. Many thanks to pl for
implementing the vcl part.

Since a Gnome configuration might have a problem with the solution as described
above, the new behavior is not active per default. To turn it on the new
configuration property
"org.openoffice.Office.Recovery/SessionShutdown/DocumentStoreUIEnabled"
should be set to true.
Comment 11 mikhail.voytenko 2009-12-04 12:12:15 UTC
mav->of: Please verify the issue. Please test the default behavior, that should
be as before, and the new behavior that is turned off per default.

In addition please test the session shutdown on Windows to be sure that the
behavior is not affected.
Comment 12 mikhail.voytenko 2009-12-04 12:14:52 UTC
Created attachment 66490 [details]
The configuration file that can be copied in user configuration to turn the new behavior on.
Comment 13 Olaf Felka 2009-12-08 14:48:26 UTC
of: The fix is ok for me. Seen Solaris and Ubuntu. Default settings and
configuration property
"org.openoffice.Office.Recovery/SessionShutdown/DocumentStoreUIEnabled" working
fine.
Comment 14 Olaf Felka 2009-12-08 19:30:16 UTC
adjusting target
Comment 15 rene 2009-12-09 12:36:44 UTC
mv: is there more info on the affected GNOME versions/configs? So I can decide
whether to enable it per default in Debian or not?
Comment 16 philipp.lohmann 2009-12-09 12:43:58 UTC
@rene: not really, but you can check by
- start gedit
- modify the default doc
- log out of gnome

-> a dialog should appear asking you to save or not

On the affected systems, you wait for a while (30s or so) and then the session
manager crashes, resulting in another dialog telling that it has crashed.
Comment 17 aviret 2010-05-21 08:52:21 UTC
Created attachment 69553 [details]
testcase SR72383802
Comment 18 aviret 2010-05-21 08:52:56 UTC
Hello,

This issue is not quite fixed IMHO.

When you save the document before closing the session, I think that's StarOffice
is killed just after having saved the document and during the handling of the
kill signal, it's still using the previous method of silent save. At the
reopening of StarOffice, it restores a previously saved document.

Please see the attached document SR72383802.

Best regards,
 Alain