Issue 105471

Summary: New crash in impress when closing office after opening task panel
Product: Impress Reporter: clippka
Component: uiAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P2 CC: issues, wolframgarten
Version: DEV300m60Keywords: regression
Target Milestone: OOo 3.2   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 99999    

Description clippka 2009-09-30 10:25:35 UTC
Start a new impress
Open "Master Pages" in the  task panel on the right
Now close the office *before* all templates are loaded -> CRASH

cl->af: sd::TemplateScanner::~TemplateScanner crashes
Comment 1 clippka 2009-09-30 10:27:18 UTC
changing version, adding keyword regression
Comment 2 groucho266 2009-09-30 14:07:14 UTC
A recent change (master fix for the DEV300 m60) triggered this crash.  The
SdModule object is destroyed and removed from the global AppData vector but is
accessed after this nonetheless. Before the fix this went undetected because the
dead SdModule structure  was by coincidence not yet overwritten and held its old
values.

Reordered the statements in the SdModule destructor to avoid this in the future.

SVN revision is 276556.
Comment 3 groucho266 2009-10-19 10:46:22 UTC
@wg: Please verify.
Comment 4 wolframgarten 2009-10-20 13:28:36 UTC
Verified in CWS.
Comment 5 Raphael Bircher 2010-02-08 17:08:51 UTC
phu, this issue request a good reaction ;-) But seems to be ok.

closing Issue