Issue 106350

Summary: Mac: Impress Paint Error When Activating Text Frame
Product: Impress Reporter: kai.sommerfeld
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, nesshof, rbircher
Version: OOO320m2   
Target Milestone: ---   
Hardware: All   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
The presentation for reproduction of the bug.
none
A screenshot demonstrating the bug. none

Description kai.sommerfeld 2009-10-27 15:33:45 UTC
See attached screen shot. Happens when selecting the text content of a text
frame in the attached presentation. I'm using Mac OS X 10.6.1

I suggest to fix this for 3.2
Comment 1 kai.sommerfeld 2009-10-27 15:37:15 UTC
Created attachment 65681 [details]
The presentation for reproduction of the bug.
Comment 2 kai.sommerfeld 2009-10-27 15:38:06 UTC
Created attachment 65682 [details]
A screenshot demonstrating the bug.
Comment 3 Armin Le Grand 2009-10-27 17:44:06 UTC
AW->CL: OutlinerView needs to work with other device except Windows only.
Currently, OutlinerView (EditView) uses a Window as source of events and for
paint. It Needs to be splitted to use a 2nd OutDev (will be a VDev) as paint
target, by keeping the Window as event source. This is needed to keep the view
buffering working, so that no BitmapData needs to be copied from the Vcl-Window
to a buffer VDev. Currently, at BeginTextEdit, a special ViewMode is entered
where the Overlay gets redefined as non-buffering overlay and other stuff, all
to keep the old OutlinerView/EditView alive.
Comment 4 Raphael Bircher 2009-11-04 09:49:50 UTC
add at CC
Comment 5 clippka 2010-06-07 16:02:07 UTC
setting target
Comment 6 Marcus 2017-05-20 10:55:54 UTC
Reset assigne to the default "issues@openoffice.apache.org".