Issue 106766

Summary: Crash when cancelling extension update
Product: General Reporter: joerg.skottke
Component: uiAssignee: joerg.skottke
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P2 CC: issues
Version: OOO320m4Keywords: regression
Target Milestone: OOo 3.2   
Hardware: All   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 99999    

Description joerg.skottke 2009-11-10 13:53:41 UTC
Reproduction:
- Start the office (shared installation) as normal user
- Install one of the publisher test-extensions (e.g. pub1.oxt) using unopkg for
the current user
- Open the extension Manager
- Check for updates, wait till the update is shown
- Cancel extension update
-> Crash
Comment 1 joerg.skottke 2009-11-10 13:56:48 UTC
Report ID for Stack is: 102143249 (rcmqc2c)
Comment 2 joerg.skottke 2009-11-10 13:57:27 UTC
Regression
Comment 3 joerg.skottke 2009-11-10 13:59:40 UTC
Automated test: extensions/optional/e_publisher.bas
Comment 4 joerg.skottke 2009-11-10 14:02:37 UTC
Priority
Comment 5 joerg.skottke 2009-11-10 14:24:14 UTC
Stack (short, so i paste it here)
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb252db70 (LWP 12362)]
0x0524e4b1 in vfprintf () from /lib/tls/i686/cmov/libc.so.6
(gdb) where
#0  0x0524e4b1 in vfprintf () from /lib/tls/i686/cmov/libc.so.6
#1  0x0526dea0 in vsnprintf () from /lib/tls/i686/cmov/libc.so.6
#2  0x03ca880e in ne_vsnprintf () from
/opt/openoffice.org3/program/../basis-link/program/libneon.so
#3  0x03ca7320 in ne_set_error () from
/opt/openoffice.org3/program/../basis-link/program/libneon.so
#4  0x03ca5296 in ?? () from
/opt/openoffice.org3/program/../basis-link/program/libneon.so
#5  0x03ca5af1 in ne_read_response_block () from
/opt/openoffice.org3/program/../basis-link/program/libneon.so
#6  0x03ca5b90 in ne_discard_response () from
/opt/openoffice.org3/program/../basis-link/program/libneon.so
#7  0x03ca6b91 in ne_request_dispatch () from
/opt/openoffice.org3/program/../basis-link/program/libneon.so
#8  0x02f8bd7b in ?? () from
/opt/openoffice.org3/program/../basis-link/program/libucpdav1.so
#9  0x02f8da9a in ?? () from
/opt/openoffice.org3/program/../basis-link/program/libucpdav1.so
#10 0x02f85f8d in ?? () from
/opt/openoffice.org3/program/../basis-link/program/libucpdav1.so
#11 0x02f742fe in ?? () from
/opt/openoffice.org3/program/../basis-link/program/libucpdav1.so
#12 0x02f751a2 in ?? () from
/opt/openoffice.org3/program/../basis-link/program/libucpdav1.so
#13 0x04cdc54f in ?? () from
/opt/openoffice.org3/program/../basis-link/program/updatefeed.uno.so
#14 0x04cdcc07 in ?? () from
/opt/openoffice.org3/program/../basis-link/program/updatefeed.uno.so
#15 0x04cdd891 in ?? () from
/opt/openoffice.org3/program/../basis-link/program/updatefeed.uno.so
#16 0x02e8b471 in ?? () from
/opt/openoffice.org3/program/../basis-link/program/deploymentguili.uno.so
#17 0x02e8e3b5 in ?? () from
/opt/openoffice.org3/program/../basis-link/program/deploymentguili.uno.so
#18 0x02e86d9b in ?? () from
/opt/openoffice.org3/program/../basis-link/program/deploymentguili.uno.so
#19 0x02e87042 in ?? () from
/opt/openoffice.org3/program/../basis-link/program/deploymentguili.uno.so
#20 0x00e420e2 in ?? () from
/opt/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3
#21 0x0072b80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#22 0x052da7ee in clone () from /lib/tls/i686/cmov/libc.so.6
(gdb) 
Comment 6 dirk.voelzke 2009-11-11 07:55:47 UTC
It looks like a multi threading problem
Comment 7 tkr 2009-11-11 11:35:46 UTC
started
Comment 8 tkr 2009-11-17 11:57:41 UTC
fixed in cws 29
Comment 9 tkr 2009-11-17 12:00:12 UTC
TKR->JSK: Please verify in cws tkr29
Comment 10 joerg.skottke 2009-11-20 10:48:43 UTC
Verified for Linux and Windows.
Comment 11 joerg.skottke 2009-11-30 12:17:06 UTC
Seen good in m6, i was able to crash the app once which might be related to
something else.
However, as i did apparently not change the autotest within this CWS is added
revision 277671 to the CWS automationooo320m6.