Issue 107870

Summary: No DDE connection to document after opening it directly (Calc in Writer)
Product: Writer Reporter: thomasjf <tjfoerster>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOO310m9   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description thomasjf 2009-12-24 08:36:58 UTC
Hi,

I am using a copy+paste (ctrl+shift+V) DDE connection in a writer-file (from an
area in a calc-file). Opening the calc-file from windows explorer, everything is
working fine.

Now I want to open the calc-file from inside the writer-file. I am using a macro:

------------------------
sub oeffne_dok
Dim Doc As Object
Dim Url As String
Dim Dummy()
Url = "file:///E:/calc_filename.ods"
Doc = StarDesktop.loadComponentFromURL(Url, "_blank", 0, Dummy())
end sub
------------------------

The calc-file opens and everything seems to work. But after (!) using this macro
no more DDE-connection (update) between the files is possible. 

OO3.11 must be restarted! After this everything is working fine again until
using the macro again.

Regards
Thomas
Comment 1 eric.savary 2009-12-31 13:26:10 UTC
Reassigned to JSK
Comment 2 hans_werner67 2011-03-28 11:56:48 UTC
Assign to new default-assignee
Comment 3 eric.savary 2011-04-11 07:21:17 UTC
Reassigned to TBO.
Comment 4 b.osi.ooo 2011-04-14 07:54:46 UTC
This issue is unconfirmed since a year, does it still not work with a recent OOo version: http://download.services.openoffice.org/files/extended/developer/
Else, please discuss in forum first: http://user.services.openoffice.org/en/forum/viewforum.php?f=20
closing
Comment 5 b.osi.ooo 2011-04-14 08:26:38 UTC
ok, still active as told by mail, then let's go to a developer with this...MAV?
Comment 6 Marcus 2017-05-20 11:17:36 UTC
Reset assigne to the default "issues@openoffice.apache.org".