Issue 108004

Summary: Hyperlink does not change to already opened document
Product: ui Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: uiAssignee: eric.savary
Status: CLOSED FIXED QA Contact: issues@ui <issues>
Severity: Trivial    
Priority: P3 CC: issues, mdxonefour
Version: OOo 3.2 RC1Keywords: regression
Target Milestone: OOo 3.3   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 111112    
Attachments:
Description Flags
Test kit, pls see report! none

Description Rainer Bielefeld 2009-12-30 13:10:16 UTC
Until 3.1.1 I was used to the following behaviour, when I click on a hyperlink:
- A new document will be opened and focus will change to newly opened document
- Focus will change to an already opened document

Steps to reproduce:
0. Download and unpack my test kit
1. Open "DocumentWithLinks.ods" (from WIN Explorer)
2. Change to "DocumentWithLinks.ods", if necessary
3. Click hyperlink for "DocumentA.odt" , switch back to 
   "DocumentWithLinks.ods" and click link for  "DocumentB.odt" 
   als expected, both documents will be opened and focus changes to 
   opened document
4. Switch back to "DocumentWithLinks.ods"
5. Click hyperlink for "DocumentB.odt" in "DocumentWithLinks.ods"
   expected: focus will change to already opened "DocumentB.odt" 
   actual: Nothing happens, same with link to other document

Now something else:

10. close all documents from test kit!
11. Open "DocumentB.odt" and "DocumentWithLinks.ods" (select both in 
   WIN Explorer, then click OPEN)
12. Change to "DocumentWithLinks.ods"
13. Switch to "DocumentWithLinks.ods" if necessary, then click hyperlink for 
   "DocumentA.odt" 
   as expected, "DocumentA.odt" will be opened and focus changes to 
   "DocumentA.odt"
14. Switch back to "DocumentWithLinks.ods"
15. Click hyperlink for "DocumentB.odt" in "DocumentWithLinks.ods"
   expected: focus will change to already opened "DocumentB.odt" 
   actual: Document is locked for edit by "Rainerbielefeld"

All That with "Ooo 3.2.0 RC1 WIN XP DE-multilingual version German UI activated
[OOo320m8 (Build 9472)]"!"

I see this as a blocker for 3.2.0
Comment 1 Rainer Bielefeld 2009-12-30 13:12:09 UTC
Created attachment 66908 [details]
Test kit, pls see report!
Comment 2 Rainer Bielefeld 2009-12-30 13:52:29 UTC
Effect starting with step 10 reproducible with "Ooo-Dev 3.2.0 multilingual
version English UI WIN XP: [DEV300m68 (Build 9474)]"!
From step 1 not tested because OOo-DEV not linked in OS
Comment 3 Rainer Bielefeld 2010-01-13 12:31:57 UTC
No longer reproducible with "Ooo 3.2.0 RC2 WIN XP DE [OOo320m9 (Build 9476)]"!
Comment 4 Rainer Bielefeld 2010-01-13 12:32:18 UTC
.
Comment 5 Rainer Bielefeld 2010-01-13 13:22:50 UTC
My Mistake, I have been working with m69 during my test. The problem still
exists. I believe it should not be too difficult to do the test with my test kit.
I believe we can't release 3.2 with this bug in it.
Comment 6 merschmann 2010-01-13 13:37:57 UTC
Can confirm with OOo 3.2 RC2 german on Windows XP.

The already opened file is not recognized.
Comment 7 uwe.luebbers 2010-01-13 15:32:13 UTC
Hi all,

I think this issue need to be discussed public on the releases list before it is
attached to the meta issue. The reason is that I'am not sure that a P3 rated
issue will be serious enough to stop the release while we are working on the
last RC.
In the last release status meeting before starting the RC process, we discussed
that not all regressions will be fixed in the future when we start to build
RC's, this was accepted.


Comment 8 Rainer Bielefeld 2010-01-13 16:12:41 UTC
Corrected typo in summary
Comment 9 Rainer Bielefeld 2010-01-13 17:01:04 UTC
And it's also not working with m69 during lots of tests I did within the last
minutes (so please ignore "comments from rainerbielefeld Wed Jan 13 12:31:57
+0000 2010" - no idea what mistake had let me think it would work.

No problem with links to PDF documents.
Also a problem in WRITER, DRAW, IMPRESS documents, also with form field buttons.

It definitively still has worked until 3.1, I have been using links to other OOo
documents intensively for years, so REGRESSION.
Comment 10 tommy27 2010-01-14 08:49:50 UTC
I suggest targetting to 3.2.1
Comment 11 eric.savary 2010-01-14 23:52:09 UTC
@MAV: Please have a look.
Comment 12 Rainer Bielefeld 2010-03-24 06:31:43 UTC
*** Issue 110351 has been marked as a duplicate of this issue. ***
Comment 13 mikhail.voytenko 2010-08-09 08:07:06 UTC
mav->rainerbielefeld: Could you please nominate the issue as a showstopper for
OOo 3.3. The fix is ready.
Comment 14 mikhail.voytenko 2010-08-09 08:11:07 UTC
The problem was that the document name in the link and the name in the file
system use different character case. That should be no problem on Windows, since
Windows handles paths case-insensitive. The fix is ready and looks to be quite safe.
Comment 15 Rainer Bielefeld 2010-08-09 08:53:24 UTC
@mav:
NOT reproducible with "testkit.zip" and "Ooo-Dev 3.3.0 multilingual version
English UI WIN XP: [DEV330m1 (Build 9514)]"! Fix already integrated? Lucky chance?
And yes, I believe this would be a blocker for next release
Comment 16 mikhail.voytenko 2010-08-09 09:21:42 UTC
@rainerbielefeld: Only the first scenario is no more reproducible. I could
reproduce the second one, and the fix affects the second scenario. Could you
please check that you still can reproduce the second scenario in OOO330_m1.
Comment 17 mikhail.voytenko 2010-08-09 09:55:33 UTC
The second scenario:

"11. Open "DocumentB.odt" and "DocumentWithLinks.ods" (select both in 
   WIN Explorer, then click OPEN)
12. Change to "DocumentWithLinks.ods"
13. Switch to "DocumentWithLinks.ods" if necessary, then click hyperlink for 
   "DocumentA.odt" 
   as expected, "DocumentA.odt" will be opened and focus changes to 
   "DocumentA.odt"
14. Switch back to "DocumentWithLinks.ods"
15. Click hyperlink for "DocumentB.odt" in "DocumentWithLinks.ods"
   expected: focus will change to already opened "DocumentB.odt" 
   actual: Document is locked for edit by "Rainerbielefeld"
"

is now fixed as well. The fix is integrated in cws fwk152.
Comment 18 Rainer Bielefeld 2010-08-09 10:25:44 UTC
@mav:
You are right, scenario steps 10 and following still reproducible with
"testkit.zip" and "Ooo-Dev 3.3.0 multilingual version
English UI WIN XP: [DEV330m1 (Build 9514)]"!
Comment 19 mikhail.voytenko 2010-08-12 09:57:31 UTC
mav->es: Please verify the issue.
Comment 20 michael.ruess 2010-08-20 11:09:24 UTC
Verified fix in CWS fwk152.