Issue 108583

Summary: Support simplified way to export CSV From Base
Product: Base Reporter: megabandwidth <megabandwidth>
Component: codeAssignee: AOO issues mailing list <issues>
Status: RESOLVED DUPLICATE QA Contact:
Severity: Trivial    
Priority: P3 CC: drewjensen.inbox, issues, oooforum
Version: OOo 3.1.1Keywords: usability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description megabandwidth 2010-01-22 16:18:35 UTC
Many people need to Export Tables and Queries from Base to use in a different
applications. A simple CSV Export would be great. I can script a little But, I
am not a programmer or i would help fill this gap. If their is a script that
fills this gap I would love to hear a bout it.
Comment 1 drewjensen.inbox 2010-01-23 15:27:30 UTC
There are ways to create a text file from any Base table or query. Depending on 
the data connection type used by the Base file this can be as simple as a single 
SQL command or using Calc as a gateway.

Altered summary - IMO a valid request and one that fits with a few other RFE 
regarding export functionality.
Comment 2 megabandwidth 2010-01-24 06:51:11 UTC
I know you can copy to Calc and Export to a CSV if your data is under 65536
records. 
I have a script that Exports small files under 68033 records, if their are more
records then it chokes. The script info can be found here
http://wiki.services.openoffice.org/wiki/CSV_export ((if you don't have Xray
installed you will need to comment out line 133.)) for the script to run. 
I need to save around 3500000 records From Table or Querie to CSV file when I
export. 
If we can improve the above script or if their is some SQL that will work please
point me in that direction. HELP! Thx,
Comment 3 oooforum (fr) 2015-11-25 08:01:05 UTC
.

*** This issue has been marked as a duplicate of issue 59369 ***
Comment 4 oooforum (fr) 2015-11-25 09:11:21 UTC
Note that SF.net page quoted in Wiki is obsolete.
No script available.