Issue 108605

Summary: extensions: Presenter Console 1.1 crashes OOo 3.2
Product: extensions Reporter: Uwe Altmann <ooo>
Component: presenterconsoleAssignee: groucho266
Status: CLOSED IRREPRODUCIBLE QA Contact: wolframgarten
Severity: Trivial    
Priority: P2 CC: hans-joachim.lankenau, issues, mdxonefour, mechtilde, stefan.weigel, werbung
Version: currentKeywords: crash, regression
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Uwe Altmann 2010-01-23 16:30:35 UTC
Observed for Mac OS 10.6, (also for 3.1.1.) Ubuntu Karmic Koala and Debian SID AMD64 so far.
When starting a presentation, OOo freeezes or crashes.
c.f. geman developers list: "Probleme mit neuer Sun Presenter Console 1.1.0": 
http://de.openoffice.org/servlets/ReadMsg?listName=dev&msgNo=42995 )
Comment 1 Stefan Weigel 2010-01-23 17:00:50 UTC
changing component to Presentation
Comment 2 Uwe Altmann 2010-01-23 17:05:23 UTC
*** Issue 108604 has been marked as a duplicate of this issue. ***
Comment 3 thackert 2010-01-23 18:26:27 UTC
Hello Uwe, *,
I can confirm the crash with OOO320m10 and Sun Presenter Console 1.1.0 under
Debian SID AMD64. My graphics adapter is an

00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce
430] (rev a2)

with

ii  nvidia-kernel-2.6.32-trunk-amd64                     190.42-3+2.6.32-2     
      NVIDIA binary kernel module for Linux 2.6.32-trunk

(build via module-assistant).
HTH
Thomas.
Comment 4 merschmann 2010-01-23 20:05:38 UTC
Crashes also on Windows XP (ATI Mobility and NVidia GeForce FX5200) with m8 and m10.
Comment 5 parity 2010-01-24 08:02:33 UTC
I can also confirm this issue:

OS: Ubuntu Karmic Koala (32 Bit)
OOo: 3.2RC3

Graphik:
VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated
Graphics Controller (rev 07)
(Intel GMA4500MHD)
Comment 6 parity 2010-01-24 08:03:37 UTC
I can also confirm this issue:

OS: Ubuntu Karmic Koala (32 Bit)
OOo: 3.2RC3

Graphik:
VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated
Graphics Controller (rev 07)
(Intel GMA4500MHD)
Comment 7 Martin Hollmichel 2010-01-25 08:02:09 UTC
released from DEV300_m69, please have a look
Comment 8 groucho266 2010-01-25 11:52:15 UTC
The problem is caused by incompatible versions of OOo and presenter console. 
The 1.1.0 version of the presenter console belongs to the DEV300 master and does
not work with current OOo versions of the OOO320 master.

Version 1.0.3 of the presenter console should be used instead on the OOO320
master.  The problem with this is is that the impressaccessibility5 CWS that
introduces version 1.0.3 has been integrated into DEV300 but not yet into OOO320.

The next best thing is the most current version 1.0.2 (version number was not
increased with every minor modification), e.g. from OOO320 m11.  This version,
however, has a paint problem in the main slide preview (fixed in 1.0.3).  This
can be worked around by switching the presenter console into notes mode and back
again.
Comment 9 Mechtilde 2010-01-25 12:15:38 UTC
So why are at http://extensions.services.openoffice.org/project/presenter-screen

Version 1.0.2 *and* 1.1.0 are declared as *compatible with Version 3.2*

and Version 1.1.0 is coming with an automatical update.
Comment 10 groucho266 2010-01-25 12:33:10 UTC
Version 1.1.0 should not be in the repository.  Only when OOo 3.3 is released
should version 1.1.0 of the extension be put into the repository. 

And yes, its current dependency is wrong and should be updated accordingly.  I
just don't know whether the extension can then still be installed on the 3.3
development versions of OOo: it may still pretend to be of version 3.2 (have to
check that.)
Comment 11 wolframgarten 2010-01-25 12:45:11 UTC
Changed component to extension.
Overview:
DEV300_m69: Presenter console version 1.0.2 : does not work
DEV300_m69: Presenter console version 1.1.0 : works
OOO320_m10: Presenter console version 1.0.2 : does not work
OOO320_m10: Presenter console version 1.1.0 : Crash
OOo3.1.1: Presenter console version 1.0.2 : works
OOo3.1.1: Presenter console version 1.1.0 : needs Office version 3.2
Comment 12 yohan14 2010-01-29 04:19:46 UTC
I don't see download link for presenter console 1.1.0.. and, does it work in
windows 7 ? Thanks
Comment 13 rygle 2010-02-09 03:02:16 UTC
If version 1.0.2 of the extension is still incompatible with OO.o 3.2, then
there will probably be a lot of disappointed people on Friday, which is when it
seems the release version of 3.2 will be coming out.

See http://lizards.opensuse.org/2010/02/08/openoffice_org-3_2_0_5/
Also on http://planet.go-oo.org/

Is there any way to work around the accessibility issue for 1.0.3 (if that is
compatible with OO.o 3.2)? Or getting the 1.0.2 issue sorted out by the upcoming
3.2 release date?
Comment 14 Mechtilde 2010-02-09 06:59:46 UTC
the version 1.0.2 works with OOo Version 3.2

this is tested with the vanilla version of OOo 3.2 and the extension from 

http://extensions.services.openoffice.org/en/project/presenter-screen

Comment 15 Mechtilde 2010-02-09 07:01:20 UTC
removing Presenter-Console from
http://extensions.services.openoffice.org/en/project/presenter-screen

fixed the problem with version 3.2 so => worksforme
Comment 16 Mechtilde 2010-02-09 07:01:43 UTC
-> closed
Comment 17 rygle 2010-02-11 00:36:34 UTC
The version that works for OOo 3.2 Win32 is 1.0.3 (which is now up on the
extension page for Win32 only), not 1.0.2.

I have just tested version 1.0.2 several times with a vanilla OOo 3.2 RC5 and it
doesn't work. I have then uninstalled 1.0.2 and installed 1.0.3 and restarted
OOo and tested with 1.0.3 and it works fine.

1.0.2 does the presentation on my external screen as if the presenter console
extension is not installed at all (i.e. no different to vanilla OOo), while
1.0.3 does it with the console appearing on the internal screen.