Issue 108835

Summary: target directory defaults to "Gallery" instead of "My Documents"
Product: Writer Reporter: Peter <peter.karl.mueller>
Component: save-exportAssignee: AOO issues mailing list <issues>
Status: CLOSED IRREPRODUCIBLE QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, oliver.brinzing, oooforum
Version: OOo 3.2 RC4   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
screenshot none

Description Peter 2010-02-02 10:51:30 UTC
Each time you use the PDF exporter (menu "Exportieren als PDF" or via PDF button
"Direktes Exportieren als PDF") the upcoming file dialog wants to save the file
into that location which the "Grafiken" path is (pre)set to.

According to issue #77340 the directory should be the document directory.
Comment 1 Peter 2010-02-02 10:59:24 UTC
(due to a design error in the issue tracker [obviously no ids in forms] in
conjunction with a webserver-timeout this bug has also been accepted under the
following issue ids:
#108836
#108837
#108838
#108839
)
Comment 2 Peter 2010-02-02 11:03:22 UTC
(I cannot post a screenshot due to a server timeouts in the url
http://www.openoffice.org/issues/createattachment.cgi)
Comment 3 Peter 2010-02-02 11:06:04 UTC
Created attachment 67521 [details]
screenshot
Comment 4 Peter 2010-02-02 11:47:26 UTC
Just found that it is only the case unless the file has not been saved.
Comment 5 Peter 2010-02-02 11:48:24 UTC
if not unless
Comment 6 michael.ruess 2010-02-02 12:17:54 UTC
When a document has not been saved and you try to export as PDF, the file picker
will head to OOo's "Gallery" directory instead of the "My Documents" folder.
I was able to confirm this on Win as well.
Comment 7 philipp.lohmann 2010-02-02 12:27:14 UTC
that file picker is not PDF export specific but should be the same for any
export filter.
Comment 8 michael.ruess 2010-03-10 15:01:47 UTC
*** Issue 110013 has been marked as a duplicate of this issue. ***
Comment 9 krokosjablik 2010-06-03 12:47:08 UTC
Ubuntu bug report
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/587263
Comment 10 krokosjablik 2010-06-03 12:54:18 UTC
The target milestone is currently OOo 3.3. That means all Ubuntu 10.04 users
will be affected by this bug next three years! I hope you can fix it in 3.2.* too.
 
P.S. for unexperienced users this bug is very annoying, because they cannot find
pdf files after exporting.
Comment 11 carsten.driesner 2010-08-06 15:05:02 UTC
cd: Too late to fixed for OOo 3.3. Must be shifted to next release. If you think
that this issue could be a show stopper then please nominate it.
Comment 12 Martin Hollmichel 2011-03-16 11:43:24 UTC
set target 3.x since not relevant for 3.4 release.
Comment 13 Oliver Brinzing 2013-10-28 19:41:48 UTC
still  reproducible in aoo 4.0.1
Comment 14 oooforum (fr) 2019-10-06 10:38:33 UTC
(In reply to michael.ruess from comment #6)
> When a document has not been saved and you try to export as PDF, the file
> picker
> will head to OOo's "Gallery" directory instead of the "My Documents" folder.
I was not able to reproduce this behavior with Windows 7
PDF export for a no named document is localised in last folder used by last saving action.
Comment 15 Marcus 2019-10-06 16:53:10 UTC
Closing issue due to comment #14