Issue 109145

Summary: Exported PDF dont include the PlaceHolders
Product: Writer Reporter: kaav <kasturikarlekar>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: elish, issues
Version: OOo 3.1.1   
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
sample document none

Description kaav 2010-02-11 09:09:33 UTC
Hello,

I want to export all place holders to PDF how can I do that?

Please help me its very argent,

Thanks in advance
Comment 1 kaav 2010-02-11 09:32:38 UTC
I have template in which I copy the required contents programatically and export
it to PDF.

The template has placeholders and I replace those placeholders with my required
content and then export it to PDF.

but PDF dont include those palceholder
Comment 2 philipp.lohmann 2010-02-11 09:55:07 UTC
kaav: please attach a sample document that shows your problem. Also please tell
which version you are using, version "1.0.0" did not have PDF export.

@od: don't know what "placeholders" could be meant, date and page number fields
work just fine.
Comment 3 kaav 2010-02-11 10:03:45 UTC
Created attachment 67742 [details]
sample document
Comment 4 kaav 2010-02-11 10:06:18 UTC
Hello,

I have attached Untitled 2.odt

It has <From> as Place holder now in my program I am 

checking whether the property is Placeholder then 

if(name.equalsIgnoreCase("From:")){
				xPropertySet.setPropertyValue("PlaceHolder", new String(from));
			}

and then exporting that file to PDF but its not working.
Comment 5 philipp.lohmann 2010-02-11 10:17:17 UTC
Setting component to writer.
Comment 6 kaav 2010-02-11 10:19:13 UTC
Opening a file in writer only
Comment 7 Edwin Sharp 2013-08-09 09:10:54 UTC
According help: "When you click a placeholder field in the document, you are prompted to insert the item that is missing."

Click in odt has no response.
Export as pdf loses field - only text is printed.

Rev. 1503704 Win 7
Comment 8 Marcus 2017-05-20 10:44:34 UTC
Reset the assignee to the default "issues@openoffice.apache.org".