Issue 110039

Summary: 'Base' title bar in data entry mode says 'Form design'
Product: Base Reporter: niekd <niek>
Component: codeAssignee: marc.neumann
Status: CLOSED FIXED QA Contact: issues@dba <issues>
Severity: Trivial    
Priority: P3 CC: drewjensen.inbox, issues, r4zoli
Version: OOO320m12Keywords: usability
Target Milestone: 3.4.0   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description niekd 2010-03-11 01:42:44 UTC
I have searched the issue database, and only found one reference to my long
standing issue in the LAST comment of issue 45617. 

However, issue 45617
- covers a different subject
- is closed

Hence I open a new issue. The OpenOffice.org Base application title bar says
'Form design' in form entry mode.

Steps to reproduce:
1) Open OpenOffice.org Base.
2) Create a new form (nothing needs to be on it)
3) Save it
4) Close it
5) Open it in data enty mode (using the context command "open" as opposed to
"edit").
6) Look at the title bar
Comment 1 drewjensen.inbox 2010-03-18 19:58:47 UTC
Confirmed (meaning I agree) - the terminology in the title bar is not as good as
it could be

Adding keyword usability and assigning to clu as UX is the proper owner, IMO

Also moving from defect to enhancement, it's been that way a long time.

Set initial target
Comment 2 christoph.lukasiak 2010-06-07 17:07:59 UTC
valid enhancement

send further to the requirements team
Comment 3 Frank Schönheit 2010-12-01 12:04:59 UTC
"requirements" is a dead-end street ...
Comment 4 niekd 2010-12-09 18:31:12 UTC
Come on folks, enhancement? Requirements? This is just a wrong text element, it
seems. How long it has been that way doesn't make much of a difference, does it?
Unless there is no way to discern the 'design' versus 'use' state of OOo base
screens (which seems unlikely), it is a matter of adding a text key/value pair,
or even just changing a text value. 

I just received the OOo newsletter, enthusiastically stating: 'Hunting issues is
fun! You hate ignoring issues?  Help us to get them fixed.
Join the QA project!'. 

Well, this issue seems to be stuck in bureaucracy forever. Not exactly fun. What
can I do to speed up this process? I have some time on my hands.
Comment 5 Frank Schönheit 2010-12-16 20:15:49 UTC
meant to grab it, together with my latest comment. Also resetting back to DEFECT
instead of ENHANCEMENT.

@niekd: In fact, at the level where the descision about the title is made, we
cannot currently distinguish between the two modes (data entry and form design).
And at the level where this distinction is possible, we have no control over the
title.

So, while sometimes you would be right in attributing bureaucracy to the
project, this is not the root cause for this issue being unfixed for so long.

What could easily be done, and is perhaps the best short-term approach to this
problem, is to rename "Form Design" to something more neutral - "Database Form",
for instance. What do you think?
Comment 6 niekd 2010-12-18 05:49:22 UTC
@fs: Using a neutral term like "Database Form" would seem to be an excellent and
inexpensive solution in the given situation. Thank your for taking this approach.
Comment 7 Frank Schönheit 2010-12-21 10:29:34 UTC
fixed in CWS dba34c: http://hg.services.openoffice.org/cws/dba34c/rev/6435a4b53c41
Comment 8 Frank Schönheit 2011-01-17 08:15:22 UTC
fs->msc: please verify in CWS dba34c
Comment 9 marc.neumann 2011-02-21 13:26:04 UTC
verified in CWS dba34c

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300/dba34c
Comment 10 r4zoli 2011-03-25 12:56:51 UTC
Checked in DEV300m104, the database title row now contain: Database Form.