Issue 110045

Summary: should report an error when a required component is not installed
Product: General Reporter: rene
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 3.1.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description rene 2010-03-11 08:42:30 UTC
[ Forwarding from http://bugs.debian.org/573297. Actually, I am quite
sure this came up before but I don't find an issue. Am I blind? Mark
as duplicate as needed ]

--- snip ---
I tried to open a Word document. After calling                                  
  ooffice x.doc                                                                 
the OOo splash appeared and disappeared again, then nothing happened. ps        
showed a sleeping OOo instance. I tried again calling only                      
  ooffice                                                                       
and the welcome screen appeared, allowing me to choose a document to open.      
Again, nothing happened; the welcome screen persisted.                          
                                                                                
While preparing a bug report, I found out that the package                      
openoffice.org-writer was not installed. After installation, everything         
worked as expected.                                                             
                                                                                
                                                                                
I think the OOo main binary should show *some* kind of error message or         
other information indicating that it won't proceed, due to a required           
component not being installed.
--- snip ---