Issue 110189

Summary: OO Solver fails where MS solver works
Product: Calc Reporter: foot <pgb>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Major    
Priority: P3 CC: elish, issues, jbf.faure, jsc
Version: OOO320m9   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 124158    
Issue Blocks:    
Attachments:
Description Flags
Screen Prints of spreadsheets and working sheets
none
Initial view in OO Scalc
none
The actual Scalc file
none
The Excel file
none
The result of running MS Solver
none
The setup before running MS Solver
none
test with updated CoinMP 1.7.6 on aoo trunk rev. 1580882 none

Description foot 2010-03-17 12:32:54 UTC
In the attached samples, when applying Solver to the data attached, all the
answers end up as showing divide by 0.  When using Excel with the same data the
correct solution is found.

attachments  OO Solver 1.jpg   all set before applying solver
             OO Solver 2.jpg   the result
             MS Solver 1.jpg   all set before applying solver
             MS Solver 2.jpg   the result

             OO Solver Test.ods  the spreadsheet used with initial data
             Statistical Failure analysis.xls  the same in Excel
I can't see how to attach these data to my submission.  Please let me know where
I can send them.
Comment 1 foot 2010-03-17 12:35:51 UTC
Created attachment 68390 [details]
Screen Prints of spreadsheets and working sheets
Comment 2 foot 2010-03-17 12:36:47 UTC
Created attachment 68391 [details]
Initial view in OO Scalc
Comment 3 foot 2010-03-17 12:37:20 UTC
Created attachment 68392 [details]
The actual Scalc file
Comment 4 foot 2010-03-17 12:38:01 UTC
Created attachment 68394 [details]
The Excel file
Comment 5 foot 2010-03-17 12:40:14 UTC
Created attachment 68395 [details]
The result of running MS Solver
Comment 6 foot 2010-03-17 12:41:03 UTC
Created attachment 68396 [details]
The setup before running MS Solver
Comment 7 Edwin Sharp 2013-08-04 13:17:26 UTC
No solution with Rev. 1507307.
Successful with Excel 2007.
Comment 8 jsc 2014-03-25 09:47:57 UTC
Created attachment 82967 [details]
test with updated CoinMP 1.7.6 on aoo trunk rev. 1580882

I tested some files with my locally build of aoo trunk rev. 1580882 and with an updated version of CoinMP 1.7.6. Looks good to me.
Comment 9 jsc 2014-03-25 09:56:37 UTC
well the buttons that triggers the scripts are still not working but that is a different problem with VBA