Issue 110256

Summary: Formula in Calc OLE breaks that object
Product: Writer Reporter: m4f <m4f>
Component: save-exportAssignee: writerneedsconfirm <swneedsconfirm>
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOO320m12Keywords: needmoreinfo, oooqa
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Sample Document
none
corrupted sample document none

Description m4f 2010-03-19 12:30:56 UTC
Hello,
 
we have a problem when saving some of our Writer documents with OO 3.2, which 
were originally created with OO 3.1.
An embedded Calc document gets damaged.
 
Steps to reproduce: (please excuse if not all Commands are described correct, 
because we use the German Version of OO)

* create a new Writer document with OO 3.1
* click Insert->Object->Ole Object
* select "Table" and "Create new" and click OK
* add a 2nd sheet and type something in as well
* switch to the 1st sheet and add in any cell a formula which references a cell 
of the 2nd sheet
* exit the embedded table
* save and close the document

* now open the document with OO 3.2
* double click the table and modify something (eg enter additional text in an 
empty cell)
* exit the embedded table
* save and close the document

* now re-open the document with OO 3.1 or 3.2 (doesn't matter)
* double click the table: The 2nd sheet is not in there anymore!

How can I avoid this issue?
Thanks
Comment 1 eric.savary 2010-03-20 18:59:35 UTC
Please attach a sample document
Comment 2 m4f 2010-03-22 10:40:11 UTC
Created attachment 68466 [details]
Sample Document
Comment 3 michael.ruess 2010-03-22 16:14:47 UTC
I cannot reproduce the problem. I tried with the attached and a new document I
created from the scratch. Perhaps a special step is missing in the description?
Comment 4 m4f 2010-03-23 16:59:39 UTC
I use two different PCs where the one with OO320 was upgraded from 311. So on
this computer OO311 components are not available anymore. On the other one I
work with OO311.

I tried modifying the sample document using OO320portable on the PC where OO311
is installed on the harddisk and it works as expected: I can open and modify the
document correctly with both versions without any issue.

Next try was to open and modify the the sample document with OO320portable on a
computer where no OOo was installed before. In this case the OLE gets corrupted.

Next step will be to install OO320 on a fresh WinXP. I will post the result
tomorrow.

I that helps a little bit. Thanks
Comment 5 m4f 2010-03-24 11:21:56 UTC
Hello again,

today I did the promised test by installing OOo320 on a machine which had never
seen OpenOffice.org before in any version.

The result is as I described in my first post: the file gets corrupted when
editing and saving with OOo32!

I will attach a corrupted version of the sample document. Perhaps this can give
you any hints.
Comment 6 m4f 2010-03-24 11:27:09 UTC
Created attachment 68513 [details]
corrupted sample document
Comment 7 michael.ruess 2010-03-24 14:51:00 UTC
No, sorry. Cannot get information from this under which conditions this problem
may occur.
Comment 8 michael.ruess 2010-04-19 13:44:23 UTC
We were now be able to reproduce, it will be handled and fixed for OOo 3.2.1.
See issue 110692.

*** This issue has been marked as a duplicate of 110692 ***
Comment 9 michael.ruess 2010-04-19 13:44:43 UTC
Closing duplicate.