Issue 110619

Summary: PDF Export no longer defaults to current document folder
Product: General Reporter: mbourne <openofficelogin.mbourne>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Minor    
Priority: P3 CC: elish, issues, rainerbielefeld_ooo_qa
Version: OOo 3.2Keywords: regression
Target Milestone: ---   
Hardware: PC   
OS: Windows, all   
Issue Type: DEFECT Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---

Description mbourne 2010-04-05 13:40:34 UTC
Having recently upgraded from OpenOffice 2.2.0 to the latest 3.2.0, I notice
that the PDF Export no longer defaults to the folder containing the current
document, as it used to.

For example:
1. Create a new Writer document and save in one folder (eg. "Folder1")
2. Export that document as a PDF (using either the toolbar button or File menu >
Export as PDF)
3. Create another new Writer document and save in a different folder (eg. "Folder2")
4. Export that document as a PDF using either method.
=> The "Export" dialog defaults to "Folder1", even though the current document
is in "Folder2".

Expected / previous behaviour:
=> The "Export" dialog defaults to "Folder2", where the current document resides.

It appears that the Export dialog currently defaults to the last used folder,
rather than that of the current document. This means that it is necessary to
navigate to the correct folder almost every time, whereas before that was only
necessary if the PDF was to be saved separate from the source document.

Although Writer is used in the example above, the same behaviour is also seen
with Calc, Impress, and Draw.
Comment 1 Rainer Bielefeld 2010-04-05 16:20:23 UTC
NOT reproducible with "Ooo-Dev 3.2.1 multilingual version English UI WIN XP:
[OOO300m14 (Build 9489)]", neither with OOo dialogs nor with WIN dialogs! Vista
specific? Wrong way how to reproduce?

@mbourne:
Does that effect only appear for PDF export or also for other exports, save as
and similar?
Comment 2 mbourne 2010-04-05 18:40:27 UTC
I do see this effect using "File > Export...", which only seems to give the
option of exporting to PDF. Also "File > Export as PDF..." and the "Export
Directly as PDF" toolbar button as described.

It does not affect File > Save As..., which defaults to the current folder and
filename as expected, but does not give a PDF option (I don't expect "save as"
to offer PDF).

I'm using the British English OpenOffice, version 3.2.0, which is the latest I
can see (from the download links on the home page http://www.openoffice.org/). I
have the Sun JDK and JRE 1.6.0 update 18 installed, so used the OpenOffice
installer without bundled JRE. If there's an English 3.2.1 version, I'd be happy
to try it out and report back.

I had assumed this would affect all Windows versions, but am about to install my
version of OpenOffice into Windows 2000 (running in a virtual machine) to see if
it is Vista specific. Unfortunately I don't have a copy of XP available myself.
Comment 3 mbourne 2010-04-05 19:53:10 UTC
I am unable to reproduce this issue on Windows 2000 (running on a virtual
machine with Vista as the host OS), so perhaps it is indeed Vista specific.

I do notice a couple of other possibly related differences between Windows 2000
and Vista...
- After creating a new document, in 2000 the Save As dialog seems to default to
"My Documents", whereas on Vista it defaults to the last folder used for "Save
As" (not affected by modifying and saving an existing document, but is affecting
by using "Save As" on an existing document).
- On exporting to PDF if there is no existing PDF in the default target folder,
in 2000 the default filename is blank, whereas in Vista it is the current
document base filename with a pdf extention.
Comment 4 mbourne 2010-04-10 15:32:22 UTC
I've just noticed that this issue only happens if there is not already a PDF in
the current document's folder.

i.e. If there is already a PDF in the current document folder, the export
defaults to the current document folder. If there is no PDF in the current
document folder, the export defaults to the last folder to which a PDF was exported.

This seems similar in a way (not a duplicate!) to issue 15530 in which the PDF
export filename is not pre-filled unless there was already a PDF in the folder;
that appears to have been put down to an issue with the Windows file handling
dialogs. Issue 15530 still occurs on Windows 2000, but not on Windows Vista (it
did previously occur on Vista, but not with the latest OOo version). This issue
occurs on Vista, but not 2000.
Comment 5 Rob Weir 2013-02-02 03:01:11 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 6 mbourne 2013-02-02 16:05:08 UTC
The last 3 comments were from me, providing feedback just a few hours after it was requested. There has been no update from OpenOffice for almost 3 years. Please check your facts before accusing others of not providing feedback.

In any case, I haven't updated OpenOffice since it started reducing usability a couple of years ago.
Comment 7 Edwin Sharp 2014-02-08 19:18:48 UTC
Confirmed with
AOO410m1(Build:9750)  -  Rev. 1565724
Rev.1565724
Win 7
Comment 8 Edwin Sharp 2014-02-08 19:20:44 UTC
Worked in OpenOffice.org 3.0.1