Issue 110692

Summary: Sheet lost in incorporated Calc OLE
Product: Writer Reporter: vitriol <vitriol_vitriol>
Component: save-exportAssignee: kla <thomas.klarhoefer>
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: issues, jbf.faure, rainerbielefeld_ooo_qa
Version: OOo 3.2Keywords: oooqa
Target Milestone: ---   
Hardware: PC   
OS: Windows, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 109046    
Attachments:
Description Flags
Test bugdoc
none
mangled file
none
unaffected file none

Description vitriol 2010-04-08 10:32:42 UTC
Severe bug found in OOo 3.2. Data loss.
Steps to reproduce:
- Open the attached OLEbug.odt in Writer.
- Double click on OLE object to modify.
- Write something into a cell. For example d in A4 on Sheet1. The object has 2
sheets.
- Click over the OLE object to leave the edit mode, and quickly save the document.
- Reopen the document, and double click on the OLE.
- BUG: Sheet2 is lost.

It's non 100% reproducible, but verified by many users. Maybe it depends on the
speed of execution.

Thank you for your attention.
Comment 1 vitriol 2010-04-08 10:33:26 UTC
Created attachment 68818 [details]
Test bugdoc
Comment 2 vitriol 2010-04-08 11:01:57 UTC
The step 4 is "Click outside the OLE object" not "over"...
Thanks
Comment 3 Rainer Bielefeld 2010-04-08 12:43:03 UTC
100% Reproducible with "OLEbug.odt" and "Ooo-Dev 3.2.1 multilingual version
English UI WIN XP: [OOO300m14 (Build 9489)]"! It does not matter how I save and
close the document, second sheet always was lost when I reopened closed document.

NOT reproducible with "OLEbug.odt" and "Ooo 3.1.1 WIN XP DE[OOO310m19 (Build
9420)]".	

I failed to create my own sample document. Only reproducible with clones of
"OLEbug.odt"?

@vitriol:
Can you please contribute a step by step instruction how to create an won sample
document?
Comment 4 vitriol 2010-04-08 12:55:51 UTC
@rainerbielefeld

- Create a document in Calc with two sheets, and save as ODS.
- Insert the Calc document into Writer with Insert > Object > Ole object... >
Create from file. The option "Link to file" must be unchecked.
- Save Writer document as ODT.
- Delete the original Calc ODS document.
Comment 5 Rainer Bielefeld 2010-04-08 13:14:16 UTC
Reproducible!
Before I saved a writer document, I increased size of OLE spreadsheet after
doubleclick, changed from to sheet 2 to sheet 1, iserted A-c into 'A1' ... 'A3',
clicked into writer document area, closed saved with name, reopened (without
deleting CALC document) and second sheet was lost.

I used WIN dialogs, I did not test whether problem also appears with OOo dialogs.
Comment 6 jbf.faure 2010-04-09 05:00:50 UTC
Add me to cc.
Comment 7 uwe.luebbers 2010-04-09 11:25:32 UTC
Adjusted target
Comment 8 uwe.luebbers 2010-04-09 11:29:20 UTC
Assigned issue
Comment 9 niklas.nebel 2010-04-09 13:54:33 UTC
Fixed in CWS "calc321stopper2".
Comment 10 niklas.nebel 2010-04-09 16:06:02 UTC
Reassigning to QA for verification
Comment 11 kla 2010-04-13 12:21:33 UTC
Seen ok in CWS calc321stopper2 -> verified
Comment 12 michael.ruess 2010-04-19 13:44:22 UTC
*** Issue 110256 has been marked as a duplicate of this issue. ***
Comment 13 michael.ruess 2010-06-18 07:23:42 UTC
*** Issue 112481 has been marked as a duplicate of this issue. ***
Comment 14 Oliver Brinzing 2010-06-18 11:53:49 UTC
.
Comment 15 delgarot 2010-07-19 19:50:28 UTC
OOo v 3.2.1 on Windows 7 Home Premium

It looks like this bug may have eaten several hours of my homework.
I will attach both the eaten assignment, and the previous assignment that was not 
affected.  I notice that when opening the odt files as zip, the undamaged file has 
object folders, while the damaged file is missing those folders.
What can I do to not reproduce this bug on my subsequent homework assignments?
Comment 16 delgarot 2010-07-19 19:52:12 UTC
Created attachment 70691 [details]
mangled file
Comment 17 delgarot 2010-07-19 19:53:07 UTC
Created attachment 70692 [details]
unaffected file