Issue 112181

Summary: footnote anchor can be wrapped to next line without preceeding word
Product: Writer Reporter: donanpa <pagan.idc>
Component: editingAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: irmhild.rogalla, issues, mechtilde, michael.ruess
Version: OOo 3.2.1 RC2Keywords: oooqa
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 111112    
Attachments:
Description Flags
please note the number on a new line
none
the same in the exported pdf
none
patch to fix this defect none

Description donanpa 2010-06-07 11:09:57 UTC
Writer breaks the line before a footnote number.
Comment 1 donanpa 2010-06-07 11:11:06 UTC
Created attachment 69850 [details]
please note the number on a new line
Comment 2 donanpa 2010-06-07 11:11:45 UTC
Created attachment 69851 [details]
the same in the exported pdf
Comment 3 michael.ruess 2010-06-07 15:33:24 UTC
MRU->TL : it is possible to separate a footnote anchor from its preceding word.
The attached document may look differently on Windows - there I just needed to
delete some characters to see the issue.
Worked fine in 3.1.1, broken since 3.2.
Comment 4 eric.savary 2010-06-28 09:22:22 UTC
*** Issue 112744 has been marked as a duplicate of this issue. ***
Comment 5 Mechtilde 2010-06-28 09:49:21 UTC
It is a regression against 3.2.0
Comment 6 lissy 2010-06-28 10:15:17 UTC
This is a *very* annoying and eminent bug!
Please provide a correction as soon as possible.
If you have a work around for now, I would like to know about it.
Comment 7 Oliver Specht 2010-06-28 11:12:00 UTC
Looks like a side effect of a bugfix in cws sw321bf01
reassigned to od
Comment 8 Oliver-Rainer Wittmann 2010-06-28 14:24:38 UTC
mru on CC
Comment 9 irmhild 2010-06-29 10:08:17 UTC
1. I fully agree with Lissy!

2. I did a futher test, with an interesting outcome: 
I used to different PCs, 
first with Debian Lenny 5.0.5 Kernel 2.6.32-trunk-686 and the 
second with Debian Lenny 5.0.5 Kernel Linux 2.6.32-trunk-amd64 (obviously a
64bit-System).
The OOo Version on both PCs are the same: OpenOffice.org 3.2.1, OOO320m19
(Build:9505), ooo-build 3.2.1.4, Debian package 1:3.2.1-3
BUT
at the first PC I get this bug
at the second PC - the 64bit Linux - I can't confirm!

Nevertheless: It's a *very* eminent bug!
Comment 10 Oliver-Rainer Wittmann 2010-06-29 11:44:27 UTC
I can not reproduce the defect in OOo 3.2.0
My investigation reveals that the defect has been introduced in OOo 3.2.1 by cws
sw321bf01

od->donanpa/mechtilde/mru: Please check again, if the defect already occurs in
OOo 3.2.0 - Thx in advance.

Nevertheless, I think that this is a serious regression, which needs to be fixed
as soon as possible.

I am working on a fix.
Comment 11 michael.ruess 2010-06-29 11:51:06 UTC
Yes, I can confirm this. 
Small but important correction: this functionality broke in 3.2.1, not in 3.2.
Comment 12 Oliver-Rainer Wittmann 2010-06-30 09:03:06 UTC
Adjusting target, because this issue has been accepted as a showstopper for OOo 3.3
Comment 13 Oliver-Rainer Wittmann 2010-06-30 09:44:26 UTC
Created attachment 70314 [details]
patch to fix this defect
Comment 14 Oliver-Rainer Wittmann 2010-06-30 09:46:23 UTC
The fix for this defect is ready - see attached patch.

I am waiting for the branch off of the OOO330 code line in order to apply this
patch to a cws on this code line.
Comment 15 Oliver-Rainer Wittmann 2010-07-07 12:09:14 UTC
fixed in cws sw33bf07 - changed file:
/sw/source/core/text/itrform2.cxx, change set d6e6d66a5c08
Comment 16 Oliver-Rainer Wittmann 2010-07-20 11:30:35 UTC
od->mru: Checked in internal installation set of cws sw33bf07 - please verify.
Comment 17 michael.ruess 2010-07-21 09:22:46 UTC
Verified fix in CWS sw33bf07.
Comment 18 michael.ruess 2010-08-06 07:58:44 UTC
Checked fix in OOO320m2.
Comment 19 eric.savary 2010-08-09 21:56:32 UTC
*** Issue 113750 has been marked as a duplicate of this issue. ***