Issue 112259

Summary: Word count incorrect when customer quotes turned on
Product: Writer Reporter: paul.m.nz
Component: editingAssignee: writerneedsconfirm <swneedsconfirm>
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, jbf.faure
Version: OOo 3.2.1   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description paul.m.nz 2010-06-09 21:39:29 UTC
Try this:

Turn off 'Custom Quotes' in Tools>Autocorrect, and type:

'word'
"word"
(with the quotes)

Now turn on custom quotes, and repeat the exercise.

Now highlight each word in turn and do a word count. With custom quotes
turned off, the word count is, as expected, one in each case. However, with
custom quotes turned on, the word count in each case becomes two.

This bug has been confirmed in OOo3.2.1 on OSX and Ubuntu. Problem also found on
windows version 3.2
Comment 1 dan_lewis 2010-06-09 22:19:45 UTC
Results the same using OOo 3.2.1 64AMD Ubuntu and 3.2.1 Mac. Both versions were
downloaded from OOo website. I typed a 10 word sentence. Word count: 10. I put a
set of custom quotes around three of the words. Word count: 11 Place a second
set of custom quotes around another word or words. Word count: 12
Comment 2 jbf.faure 2010-06-09 23:10:19 UTC
I think the problem is more general.I use OOo 3.2.1 FR and DEV300m81 under Ubuntu.

Type : Exemple de texte pour compter les mots.
Word count reported by OOo : 7

Type : Exemple de texte pour « compter » les mots !
Word count reported by OOo : 10.
In French you have to put non-breaking space after « and before » and ! (and
other double ponctuation signs like ; : and ?)

In fact each character string with blank character or non-breaking space after
and before counts for one word. The word count should ignore ponctuation signs
and others " or »

Regards. JBF
Comment 3 jbf.faure 2010-06-09 23:19:22 UTC
Hum, probably a duplicate of issue 89042.

However in French we have the case of blank or non-breaking space characters
around ponctuation signs.

Regards. JBF
Comment 4 eric.savary 2010-06-10 09:04:08 UTC
Yes it is.

*** This issue has been marked as a duplicate of 89042 ***
Comment 5 eric.savary 2010-06-10 09:04:19 UTC
closed