Issue 112616

Summary: smoketestoo_native: generate smoketestdoc.sxw
Product: Installation Reporter: Stephan Bergmann <stephan.bergmann.secondary>
Component: codeAssignee: kurt.zenker
Status: CLOSED FIXED QA Contact: issues@installation <issues>
Severity: Trivial    
Priority: P3 CC: issues, kurt.zenker, rene, ruediger.timm
Version: DEV300m83   
Target Milestone: OOo 3.3   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 97025, 112263    

Description Stephan Bergmann 2010-06-23 08:11:01 UTC
see <http://www.openoffice.org/issues/show_bug.cgi?id=112212#desc5>
Comment 1 Stephan Bergmann 2010-06-23 08:14:00 UTC
.
Comment 2 rene 2010-06-23 08:27:36 UTC
I think we shoudl do it more early. The current thing is a PITA.

I need to disable the DB tests on armel for example (due Base being broken -
yes, I disable Base there too no fear). What do I need to do?:

ifeq "$(ARCH)" "armel"
        TMP=`mktemp -q -d`; \
        mkdir -p $$TMP && \
        cd $$TMP && unzip
$(CURDIR)/$(SOURCE_TREE)/smoketestoo_native/data/smoketestdoc.sxw && \
                cp
$(CURDIR)/$(SOURCE_TREE)/smoketestoo_native/data/smoketestdoc.sxw \
                       
$(CURDIR)/$(SOURCE_TREE)/smoketestoo_native/data/smoketestdoc.sxw.orig && \
                patch -p0 <
$(CURDIR)/debian/smoketest/patches/smoketest-disable-db-insert-delete-seek-tests.diff
&& \
        zip -r $(CURDIR)/$(SOURCE_TREE)/smoketestoo_native/data/smoketestdoc.sxw
Basic/Standard/Test_DB.xml
endif
        cd $(SOURCE_TREE)/smoketestoo_native && \
                . $(CURDIR)/$(SOURCE_TREE)/*Env*.sh; \
                export PATH=$(BUILD_PATH); \
                export TMPDIR=$(CURDIR)/debian/smoketest; \
                export JAVA_HOME=$(TEST_JAVA_HOME); \
                SAL_USE_VCLPLUGIN="svp" ../solenv/bin/build.pl
        # doesn't get cleaned up...
        rmdir $(CURDIR)/debian/smoketest/ooopackaging
ifeq "$(ARCH)" "armel"
        mv $(SOURCE_TREE)/smoketestoo_native/data/smoketestdoc.sxw.orig \
                $(SOURCE_TREE)/smoketestoo_native/data/smoketestdoc.sxw
endif

This is a serious pain in the ass and a regression to 3.2.1 where you could just
apply a patch to Test_DB.xba (also needing pre and post-proccessing
but no zip handling and easily revertable with patch. Right now, if the
smoketest fails you have a "unclean" smoketestdoc there unless you start a clean
build with fresh extraction...
Comment 3 Stephan Bergmann 2010-06-23 08:38:40 UTC
@rene:  I see your problem now.  (It appears old smoketestoo_native had the test
macros twice, as smoketestoo_native/data/scripts/*.xba files that were used when
building smoketestoo_native, and within
smoketestoo_native/data/smoketestdoc.sxw, where they would only be used if you
loaded smoketestdoc.sxw manually into an soffice.  This violated DRY, so I
consolidated to just a checked-in smoketestoo_native/data/smoketestdoc.sxw,
which now turns out to be an unfortunate choice.)  I will come up with a patch
and we can then see where best to integrate it.
Comment 4 Stephan Bergmann 2010-06-23 12:48:00 UTC
fixed as <http://hg.services.openoffice.org/cws/smoketest26/rev/08bdc5652379>: 
smoketsetoo_native/data/smoketestdoc.sxw got replaced with the files zipped into
it, dropping those that are apparently not needed; manual smoketesting is still
possible, the file to load is now smoketestoo_native/<platform>/bin/smoketestdoc.sxw
Comment 5 Stephan Bergmann 2010-07-02 15:35:57 UTC
@kz: please verify
Comment 6 kurt.zenker 2010-07-07 18:14:56 UTC
verified