Issue 112666

Summary: chart2/qa/unoapi sch.ChXChartDocument, sch.ChXDiagram failures
Product: General Reporter: Stephan Bergmann <stephan.bergmann.secondary>
Component: chartAssignee: oc
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: IngridvdM, issues
Version: 3.3.0 or older (OOo)Keywords: regression
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
test log
none
patch to fix the issue
none
macro to reproduce the problem none

Description Stephan Bergmann 2010-06-24 16:38:36 UTC
<http://termite.services.openoffice.org/buildbot/builders/Ubuntu-9.04-i386/builds/2441>
on CWS sb127, effectively being latest re/DEV300_next towards DEV300_m84 with
subsequenttests enabled, fails in chart2/qa/unoapi with the attached
Ubuntu-9.04-i386.subsequenttests.log.
Comment 1 Stephan Bergmann 2010-06-24 16:40:01 UTC
Created attachment 70203 [details]
test log
Comment 2 Stephan Bergmann 2010-06-24 16:43:21 UTC
(same for
<http://termite.services.openoffice.org/buildbot/builders/Solaris-Sparc/builds/2202>,
so this appears to not be a sporadic-only problem)
Comment 3 IngridvdM 2010-06-28 15:08:02 UTC
Created attachment 70263 [details]
patch to fix the issue
Comment 4 IngridvdM 2010-06-28 15:46:51 UTC
Two problems were found:
New properties were introduced with wrong flags causing the now more strict
XPropertySet test to break. Those flags are corrected with the patch.
The second problem is more severe as I thought first. The method setPosition
does not fail because the new position is really out of range. A new bug was
introduced that makes it impossible to use this method.
Both are regressions and both could have been prevented if the tests have been
enabled before, sigh.
I will create a new patch, fixing the second problem correctly.
Comment 5 IngridvdM 2010-06-28 15:57:43 UTC
Created attachment 70266 [details]
macro to reproduce the problem
Comment 6 IngridvdM 2010-07-02 15:25:08 UTC
Fixed in CWS calc56 with this patch:
http://hg.services.openoffice.org/cws/calc56/rev/590a28982c39
Comment 7 IngridvdM 2010-07-19 15:47:59 UTC
@oc, please verify with the attached Macro-Document in CWS calc56.
Comment 8 oc 2010-07-26 08:20:57 UTC
verified in internal build cws_calc56