Issue 112670

Summary: strange (copy-paste) X window selection result
Product: Impress Reporter: karstenburger <karsten_burger>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOO320m9Keywords: needmoreinfo
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
presentation with simple example page
none
sorry, corrected the last text line in example none

Description karstenburger 2010-06-24 22:44:52 UTC
When I 
- copy any text in a shell or browser window using the primary mouse button 
(left), 
- change back to OO-Impress and activate the text box so that the grey border 
is shown
- paste it using the middle mouse button 

→ the complete active text box is duplicated: (see attachment for example).

When the text bos was already active BEFORE copy, then it works fine.
Comment 1 karstenburger 2010-06-24 22:47:36 UTC
Created attachment 70209 [details]
presentation with simple example page
Comment 2 karstenburger 2010-06-24 22:53:50 UTC
Created attachment 70210 [details]
sorry, corrected the last text line in example
Comment 3 wolframgarten 2010-06-25 07:17:31 UTC
Please give a detailed step by step description. How do you copy with the left
mouse button? When and how do you select the text box? Thanks.
Comment 4 karstenburger 2010-06-25 09:03:46 UTC
I thought to have described it perfectly:

- make sure no text box is active
- use the left mouse to mark a word or so in the shell window or browser
- change back to OO-Impress
- click on a text to activate the text box
- paste with middle mouse.
Comment 5 karstenburger 2010-06-25 09:08:34 UTC
I use the newest version 3.2.1 of OO, OOO320m18.

Please see also the attached little document for result.
Comment 6 wolframgarten 2010-06-25 09:15:07 UTC
Thanks, now I have it. Reproducible. Reassigned.
Comment 7 Joost Andrae 2010-06-25 09:33:12 UTC
just to name it correctly: it's not 'copy&paste' but 'X Window selection'
Comment 8 karstenburger 2010-06-25 10:33:11 UTC
renamed topic more correctly as "X-window selection" problem
Comment 9 Marcus 2017-05-20 10:55:18 UTC
Reset assigne to the default "issues@openoffice.apache.org".