Issue 113432

Summary: OpenOffice.org crashes while open the sample file which have over 1024 columns
Product: Calc Reporter: mayongl <mayongl>
Component: codeAssignee: oc
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P2 CC: issues
Version: OOo 3.2   
Target Milestone: ---   
Hardware: Mac   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 111112    
Attachments:
Description Flags
The file contains more 1024 cloumns. none

Description mayongl 2010-07-26 15:29:48 UTC
The sample file has over 1024 columns.

Open the sample on Mac OS X, openOffice.org will crash. If the file is opened on Windows platform, an 
"unknown error" dialog will be popped. But Openoffice.org won't crash.

The crash is caused by lang::IndexOutOfBoundsException() exception throw out in 
ScCellRangeObj::getCellRangeByPosition(). The exception is not handled correctly, due to up to the stack, 
there is call for XML_parse() which is implemented in C.
Comment 1 mayongl 2010-07-26 15:31:37 UTC
Created attachment 70824 [details]
The file contains more 1024 cloumns.
Comment 2 niklas.nebel 2010-07-26 16:57:58 UTC
This was already fixed as issue 94951, but apparently it got lost in a merge
conflict with CWS "frmdlg".
Comment 3 Joost Andrae 2010-07-27 17:13:17 UTC
target set
Comment 4 niklas.nebel 2010-07-28 16:21:09 UTC
Fixed in CWS "calc57".
Comment 5 pengyunquan 2010-07-29 04:26:44 UTC
I have tried to browse "svn://svn@svn.services.openoffice.org/ooo/cws/calc57", 
but I got an error. I have listed all CWSs, but I only found calc51. 
Comment 6 niklas.nebel 2010-07-29 09:16:55 UTC
pengyunquan, all current CWSs are in Mercurial.
http://hg.services.openoffice.org/cws/calc57/
Comment 7 ooo 2010-08-06 13:38:22 UTC
Reassigning to QA fo verification.
Comment 8 oc 2010-08-09 14:15:01 UTC
verified in internal build cws_calc57