Issue 114361

Summary: "Read Error" with embedded images after saving in Writer
Product: Writer Reporter: lingent <tony.vanlingen>
Component: editingAssignee: Oliver-Rainer Wittmann <orw>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P2 CC: dulik, fanyuzhen, h0l0fernes, issues, jonabbey, josef.latt, jsc, pescetti, rainerbielefeld_ooo_qa, sstowell, steve.romankiw, zeklh
Version: OOo 3.2Keywords: data_loss
Target Milestone: 4.1.1Flags: jsc: 4.1.1_release_blocker+
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 124946    
Issue Blocks: 124985, 124717    
Attachments:
Description Flags
Screenshot of case 3
none
Screenshot of about box
none
An ODT file containing PNG images that have vanished with a "Read Error" message
none
Image of PNG file corruption on OOWriter 3.3.0rc5 on Mac
none
the resulting file: ARL_Workflow_User_Documentation3.odt none

Description lingent 2010-09-07 08:16:39 UTC
Case 1

1. Document contains 10 pages, 5 embedded PNG images
2. Open document 
3. Scroll back & forth a few times
4. Image(s) (may) disappear and broken image icon is displayed along with text
"Read Error"
5. close OO without saving

Case 2

1. Document contains 22 pages, 1 embedded PNG image
2. Open document
3. Scroll somewhat and read previous work
4. Scroll to point where new text is required
5. Enter and format text
6. Scroll back and note that image is replaced by broken image icon and text
"Read Error"
7. Copy new text into ascii text editor & close OO without saving

In both cases closing & reopening the document restores the images, but new work
was not saved (obviously). Found many messages in forums saying images disappear
permanently if saved - did not try this as these documents are important. Below
follows some configuration and document information. Please let me know if any
more is useful or needed. 

I understand that OOffice hangs together with the system java? If so, could this
be a memory corruption issue which can be traced back to the JVM? The java
version in the path is: 

$ java -version 
java version "1.6.0_17"
Java(TM) SE Runtime Environment (build 1.6.0_17-b04)
Java HotSpot(TM) 64-Bit Server VM (build 14.3-b01, mixed mode)

Document contents (unzip -v): 
-----------------------------
document 1: 
Archive:  Alerting_DataProcessing.odt
 Length   Method    Size  Cmpr    Date    Time   CRC-32   Name
--------  ------  ------- ---- ---------- ----- --------  ----
     338  Defl:N      211  38% 2010-09-06 12:30 6c8290fa  Dialogs/dialog-lc.xml
     353  Defl:N      217  39% 2010-09-06 12:30 d9e0f9e3 
Dialogs/Standard/dialog-lb.xml
    2767  Defl:N      763  72% 2010-09-06 12:30 c09bce13 
Dialogs/Standard/dlgCreateDoc.xml
  133247  Stored   133247   0% 2010-09-06 12:30 5474811e 
Pictures/10000201000003360000054828D57FE7.png
  139016  Stored   139016   0% 2010-09-06 12:30 1d4c6ea9 
Pictures/100002010000035E0000058629E6F985.png
   95028  Stored    95028   0% 2010-09-06 12:30 ec006976 
Pictures/10000201000003320000058C2D813449.png
  116946  Stored   116946   0% 2010-09-06 12:30 2297a7fd 
Pictures/10000000000003F0000003E19EE36269.png
  202119  Stored   202119   0% 2010-09-06 12:30 bdbd63e9 
Pictures/10000201000006EA0000058B0B15D9E1.png
    5181  Defl:N     2467  52% 2010-09-06 12:30 693e5e9f 
META-INF/macrosignatures.xml
    3730  Defl:N      551  85% 2010-09-06 12:30 d7cf5e2a  META-INF/manifest.xml
      39  Stored       39   0% 2010-09-06 12:30 0c32c65e  mimetype
   82349  Defl:N     8864  89% 2010-09-06 12:30 6e7f9a75  content.xml
     324  Defl:N      191  41% 2010-09-06 12:30 c1589ff2  layout-cache
     532  Defl:N      244  54% 2010-09-06 12:30 4f02c6e6  manifest.rdf
    3084  Defl:N     1055  66% 2010-09-06 12:30 33f1f882 
Basic/Standard/mCreateDocument.xml
     356  Defl:N      216  39% 2010-09-06 12:30 00ec9b86 
Basic/Standard/script-lb.xml
     338  Defl:N      211  38% 2010-09-06 12:30 6c8290fa  Basic/script-lc.xml
   83968  Defl:N     8156  90% 2010-09-06 12:30 2af12fc5  styles.xml
    1696  Stored     1696   0% 2010-09-06 12:30 21ba3cc3  meta.xml
    4142  Defl:N     3830   8% 2010-09-06 12:30 a11cf9c9  Thumbnails/thumbnail.png
       0  Defl:N        2   0% 2010-09-06 12:30 00000000 
Configurations2/accelerator/current.xml
       0  Stored        0   0% 2010-09-06 12:30 00000000 
Configurations2/progressbar/
       0  Stored        0   0% 2010-09-06 12:30 00000000  Configurations2/floater/
       0  Stored        0   0% 2010-09-06 12:30 00000000  Configurations2/popupmenu/
       0  Stored        0   0% 2010-09-06 12:30 00000000  Configurations2/menubar/
       0  Stored        0   0% 2010-09-06 12:30 00000000  Configurations2/toolbar/
       0  Stored        0   0% 2010-09-06 12:30 00000000 
Configurations2/images/Bitmaps/
       0  Stored        0   0% 2010-09-06 12:30 00000000  Configurations2/statusbar/
   10300  Defl:N     1949  81% 2010-09-06 12:30 fcc5fe43  settings.xml
--------          -------  ---                            -------
  885853           717018  19%                            29 files

Document 2:
Archive:  MonitoringTool.odt
 Length   Method    Size  Cmpr    Date    Time   CRC-32   Name
--------  ------  ------- ---- ---------- ----- --------  ----
     338  Defl:N      211  38% 2010-08-13 04:01 6c8290fa  Dialogs/dialog-lc.xml
     353  Defl:N      217  39% 2010-08-13 04:01 d9e0f9e3 
Dialogs/Standard/dialog-lb.xml
    2767  Defl:N      763  72% 2010-08-13 04:01 c09bce13 
Dialogs/Standard/dlgCreateDoc.xml
  140228  Stored   140228   0% 2010-08-13 04:01 fb0a63b0 
Pictures/10000000000005090000035966F16CF5.png
    5181  Defl:N     2466  52% 2010-08-13 04:01 7c7696ff 
META-INF/macrosignatures.xml
    3238  Defl:N      485  85% 2010-08-13 04:01 21ea04fc  META-INF/manifest.xml
      39  Stored       39   0% 2010-08-13 04:01 0c32c65e  mimetype
  275497  Defl:N    26994  90% 2010-08-13 04:01 6fa0b093  content.xml
     332  Defl:N      176  47% 2010-08-13 04:01 fa1cb292  layout-cache
     532  Defl:N      244  54% 2010-08-13 04:01 4f02c6e6  manifest.rdf
    3084  Defl:N     1055  66% 2010-08-13 04:01 33f1f882 
Basic/Standard/mCreateDocument.xml
     356  Defl:N      216  39% 2010-08-13 04:01 00ec9b86 
Basic/Standard/script-lb.xml
     338  Defl:N      211  38% 2010-08-13 04:01 6c8290fa  Basic/script-lc.xml
   85046  Defl:N     8287  90% 2010-08-13 04:01 820eab3d  styles.xml
    1530  Stored     1530   0% 2010-08-13 04:01 6276321d  meta.xml
    3838  Defl:N     3538   8% 2010-08-13 04:01 06f3fd36  Thumbnails/thumbnail.png
       0  Defl:N        2   0% 2010-08-13 04:01 00000000 
Configurations2/accelerator/current.xml
       0  Stored        0   0% 2010-08-13 04:01 00000000 
Configurations2/progressbar/
       0  Stored        0   0% 2010-08-13 04:01 00000000  Configurations2/floater/
       0  Stored        0   0% 2010-08-13 04:01 00000000  Configurations2/popupmenu/
       0  Stored        0   0% 2010-08-13 04:01 00000000  Configurations2/menubar/
       0  Stored        0   0% 2010-08-13 04:01 00000000  Configurations2/toolbar/
       0  Stored        0   0% 2010-08-13 04:01 00000000 
Configurations2/images/Bitmaps/
       0  Stored        0   0% 2010-08-13 04:01 00000000  Configurations2/statusbar/
   10299  Defl:N     1954  81% 2010-08-13 04:01 aa131b9b  settings.xml
--------          -------  ---                            -------
  532996           188616  65%                            25 files



System Information:
-------------------

CPU: AMD AthlonII X2 240
RAM: 7680MB (1962M used) -- OO Writer with 1 document running
OS: Debian Squeeze x86-64
Display: 1920x1080 (Xorg 1.7.6)

Filesystem: 
-----------
 root: 1.97G - 1.0G free
 home: 20.2G - 11.5G free
 tmp:  3.7G - 3.7G free 

Writer deb package details:
---------------------------
openoffice.org-writer	1:3.2.0-4
Provides:	openoffice.org2-writer
Conflicts:	openoffice.org-debian-files, openoffice.org-java-common (<= 1:2.3.1),
openoffice.org2-writer (<< 1:3.2.0-4)
Suggests:	openoffice.org-gcj, openoffice.org-base
Depends:	openoffice.org-core (= 1:3.2.0-4), openoffice.org-base-core (=
1:3.2.0-4), libc6 (>= 2.2.5), libgcc1 (>= 1:4.1.1), libicu42 (>= 4.2-1),
libstdc++6 (>= 4.4.0), libwpd8c2a, libwps-0.1-1, ure (>= 1.4.0), zlib1g (>= 1:1.1.4)
Comment 1 michael.ruess 2010-09-07 08:51:09 UTC
This problem has already been reported by several Linux users working with OOo
provided by the distributor. Please use OOo downloaded from openoffice.org -
there the problem does not occur.
Please report this problem to your Linux distributor.
Comment 2 michael.ruess 2010-09-07 08:52:13 UTC
Closed.
Comment 3 lingent 2010-09-07 09:22:31 UTC
New case (screenshot attached).
Same documents as before
1. open both documents in full-screen mode, leave document with 5 pictures active
2. resize viewport to show all pages as in screen shot
3. walk away from PC
4. return half-hour later - pictures are broken

Comment 4 lingent 2010-09-07 09:23:41 UTC
Created attachment 71596 [details]
Screenshot of case 3
Comment 5 michael.ruess 2010-09-07 09:30:42 UTC
As I already said, please use the official build from openoffice.org download page.
Comment 6 michael.ruess 2010-09-07 09:31:16 UTC
Closed.
Comment 7 lingent 2010-09-07 09:35:41 UTC
Excuse me for reopening. I had not read your comment. However, I wonder if it is
correct. I decided to post because of this discussion:
http://user.services.openoffice.org/en/forum/viewtopic.php?f=7&t=32295&hilit=+read+error+image&sid=77da46065c2122a0fd0b7b1ab1d5ee27

Note that that thread is on a hetrogenous environment of Mac, Windows and Linus.
It seems the same problem to me, and I am prepared to go the length in assisting
in finding the cause. 

I note that Debian have released a new package. I will upgrade and see if it
recurs and try with the source distribution. If it recurs, I will let you know. 

Thanks.
Comment 8 lingent 2010-09-08 08:44:26 UTC
I'm sorry to have to report that the issue happens in exactly the same way with
the official build. I completely removed the Debian-provided packages (including
configuration files) and downloaded the official distribution from
http://mirror.aarnet.edu.au/pub/openoffice/stable/3.2.1/

The md5sums & files that I have are: 

829c11ba6dcdfe045dd1e5a77b34c05e 
OOo-SDK_3.2.1_Linux_x86-64_install-deb_en-US.tar.gz
455fc8d3da9010eed910a16155f16baf  OOo_3.2.1_Linux_x86-64_install-deb_en-US.tar.gz

I unpacked the files and installed all .deb packages contained therein. Then I
tested with the same documents as before.

Please instruct me how to gather enough data to help you with assessing this
issue. Is it useful to try and build from the official source?

Comment 9 michael.ruess 2010-09-08 09:08:28 UTC
Please attach the document to this issue so that we can see what's going on.

But: if the graphics are already corrupted when you open the file, the problem
is that the previous debian build of OOo has already damaged them - that was the
bug in the debian-OOo package.
Comment 10 lingent 2010-09-08 09:22:03 UTC
Sorry, I was not clear. The graphics are not corrupted. When the document is
opened they show perfectly well, but after some time (see case descriptions) the
"Read Error" appears. I could succesfully export the document to PDF (before the
"Read Error" appeared) and the pictures were present in the PDF. I have also
tested with the same document on a Mac (transferred via ssh) in NeoOffice and
both documents showed perfectly in that setup.

To check, I have just unzipped one of the images from document 1 and opened it
in eog, which worked fine:

$ unzip Alerting_DataProcessing.odt Pictures/10000201000003360000054828D57FE7.png
Archive:  Alerting_DataProcessing.odt
 extracting: Pictures/10000201000003360000054828D57FE7.png  
$ l Pictures/10000201000003360000054828D57FE7.png 
-rw-r--r-- 1 lingent lingent 131K Sep  6 12:30
Pictures/10000201000003360000054828D57FE7.png
$ file Pictures/10000201000003360000054828D57FE7.png 
Pictures/10000201000003360000054828D57FE7.png: PNG image data, 822 x 1352,
8-bit/color RGBA, interlaced
$ eog Pictures/10000201000003360000054828D57FE7.png 
(shows picture in window)

The document is "confidential" and "internal use only"... can you guarantee that
it will be treated as such? 
Comment 11 michael.ruess 2010-09-08 09:47:16 UTC
OK, in this case please send the document to mru@openoffice.org. Me -as Oracle
employee- I am "treated" to handle your document confidential.
Comment 12 michael.ruess 2010-09-08 16:39:04 UTC
Yes, with the document I am able reproduce the issue on ubuntu and Solaris using
OOo 3.2.1.
It looks, that it is fixed with OOo 3.3 milestone OOO330m6 or m7. 
Could you please be so kind and and doublecheck this on your system using one of
these newer builds? It is no problem to install it besides OOo 3.2.1 on Linux
without interfering the other build.
Comment 13 lingent 2010-09-08 22:48:45 UTC
That's good that you are able to reproduce it - in a sense :) At least that
shows that it's not an artifact caused by my setup...

As I said, I did download the files only yesterday from the aarnet mirror.
According to the "About" dialog this is m18, build 9502. I'll attach a
screenshot of it to this.

Cheers
Tony
Comment 14 lingent 2010-09-08 22:49:40 UTC
Created attachment 71623 [details]
Screenshot of about box
Comment 15 michael.ruess 2010-09-09 07:41:04 UTC
I know which version you deployed on your system (3.2.1).
From the OpenOffice.org download page you can also get the OOo 3.3 pre-releases
(currently build ID OOO330m7). You can install it besides your actual OOo 3.2.1
build on your system. Would be interesting, if the issue also occurs with that
build on your system. Thanks in advance!
Comment 16 lingent 2010-09-09 08:54:16 UTC
So you do.. sorry. I should really learn to read all the letters in the words,
not just the last few, shouldn't I :( 

I'm downloading 3.3 m7 (.deb) now. Will get back to you as soon as I can.
Comment 17 lingent 2010-09-09 12:16:48 UTC
It's looking good. I've had both documents open in 3.3 m7 for the last 2 hours,
resized, scrolled, left alone etc. as per the cases described earlier, and no
read errors have shown yet. 

I plan to leave the documents open overnight and see if the problem reappears
over that time. I'll report back tomorrow. 
Comment 18 lingent 2010-09-09 12:33:57 UTC
Isn't it always the case... I should have waited a few minutes before posting...
the read error has now occurred in the document with 5 images. All images are
gone at the same time, as with the 3.2.1 version. It took 2.25 hours to develop. 

The single image in the other document is still showing - but that always took
longer to break.
Comment 19 lingent 2010-09-09 23:21:26 UTC
Results after running with 3.3 m7 from last night 19:15 AEST until 8:05 AEST 
10/9/10 (15 mins ago):
- document 1 displayed "Read Error" in all images after 2 1/4 hours
- document 2 (1 picture) did not develop the error
- on menu-close a program crash was reported and an automatic error report
generated. Interestingly, the crash utility recovered only document 2, even
though both were modified.

I allowed the crash report to be sent, and added "REFER TO ISSUE 114361" in the
top, so you should be able t find it if you wish.
Comment 20 eric.savary 2010-09-10 08:49:00 UTC
@lingent: you might have received a report ID by e-mail. We need to know this ID
to look into the crash report database.
Comment 21 lingent 2010-09-10 11:15:33 UTC
No sorry, no email arrived :( 

Does it save the crash report locally as well? If so, I could attach it to this
issue? 
Comment 22 eric.savary 2010-09-10 11:57:32 UTC
No, better write down here or by private e-mail to me the e-mail address you
used to send the crash report.
We can also look for submitter in the database.

Anyway it is not obvious that the crash has something to do with the image
problem...
Comment 23 jonabbey 2010-11-20 02:42:23 UTC
I see the same thing with a couple of our ODT files that contain PNG files. I
will be working with the file, editing text, and I'll get the "Read Error"
message and some significant portion of my images will disappear.  If I
subsequently save the file, the file on disk is much, much smaller and many
images are simply missing.

I've seen this in the OO 3.2.1 download for Mac OS X on Intel as well as the OO
3.3.0RC5 on Linux using native downloads from openoffice.org.

I'm attaching one that contains 23 PNG files.  The file has been previously
edited by Word 2010, but it does initially load into Open Office successfully
(modulo a mis-alignment of graphics overlaid on one of the images, but I don't
think that's relevant here).
Comment 24 jonabbey 2010-11-20 02:44:34 UTC
Created attachment 75072 [details]
An ODT file containing PNG images that have vanished with a "Read Error" message
Comment 25 jonabbey 2010-11-21 03:29:29 UTC
I just verified that this issue occurs with OO 3.3.0 rc 5 Writer on Mac OS X on
Intel, as well.

I opened a file containing PNG images, edited out some text, and all the images
were fine when I scrolled around.  When I saved the document with command-S, all
the PNG images (all the images in the document) turned to garbage, and Open
Office Writer started glitching when trying to render those images.
Comment 26 jonabbey 2010-11-21 03:30:35 UTC
Created attachment 75078 [details]
Image of PNG file corruption on OOWriter 3.3.0rc5 on Mac
Comment 27 jonabbey 2010-11-21 04:01:02 UTC
The OS should probably be changed to 'all'.
Comment 28 michael.ruess 2010-11-25 16:24:44 UTC
I now tried with RC5 on Mac and Win, but the problem did not occur.
which steps did you perform? did you add or remove graphics? Did you scroll
through the document before saving?
Comment 29 osnola 2010-11-29 14:22:47 UTC
Just for note, I success to reproduce this bug on a mac OS X 10.6.5 ( **) with the following steps:
- I open the odt file ARL_Workflow_User_Documentation.odt
- I replace the title:
"The University of Texas at Austin \n Applied Research Laboratories"
by
"The University of Te  xas at Austin \n Applied Research Laboratories"
- I save the file as ARL_Workflow_User_Documentation2.odt
at this point, the pictures disappear in the Writer windows ( ie. the "read error" messages appear when I scroll to see a new page).
- I replace again the title to
"The University of Te  x  as at Austin \n Applied Research Laboratories"
- I save the file as ARL_Workflow_User_Documentation3.odt

The file ARL_Workflow_User_Documentation2.odt is ok , but the file ARL_Workflow_User_Documentation3.odt no longer contain any picture...

(**) with DEV300_m88 and with DEV300_m94 ( compiled by hand on my compiler ).
Comment 30 osnola 2010-11-29 14:25:41 UTC
Created attachment 75162 [details]
the resulting file: ARL_Workflow_User_Documentation3.odt
Comment 31 michael.ruess 2010-11-30 12:16:53 UTC
MRU->OD: we are now able to reproduce the problem. Open the attached document,
do a change in the text at the top, save document under new name -> graphics
will show as "read error".

Problem is, that the document has been created with MS Word 2010. This seems to
save the graphics in the odt package in a different way which confuses Writer.

The problem already occurred in OOo 2.4.1.

Curious is the fact, that sometimes it helps if you scroll through the document
before saving - but only sometimes and I am not able to find out in which cases...
Comment 32 jonabbey 2010-11-30 18:00:01 UTC
I believe the document was originally created in OO 3.x, but yeah, it has been
edited in Word 2010, saved in DOCX for some iterations, and then put back into
ODT from there.
Comment 33 lingent 2010-11-30 22:40:04 UTC
In addition I want to stress that:

1. my documents were created from OpenOffice 2.x templates in OpenOffice 2. 

2. in my case rather than alleviating, scrolling trough the document is enough
to produce the "Read Error". Saving causes the images to disappear altogether.

Cheers,
Tony
Comment 34 michael.ruess 2010-12-09 13:30:21 UTC
*** Issue 115994 has been marked as a duplicate of this issue. ***
Comment 35 dulik 2011-03-02 23:19:26 UTC
The last comment is now 3 months old, is any progress here?

Neooffice@Mac seems to have a patch already: 
http://bugzilla.neooffice.org/bug.php?op=show&bugid=3631
Comment 36 sstowell 2011-04-16 01:36:40 UTC
My 16 page doc with mostly pictures is still VERY BROKEN in 3.4 Beta (downloaded 4/15/11).
Comment 37 sstowell 2011-04-18 19:16:10 UTC
(In reply to comment #36)
> My 16 page doc with mostly pictures is still VERY BROKEN in 3.4 Beta
> (downloaded 4/15/11).

Made a new doc using 3.4 with same format (5.5x8.5 portrait pages) with all pics inserted as links (as previously). And also setting memory options higher. Document content seems OK and looks good with Zoom/ single page, scolling down. With multiple pages it starts to appear broken, w/read error and file pathnames showing for many pictures. But it appears that the document content may be OK when printing... TBD
Comment 38 h0l0fernes 2011-07-14 12:21:29 UTC
(In reply to comment #37)
> (In reply to comment #36)
> > My 16 page doc with mostly pictures is still VERY BROKEN in 3.4 Beta
> > (downloaded 4/15/11).
> 
> Made a new doc using 3.4 with same format (5.5x8.5 portrait pages) with all
> pics inserted as links (as previously). And also setting memory options higher.
> Document content seems OK and looks good with Zoom/ single page, scolling down.
> With multiple pages it starts to appear broken, w/read error and file pathnames
> showing for many pictures. But it appears that the document content may be OK
> when printing... TBD

I have also disappearing images in OOo and LibreOffice. Attached above document ARL_Workflow_User_Documentation.odt opened, changed and saved with default memory options lose images.
Increasing Tools→Options→Memory settings allowed me to open, change, save ARL_Workflow_User_Documentation.odt without losing images in 3.3.2 OOo and LibreOffice.
Comment 39 Hans W. Zekl 2012-01-16 12:01:59 UTC
(In reply to comment #38)
> (In reply to comment #37)
> > (In reply to comment #36)
> > > My 16 page doc with mostly pictures is still VERY BROKEN in 3.4 Beta
> > > (downloaded 4/15/11).
> > 
> > Made a new doc using 3.4 with same format (5.5x8.5 portrait pages) with all
> > pics inserted as links (as previously). And also setting memory options higher.
> > Document content seems OK and looks good with Zoom/ single page, scolling down.
> > With multiple pages it starts to appear broken, w/read error and file pathnames
> > showing for many pictures. But it appears that the document content may be OK
> > when printing... TBD
> 
> I have also disappearing images in OOo and LibreOffice. Attached above document
> ARL_Workflow_User_Documentation.odt opened, changed and saved with default
> memory options lose images.
> Increasing Tools→Options→Memory settings allowed me to open, change, save
> ARL_Workflow_User_Documentation.odt without losing images in 3.3.2 OOo and
> LibreOffice.

The problem still exitst in the latest version of OpenOfiice and LibreOffice. I ran into the case on two Win 7 PCs. Checking the XML files I found that in the image tags the file name of the image is missing and that the image is lost in the the image folder. I have the impression - but I am not certain about it - that the error may happen during the automatic safety updates while editing.

Nevertheless the problem is too old and should be solved asap.
Comment 40 Oliver-Rainer Wittmann 2014-05-07 13:07:30 UTC
working on a solution
Comment 41 SVN Robot 2014-05-19 11:37:12 UTC
"orw" committed SVN revision 1595847 into trunk:
114361: provide and accept changed URL of embedded graphic file during save (...
Comment 42 Oliver-Rainer Wittmann 2014-05-19 11:40:50 UTC
defect of losing images on save fixed on trunk
Comment 43 Oliver-Rainer Wittmann 2014-05-23 12:42:53 UTC
fix needs correction - see issue 124946
Comment 44 Rainer Bielefeld 2014-05-26 18:16:53 UTC
Blocks Issue 124985, causes data loss, so can't be trivial
Comment 45 jsc 2014-06-16 09:14:51 UTC
grant showstopper flag, data loss and already fixed
Comment 46 SVN Robot 2014-06-19 08:34:19 UTC
"orw" committed SVN revision 1603754 into branches/AOO410:
114361: provide and accept changed URL of embedded graphic file during save (...
Comment 47 Oliver-Rainer Wittmann 2014-06-19 08:35:47 UTC
fixed on branch AOO410 for planned 4.1.1. release
Comment 48 mroe 2014-06-24 14:12:37 UTC
*** Issue 125151 has been marked as a duplicate of this issue. ***
Comment 49 jolatt 2014-07-10 08:48:32 UTC
Verified with AOO411m1(Build:9770)  -  Rev. 1603804
Comment 50 fanyuzhen 2014-07-14 08:53:21 UTC
It's verified fixed in build AOO411m1(Build:9770)  -  Rev. 1603804 2014-06-16 14:10:45 (Mo, 16 Jun 2014), on Win 7