Issue 114669

Summary: forms/qa/unoapi forms.OListBoxControl crash
Product: gsl Reporter: Stephan Bergmann <stephan.bergmann.secondary>
Component: codeAssignee: philipp.lohmann
Status: CLOSED DUPLICATE QA Contact: issues@gsl <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: current   
Target Milestone: OOo 3.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Stephan Bergmann 2010-09-22 11:02:47 UTC
At least on DEV300_m87 based CWS sb123subsequenttests, executing forms/qa/unoapi
once failed on
<http://termite.services.openoffice.org/buildbot/builders/Solaris-Sparc/builds/2476>
at

[...]
5: LOG> Execute: isTransparent()
5: Method isTransparent() finished with state OK
5: LOG> isTransparent(): PASSED.OK
5: ***** State for forms.OListBoxControl::com::sun::star::awt::XControl ******
5: Whole interface: PASSED.OK
5: ***************************************************************************
5: LOG> Log started 21.08.2010 - 13:51:26
5: checking: [forms.OListBoxControl::com::sun::star::accessibility::XAccessible]
is iface: [com.sun.star.accessibility.XAccessible] testcode:
[ifc.accessibility._XAccessible]
5: LOG> Execute: getAccessibleContext()
5: com.sun.star.lang.DisposedException: java.io.EOFException
5: LOG>         at
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge$MessageDispatcher.run(java_remote_bridge.java:158)
5: LOG> getAccessibleContext(): java.io.EOFException.FAILED
5: ***** State for
forms.OListBoxControl::com::sun::star::accessibility::XAccessible ******
5:
[forms.OListBoxControl::com::sun::star::accessibility::XAccessible::getAccessibleContext()]
is testcode: [getAccessibleContext()] - java.io.EOFException.FAILED
5: 
5: Whole interface: PASSED.FAILED
5:
****************************************************************************************
5: LOG> Log started 21.08.2010 - 13:51:40
5: checking: [forms.OListBoxControl::com::sun::star::awt::XTextLayoutConstrains]
is iface: [com.sun.star.awt.XTextLayoutConstrains] testcode:
[ifc.awt._XTextLayoutConstrains]
5: Creating: forms.OListBoxControl
5: LOG> Log started 21.08.2010 - 13:51:40
5: LOG> creating a textdocument
5: Office disposed
5: EE
5: 28636 Segmentation Fault - core dumped
5: Time: 209.404
5: There were 2 failures:
5: 1) test(org.openoffice.forms.qa.unoapi.Test)
5: com.sun.star.lang.DisposedException: java_remote_bridge
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge@13d9460 is disposed
5:      at
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge.checkDisposed(java_remote_bridge.java:702)
5:      at
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge.sendRequest(java_remote_bridge.java:621)
5:      at
com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.request(ProxyFactory.java:151)
5:      at
com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.invoke(ProxyFactory.java:133)
5:      at $Proxy10.loadComponentFromURL(Unknown Source)
5:      at util.SOfficeFactory.openDoc(SOfficeFactory.java:594)
5:      at util.SOfficeFactory.createTextDoc(SOfficeFactory.java:100)
5:      at mod._forms.OListBoxControl.initialize(OListBoxControl.java:65)
5:      at lib.TestCase.initializeTestCase(TestCase.java:79)
5:      at base.java_fat.getEnv(java_fat.java:465)
5:      at base.java_fat.executeTest(java_fat.java:254)
5:      at org.openoffice.Runner.run(Runner.java:240)
5:      at org.openoffice.forms.qa.unoapi.Test.test(Test.java:44)
5:      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
5:      at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
5:      at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
5:      at java.lang.reflect.Method.invoke(Method.java:585)
5:      at
org.junit.internal.runners.TestMethodRunner.executeMethodBody(TestMethodRunner.java:99)
5:      at
org.junit.internal.runners.TestMethodRunner.runUnprotected(TestMethodRunner.java:81)
5:      at
org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
5:      at
org.junit.internal.runners.TestMethodRunner.runMethod(TestMethodRunner.java:75)
5:      at org.junit.internal.runners.TestMethodRunner.run(TestMethodRunner.java:45)
5:      at
org.junit.internal.runners.TestClassMethodsRunner.invokeTestMethod(TestClassMethodsRunner.java:66)
5:      at
org.junit.internal.runners.TestClassMethodsRunner.run(TestClassMethodsRunner.java:35)
5:      at
org.junit.internal.runners.TestClassRunner$1.runUnprotected(TestClassRunner.java:42)
5:      at
org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
5:      at org.junit.internal.runners.TestClassRunner.run(TestClassRunner.java:52)
5:      at org.junit.internal.runners.CompositeRunner.run(CompositeRunner.java:29)
5:      at org.junit.runner.JUnitCore.run(JUnitCore.java:130)
5:      at org.junit.runner.JUnitCore.run(JUnitCore.java:109)
5:      at org.junit.runner.JUnitCore.run(JUnitCore.java:100)
5:      at org.junit.runner.JUnitCore.runMain(JUnitCore.java:81)
5:      at org.junit.runner.JUnitCore.main(JUnitCore.java:44)
5: 2) test(org.openoffice.forms.qa.unoapi.Test)
5: com.sun.star.lang.DisposedException: java_remote_bridge
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge@13d9460 is disposed
5:      at
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge.checkDisposed(java_remote_bridge.java:702)
5:      at
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge.sendRequest(java_remote_bridge.java:621)
5:      at
com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.request(ProxyFactory.java:151)
5:      at
com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.invoke(ProxyFactory.java:133)
5:      at $Proxy7.getServiceManager(Unknown Source)
5:      at org.openoffice.test.OfficeConnection.tearDown(OfficeConnection.java:109)
5:      at org.openoffice.forms.qa.unoapi.Test.tearDown(Test.java:40)
5:      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
5:      at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
5:      at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
5:      at java.lang.reflect.Method.invoke(Method.java:585)
5:      at
org.junit.internal.runners.BeforeAndAfterRunner.invokeMethod(BeforeAndAfterRunner.java:74)
5:      at
org.junit.internal.runners.BeforeAndAfterRunner.runAfters(BeforeAndAfterRunner.java:65)
5:      at
org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:37)
5:      at
org.junit.internal.runners.TestMethodRunner.runMethod(TestMethodRunner.java:75)
5:      at org.junit.internal.runners.TestMethodRunner.run(TestMethodRunner.java:45)
5:      at
org.junit.internal.runners.TestClassMethodsRunner.invokeTestMethod(TestClassMethodsRunner.java:66)
5:      at
org.junit.internal.runners.TestClassMethodsRunner.run(TestClassMethodsRunner.java:35)
5:      at
org.junit.internal.runners.TestClassRunner$1.runUnprotected(TestClassRunner.java:42)
5:      at
org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
5:      at org.junit.internal.runners.TestClassRunner.run(TestClassRunner.java:52)
5:      at org.junit.internal.runners.CompositeRunner.run(CompositeRunner.java:29)
5:      at org.junit.runner.JUnitCore.run(JUnitCore.java:130)
5:      at org.junit.runner.JUnitCore.run(JUnitCore.java:109)
5:      at org.junit.runner.JUnitCore.run(JUnitCore.java:100)
5:      at org.junit.runner.JUnitCore.runMain(JUnitCore.java:81)
5:      at org.junit.runner.JUnitCore.main(JUnitCore.java:44)
5: 
5: FAILURES!!!
5: Tests run: 1,  Failures: 2
5: 
5: dmake:  Error code 1, while making 'javatest'
failed in /space/termite/slavedir/Solaris-Sparc/workdir/forms/qa/unoapi
Comment 1 Stephan Bergmann 2010-09-22 12:03:00 UTC
worked around for now by disabling the affected tests as
<http://hg.services.openoffice.org/cws/sb123/rev/5cacd9a0a1e7>; please revert
when fixing this issue
Comment 2 philipp.lohmann 2010-09-23 11:18:53 UTC
target
Comment 3 Stephan Bergmann 2011-02-03 15:45:39 UTC
this *might* be issue 114718 (which can cause soffice to crash anytime after the
forms.OEditModel test)
Comment 4 Stephan Bergmann 2011-04-05 13:41:47 UTC
on CWS sb140 with the fix for bug 114718 included and the workaround from comment 1 undone this problem has not been observed again, so assuming it indeed is a duplicate and committed the undo as <http://hg.services.openoffice.org/cws/sb140/rev/4df84ed96f34>

*** This issue has been marked as a duplicate of issue 114718 ***