Issue 115136

Summary: cws tl77: numbering is lost after copy+paste
Product: Impress Reporter: clippka
Component: uiAssignee: AOO issues mailing list <issues>
Status: REOPENED --- QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: arielch, issues, jdaniel.alvaro
Version: OOo 1.0.0   
Target Milestone: 3.4.0   
Hardware: All   
OS: All   
Issue Type: TASK Latest Confirmation in: ---
Developer Difficulty: ---

Description clippka 2010-10-20 10:57:37 UTC
Open Impress, insert text shape, add some text, enable numbering (f.e. bullets)
for text, copy text, deselect shape, paste.

New shape with text is pasted, numbering is lost completly
Comment 1 thomas.lange 2010-11-08 11:46:54 UTC
.
Comment 2 thomas.lange 2010-11-18 15:20:26 UTC
Fixed in CWS tl77.
Comment 3 DanielAlvaro 2013-02-19 03:11:14 UTC
Hello,
Can  you  attach a image or your impress project? 

Regards,
Comment 4 Ariel Constenla-Haile 2013-02-19 03:20:04 UTC
(In reply to comment #3)
> Hello,
> Can  you  attach a image or your impress project? 

I guess the reporter is no longer working with OpenOffice.
Try to reproduce the bug with the steps in the bug Description

Note: comment 2 says that this bug was fixed in CWS tl77, a CWS was a kind of development branch in the Sun/Oracle era, this CWS was never integrated: http://hg.services.openoffice.org/cws/tl77

So you should be able to reproduce the bug in the latest stable release.
Comment 5 DanielAlvaro 2013-02-19 03:50:22 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Hello,
> > Can  you  attach a image or your impress project? 
> 
> I guess the reporter is no longer working with OpenOffice.
> Try to reproduce the bug with the steps in the bug Description
> 
> Note: comment 2 says that this bug was fixed in CWS tl77, a CWS was a kind
> of development branch in the Sun/Oracle era, this CWS was never integrated:
> http://hg.services.openoffice.org/cws/tl77
> 
> So you should be able to reproduce the bug in the latest stable release.

So, I need to reproduce it with the version of AOO 3.4.1 ?
Comment 6 Ariel Constenla-Haile 2013-02-19 04:15:36 UTC
(In reply to comment #5)
> So, I need to reproduce it with the version of AOO 3.4.1 ?

Try to reproduce it with the latest version you have installed (3.4.1, developer snapshot, or nightly build).

If you cannot reproduce it, change the status to CLOSED as FIXED.

The bug might have been fixed by in the meantime, although the CWS tl77 was never integrated.

I could reproduce it with the following steps:

1. open Impress
2. insert text shape
3. write some text, for example: Test
4. right click with the mouse to open the context menu
5. in the context menu select "Numbering/Bullets"
6. in the tab "Bullets" select the first bullet and press Ok
7. select the text and copy it with Ctrl + C
8. press Esc to leave the insertion of text
9. press Esc again to deselect the shape
10. Ctrl + V to paste the text

Result: the new text shape has the text I copied and pasted, but has no bullet.
Expected result: the new shape should have the same text and all formatting, including the bullets.
Comment 7 DanielAlvaro 2013-02-19 21:04:26 UTC
Hello,  
I reproduced the bug  with AOO 3.4.1 and you're right, but this happens also  in Miscrosoft Office. 

Regards,
Comment 8 Ariel Constenla-Haile 2013-02-20 02:31:41 UTC
Changed to TASK.

The task is: look the fix in the mercurial repository and see if it still applies and fixes the bug.

The repository is available at http://hg.services.openoffice.org/cws/tl77

hg clone http://hg.services.openoffice.org/cws/tl77