Issue 115357

Summary: oowriter - OpenOffice 3.1.1 crash after label File > New > Label
Product: Writer Reporter: skiver <tiziana.ferro>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.0.1   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description skiver 2010-11-02 14:37:32 UTC
When I try to create a label File > New > Label in oowriter, the application
crashes with the message: "Due to an unexpected error, crashed.
All the files you were working on will now be saved. ..etc.." 
This *only* happens when I want to use the "Labels" feature, none of the other
menu items cause this, & it doesn't matter if I'm using Writer or Calc. There
are no debugging reports I can add to this, as nothing else appears but that
"Unexpected error" message.
Comment 1 celtic_hackr 2010-12-17 20:19:59 UTC
I have the same problem. Same error message, same version 3.1.1. I am running
Mepis 32 bit version 8.5, using the community repos, on a triple core Phenom II
64 bit cpu. I cannot create new labels, but label documents from a previous
Linux desktops open, print and edit fine. I just can't make new ones. It crashes
right after opening the label selection screen, but before filling in the list.
I also have some packages installed from debian multimedia, but thet repos is
deselected unless I am installing a package from it.  That repo is never used
for updating from (due to the resulting conflicting packages). This install has
no conflicts resulting from te debian multimedia repo.
Comment 2 rjlapham 2010-12-30 01:32:33 UTC
*** Issue 115357 has been confirmed by votes. ***
Comment 3 rjlapham 2010-12-30 01:37:21 UTC
I have the same problem. Same error message, but on versions 3.2.0 running on
Kubuntu 10.04 AMD-64, and 3.2.1 running on Kubuntu 10.10. AMD-64. Same happens
with a 32bit version on my laptop.  I too can open old label documents (.odt).
Comment 4 dj6rx 2011-01-02 13:11:57 UTC
Same Problem here, writer crashes when doing: file - new - label.

OS SuSE 11.3
Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
Java HotSpot(TM) Server VM (build 17.1-b03, mixed mode)

java error log:
# A fatal error has been detected by the Java Runtime Environment:
#  SIGFPE (0x8) at pc=0xb75a6962, pid=7483, tid=3030353616
# JRE version: 6.0_22-b04
# Java VM: Java HotSpot(TM) Client VM (17.1-b03 mixed mode linux-x86 )
# Problematic frame:
# C  []  __divdi3+0xc2
# If you would like to submit a bug report, please visit:

---------------  T H R E A D  ---------------

Current thread is native thread

siginfo:si_signo=SIGFPE: si_errno=0, si_code=1 (FPE_INTDIV), si_addr=0xb75a6962

EAX=0x00000001, EBX=0xb38a9ff4, ECX=0x00000001, EDX=0x00000000
ESP=0xbfae7e30, EBP=0x000078a0, ESI=0x00000000, EDI=0x00000000
EIP=0xb75a6962, CR2=0x00000000, EFLAGS=0x00210246

Top of Stack: (sp=0xbfae7e30)
0xbfae7e30:   080a95a8 080a9ad0 00000000 00000000
0xbfae7e40:   00000000 00000000 00000000 000078a0
0xbfae7e50:   bfae7fd4 bfae7fc0 00000000 b328950e
0xbfae7e60:   000078a0 00000000 00000000 00000000
0xbfae7e70:   00000000 4d1f1699 109ee2d6 b38a9ff4
0xbfae7e80:   bfae7ff8 bfae7ea8 bfae7ff4 b2f9563b
0xbfae7e90:   bfae7ea8 000000a0 00000010 ffffffe0
0xbfae7ea0:   ffffff3f 00000018 0811b5e8 00dff7f0 

Instructions: (pc=0xb75a6962)
0xb75a6952:   00 eb bb 8d 76 00 85 c9 75 0a b1 01 31 d2 89 c8
0xb75a6962:   f7 f7 89 c1 89 f0 31 d2 f7 f1 89 c6 89 e8 f7 f1 

Stack: [0xbfa9c000,0xbfaec000],  sp=0xbfae7e30,  free space=12fbfae77b0k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  []  __divdi3+0xc2

I removed the OfficeOrg package as well as java and reinstalled all via SuSE
YAST. No difference. file new label crashes the writer.