Issue 115511

Summary: EPS export creates additional top-left/bottom-right pixels
Product: Draw Reporter: mizapf <michael.zapf>
Component: save-exportAssignee: sven.jacobi
Status: CLOSED NOT_AN_OOO_ISSUE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 3.2.1Keywords: needmoreinfo
Target Milestone: ---   
Hardware: All   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Test file (drawing)
none
EPS export (no tiff preview, no epsi, level 2, color, no compression) none

Description mizapf 2010-11-10 17:23:56 UTC
For some objects in the selection, exporting to EPS creates an additional pixel
in the top-left and one in the bottom-right corner of the bounding area of the
respective shape. I tested this with a filled borderless rhomboid; it also
happens for circles and presumably for all other shapes. The pixel in the
top-left and the one in the bottom-right corner have the same color as the
filling of the shape. The shapes are not modified but just taken from the tool
pallette as offered by OpenOffice.

The following excerpt is taken from the export of a rhomboid with no borderline
and filled green.

...
pum
0.02844 0.02844 s
0 -2004 t
/tm matrix currentmatrix def
tm setmatrix
-999 -999 t
1 1 s
0.003 0.503 0.003 c 1500 1000 m  3001 1000 l  2500 3001 l  1000 3001 l  1500 1000 l
p
1000 1000 m  1000 1000 l  p
3001 3001 m  3001 3001 l  p ef

0 2004 t
pom
count op_count sub {pop} repeat countdictstack dict_count sub {end} repeat
b4_inc_state restore
...

The two lines starting with "1000" and "3001" seem to be responsible for these
extra pixels. When I remove them (putting the ef in a separate line) the pixels
are gone.

Depending on the resolution of the output device, these additional pixels can be
well visible in an exported drawing.

Michael
Comment 1 wolframgarten 2010-11-11 09:21:25 UTC
Please attach a document for reproducing and the resulting eps. Please give
additional information about the selected options. Thanks.
Comment 2 mizapf 2010-11-11 11:33:38 UTC
Created attachment 74551 [details]
Test file (drawing)
Comment 3 mizapf 2010-11-11 11:35:45 UTC
Created attachment 74552 [details]
EPS export (no tiff preview, no epsi, level 2, color, no compression)
Comment 4 wolframgarten 2010-11-12 07:35:32 UTC
Your rhomboid has a borderlline. I can see a pixel in the lower right corner of
your eps but I cannot reproduce it even with your file.
Reassigned. @sj: any idea what this might be?
Comment 5 mizapf 2010-11-12 10:33:54 UTC
Did some more tests ... the effect seems to occur only for OOo 3.2.1 installed
from an OpenSUSE 11.3 repository. When I use the original version from the OOo
website, the effect is gone. 

Before closing the issue give me some more days to verify this on some more
platforms.

Michael
Comment 6 mizapf 2010-11-15 16:57:08 UTC
Seems to be a problem of the package OpenOffice.org_filters_optional from the
OpenSUSE build service, probably containing a defect EPS exporter. I guess I'll
have to report this issue there.

Using the installation package from openoffice.org the problem does not occur.
Comment 7 Mechtilde 2010-11-28 18:10:18 UTC
invalid -> closed